Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Uri uplod not working  (Read 3302 times)

0 Members and 1 Guest are viewing this topic.

feri_soft

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Uri uplod not working
« on: December 20, 2006, 05:15:34 pm »

When i try to upload a pic using the file upload its fine. But whe i try using the url/uri box i get 0 files were uploaded.
I read the upload trobleshooting but i cant find the answear to my problem...


Here is debug:

Code: [Select]
USER:
------------------
Array
(
    [ID] => 6249063477e88c91aa6380dc60422afc
    [am] => 1
    [liv] => Array
        (
            [0] => 553
            [1] => 594
            [2] => 593
            [3] => 634
            [4] => 615
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => feri_soft
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 2147483647
    [disk_min] => 2147483647
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 1
    [num_file_upload] => 10
    [num_URI_upload] => 10
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 1
    [priv_upl_need_approval] => 1
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 2147483647
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM gallery_filetypes; (0s)
    [1] => select * from gallery_plugins order by priority asc; (0s)
    [2] => delete from `young_gallery`.gallery_sessions where time<1166627615 and remember=0; (0s)
    [3] => delete from `young_gallery`.gallery_sessions where time<1165421615; (0s)
    [4] => select user_id from `young_gallery`.gallery_sessions where session_id=md5("a1ac2bc14a7b36307f8a448438739e81e10a1f02ec67dc4f751f2cc41429ec92"); (0s)
    [5] => select user_id as id, user_password as password from `young_gallery`.gallery_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `young_gallery`.gallery_users AS u INNER JOIN `young_gallery`.gallery_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `young_gallery`.gallery_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM gallery_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  gallery_usergroups WHERE group_id= 1 (0s)
    [10] => update `young_gallery`.gallery_sessions set time='1166631215' where session_id=md5('a1ac2bc14a7b36307f8a448438739e81e10a1f02ec67dc4f751f2cc41429ec92'); (0s)
    [11] => SELECT user_favpics FROM gallery_favpics WHERE user_id = 1 (0s)
    [12] => DELETE FROM gallery_banned WHERE expiry < '2006-12-20 19:13:35' (0s)
    [13] => SELECT * FROM gallery_banned WHERE (ip_addr='84.252.50.57' OR ip_addr='84.252.50.57' OR user_id=1) AND brute_force=0 (0s)
    [14] => SELECT aid, title FROM gallery_albums WHERE category < 10000 ORDER BY title (0s)
    [15] => SELECT aid, title FROM gallery_albums WHERE category='10001' ORDER BY title (0s)
    [16] => SELECT COUNT(*) FROM gallery_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
    [URI_array] => Array
        (
            [0] => http://youngdesigner.info/mkportal/templates/default/images/logo.gif
        )

    [control] => phase_1
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.0 - OK
------------------
mySQL version: 5.0.27-standard-log
------------------
Coppermine version: 1.4.8(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 5.0.24
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.1.2
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | exec, system, shell_exec, passthru, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, pfsockopen, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, escapeshellargHey, disk_free_space, disk_total_space, diskfreespace, highlight_file, chown, show_source, leak, chgrp, mysql_list_dbs | exec, system, shell_exec, passthru, popen, pclose, proc_open, proc_nice, proc_terminate, proc_get_status, proc_close, pfsockopen, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, escapeshellcmd, escapeshellargHey, disk_free_space, disk_total_space, diskfreespace, highlight_file, chown, show_source, leak, chgrp, mysql_list_dbs
file_uploads | On | On
include_path | .:/usr/local/php5fcgi/lib/php | .:/usr/local/php5fcgi/lib/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 10M | 10M
post_max_size | 8M | 8M
==========================
Page generated in 0.155 seconds - 17 queries in 0 seconds - Album set : ; Meta set: ;
Logged

Nibbler

  • Guest
Re: Uri uplod not working
« Reply #1 on: December 20, 2006, 06:31:35 pm »

url fopen is probably disabled on your server. Check with your host.

Also setting insanely high quotas and limits is known to cause issues, don't do that.
Logged

feri_soft

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Uri uplod not working
« Reply #2 on: December 20, 2006, 08:02:25 pm »

Hmm,
in the php info which coppermine gives url_fopen is on
Logged

Nibbler

  • Guest
Re: Uri uplod not working
« Reply #3 on: December 20, 2006, 08:07:42 pm »

The link you tried is 404. Also you need to update your gallery to lastest stable - 1.4.10
Logged

feri_soft

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Uri uplod not working
« Reply #4 on: December 26, 2006, 11:13:14 am »

updated to 1.40.10

again the same error....

help please

url:  youngdesigner.info/gallery


lang is bg but i think you can change it
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Uri uplod not working
« Reply #5 on: December 26, 2006, 11:22:29 am »

url fopen is probably disabled on your server. Check with your host.
Did you do as suggested?

URI upload sucks anyway imo. You (as admin) should use FTP-uploads plus batch-add anyway.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 21 queries.