Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: XP Web Publishing Wizard  (Read 21389 times)

0 Members and 1 Guest are viewing this topic.

KevinBeamer

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
XP Web Publishing Wizard
« on: November 26, 2006, 01:01:07 am »

Now that my bridge problem is solved, I have one lingering problem with the XP Web Publishing Wizard.

First and foremost, I apologize for the long post, as I've been through the docs and troubleshooting tips to no avail.

Our intent is to allow only registered users upload permissions to the public albums and no personal galleries

[gallery.reg]
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\PublishingWizard\PublishingWizard\Providers\Clann Na Cara Photo Gallery]
"displayname"="Clann Na Cara Photo Gallery"
"description"=""
"href"="http://clannnacara.com/gallery/xp_publish.php?cmd=publish"
"icon"="http://www.clannnacara.com/favicon.ico"

Admin can upload via XP wizard without error, provided you login to the gallery ahead of time.

After login the to gallery from test account, when using the XP wizard the error is:

"Welcome username,
Sorry but there is no album where you are allowed to upload pictures with this wizard."

With that being said, here's the troubleshooting steps I've performed with one file (63KB) with test account: PamBeamer cpg149 (not an admin)

Folder permissions validated to be 755.
Debug mode: yes everyone
In the group config, with the # of file upload boxes set to 1 and the # of URI upload boxes set to 0 for registered users, with the test account, http upload generates the following error:

"The selected album/file does not exist !"
File: /usrhome/xxxxx/public_html)/gallery/include/functions.inc.php - line 1315
However, the photo is added to the album.

There are two hits on that error in the forums, but they're not relevant.

If I increase the group config file boxes to 5, the http upload works perfectly, then prompts the user for an album.
At this point, the XP wizard continues to fail.

BBS / CPG info:

Coppermine install: http://www.ClannNaCara.com/gallery
Forum install: http://www.ClannNaCara.com/BB
Coppermine version: cpg1.4.9
Forum version: PHPBB (Bulletin Board)    v.2.0.21     
Test user account: PamBeamer cpg149

BridgeManager settings:
Forum URL:  http://www.ClannNaCara.com/BB
Relative path to your BBS's config file:  ../BB/ 
Use post-based groups?:  0 (no)
Cookie name/preifx: clannnacar_forum

There are only four albums set as follows:

Album can be viewed by: Everybody (public album)
Visitors can upload files: yes
Visitors can post comments: yes
Visitors can rate files: yes

Group settings:

Registered:

quota 1024

permissions:
rating: yes
ecards: yes
comments: yes

public album upload"
allowed: yes
approval: no

personal gallery
allowed: no
approval: no

upload method:
# of boxes: fixed
file upload: 1
uri upload: 0


Guests:

quota 0

permissions:
rating: yes
ecards: no
comments: no

public album upload"
allowed: no
approval: yes

personal gallery
allowed: no
approval: yes

upload method:
# of boxes: fixed
file upload: 1
uri upload: 0
« Last Edit: November 29, 2006, 07:44:09 pm by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Logged

KevinBeamer

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: XP Web Publishing Wizard
« Reply #2 on: November 27, 2006, 02:55:20 am »

GauGau,

Thanks for inviting me to review the upload_trouble doc again.

Is there a specific step in the above task I've failed to complete ?

debug is on for everyone
all groups set to "single file upload"
hits on error message in forums are not relevant
link to site included
test account included

I think there is a misleading error message when the file upload boxes is set to 1 as the file is added to the album.
When the file upload box is set to 2, no error message exists.


In the group config, with the # of file upload boxes set to 1 and the # of URI upload boxes set to 0 for registered users, with the test account, http upload generates the following error:

"The selected album/file does not exist !"
File: /usrhome/xxxxx/public_html)/gallery/include/functions.inc.php - line 1315
However, the photo is added to the album.

There are two hits on that error in the forums, but they're not relevant.

If I increase the group config file boxes to 5, the http upload works perfectly, then prompts the user for an album.
At this point, the XP wizard continues to fail.


Please advise...

KB
Logged

KevinBeamer

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: XP Web Publishing Wizard
« Reply #3 on: November 27, 2006, 03:16:09 am »

Did you happen to upload a photo of a blue car to the MISC album ?

KB
Logged

Nibbler

  • Guest
Re: XP Web Publishing Wizard
« Reply #4 on: November 27, 2006, 04:23:51 am »

That was me. I didn't notice this was an XP publisher issue. I don't use windows so I can't really suggest anything to help you.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: XP Web Publishing Wizard
« Reply #5 on: November 27, 2006, 04:40:56 am »

I don't have Windows XP neither, sorry. Maybe someone else could look into this.
Logged

KevinBeamer

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: XP Web Publishing Wizard
« Reply #6 on: November 27, 2006, 02:51:22 pm »

OK, thanks.  And by the way, that's a cool looking car !

Based on other threads about the XP publishing wixard, I figured that might be your answer
 
When we (the community) run into problems that the forums have no solutions for, we turn to you for support.
May I suggest that if you don't have the resources to support the initiative, it be removed from the offering ?

Based on the number of posts about the XP publishing wizard, it's clearly something the public would like to work better.  I'm not suggesting either product is at fault, but if it's a feature in your software, people will use it and expect some degree of support if it doesn't perform.

In the interest of time, we're going to drop the option to use the XP publishing wizard with our CPG.

Regarding the error message when the file upload box is set to 1, I believe that's something your team should look more into as it the error goes away if only the file upload boxes is increased to 2.  Contact me by email if you would like to debug and / or reproduce it...


Keep up the good work on a very good product !!!


KB
Logged

Nibbler

  • Guest
Re: XP Web Publishing Wizard
« Reply #7 on: November 27, 2006, 03:17:57 pm »

There are lots of people who use it, we can't just remove it because some people have problems some of the time. From reading the code, it only allows users to upload into user galleries (ie. not public albums), which you do not have enabled on your gallery.

Your second issue has been fixed for the next version of Coppermine.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: XP Web Publishing Wizard
« Reply #8 on: November 27, 2006, 05:06:44 pm »

When we (the community) run into problems that the forums have no solutions for, we turn to you for support.
May I suggest that if you don't have the resources to support the initiative, it be removed from the offering ?
Nibbler and I don't have Windows XP. The Sanisoft team doesn't have Windows XP afaik. But this doesn't mean that the other supporters could not help you, or other community members - there are still a lot of supporters who actually use Windows XP. When people report issues with XP Publisher, we're often able to track and fix their issues by looking into it, even if we don't have Windows XP (as their problem often lies somewhere else). That's why Nibbler and I replied to this thread. But at a certain stage, we can't look into this any more and have to ask for other supporters to jump in. Nothing wrong with this in my eyes.

As Nibbler suggested: it would be silly to remove XP Publishing wizard support from Coppermine core, as it works without issues for many users. Don't let yourself get mislead into believing that just because there are some reports and support requests on XP Publisher that things don't work as expected and the feature in itself doesn't work. There are postings about every aspect of Coppermine on this board, as this is a quite busy board with a lot of postings. Usually, people who don't have issues don't post on a support board. Suggesting the removal of the XP Publishing wizard therefor is nonsensical.
Take a look at boards that deal with Microsoft Windows: there's a whole industry dedicated to support and maintenance of Windows-driven computers; and you can find millions of postings on the internet from people who request support for particular Windows components. Should Microsoft remove all features from future versions of Windows just because there are some people who have trouble with them? If yes, then the next Windows release would probably consist of notepad and minesweeper in two fixed windows in EGA resolution. But guess what: Microsoft will add even more features to future versions, even though some users are bound to have issues with it.

Joachim
Logged

KevinBeamer

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: XP Web Publishing Wizard
« Reply #9 on: November 29, 2006, 07:36:53 pm »

Thanks for your candid responses.  I can appreciate your positions on each point.   :)

From reading the code, it only allows users to upload into user galleries (ie. not public albums), which you do not have enabled on your gallery.

I did not know (or find in the DOCS) anything about general users not having the ability to use the XP publishing wizard into public albums.

Thanks again for your support and keep up the good work on a very good product !!!

KB

PS - our problem is solved now that we've learned our users can't use the XP wizard to upload into public albums.
Logged
Pages: [1]   Go Up
 

Page created in 0.028 seconds with 21 queries.