Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Uploading and Batch adding files problems  (Read 4062 times)

0 Members and 1 Guest are viewing this topic.

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Uploading and Batch adding files problems
« on: November 23, 2006, 08:00:53 pm »

Hi, well i installed the forum and changed the new theme. Everything works fine but when i upload my pictures ( both ways in http and ftp ) but it didnt work. I found my pictures files in forder user ( upload by http ) but it wasnt displayed when i finished my upload and also my folder i upload by ftp appear in batch area but no pictures display. I have read carefully the docoment and did everything but my pictures still dont display. So plz help.
« Last Edit: November 25, 2006, 04:47:03 am by GauGau »
Logged

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Unable to create thumbnail or reduced size image.
« Reply #1 on: November 23, 2006, 08:10:20 pm »

What does that mean ? Do i have to resize my pictures before i upload them ?

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Problems
« Reply #2 on: November 23, 2006, 08:24:37 pm »

After long time trying to fix my problems, i remove my gallery and then reinstall it with default them but i still got the same result. No thumbnails or pictures display.. U can see it in this pictures below. I am wondering what is wrong with my gallery. Plz, help

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Re: Problems
« Reply #3 on: November 23, 2006, 10:14:47 pm »

ok, i did my best. I read over and over again the document and did everything and also read all thread in this forum but i still got the same problem. There is one thing i havent checked is that GD2 or ImageMagick. I dont know what kind of that i used . Plz help me..

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Uploading and Batch adding files problems
« Reply #4 on: November 24, 2006, 05:58:19 am »

1) Coppermine is not a forum.
2) Do exactly as suggested in http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble
3) Not related to pnCPG, moving accordingly.
4) Merged your three similar threads that all deal with uploading. Apparently, you haven't read the docs carefully enough. Don't double-post!
« Last Edit: November 24, 2006, 06:04:16 am by GauGau »
Logged

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Re: Uploading and Batch adding files problems
« Reply #5 on: November 24, 2006, 10:17:39 pm »

Hi GauGau, ur nickname sounds like Vietnamese to me, but it doesnt any matter anyway. what made me really confused is that i install another gallery ( which belongs to gallery ) and it works fine. I really prefer compermine so i wanna user it as my gallery so that's why i am here again to fixing my problem. I wrote that i read carefully over and over again the doc meant i did read it many times in those topic that related to my problem ( such as uploading, permission , ect ) ..But i am sorry for posting wrong.  Come back to the problem i have. Here is what i have been done and tried
- First, i tried to upload by http with my admin acc .
I set my config with maintenaince setttings is enable debug mode for everyone ( I left the display notices in debug mode is no). And then i change the group ( allow album pictures upload, personal gallery upload with upload methods is single upload which mean 1 picture each upload ).
After that i check my config for image view and thumbnail views to see the size which i prefer to display pictures ( which i just left as default ).
Finally i check  this
1. max_input_time- 60 seconds is the default time limit for uploading files.

This time limit includes the time it takes for the files to upload, so if you exceed this limit, the file will not even parse, and the browser will not get a response. You can workaround this by trying to upload smaller or fewer files, or you can try uploading over broadband. The best solution, of course, is to increase the time limit to something more in line with your needs.

2. upload_max_filesize - 2MB is the default limit for individual files.

3. post_max_size - 8MB is the default limit for post requests.

4. memory_limit - 8MB is the default size.

5. PHP's LimitRequestBody - 512KB default limit. (mainly an issue on Redhat/Apache systems.  Found in /etc/http/conf.d)

In general, upload_max_filesize < post_max_size < memory_limit in order for uploads to function properly. Coppermine may warn you if a file exceeds upload_max_filesize, but it cannot warn you if the total size of all the files exceeds the post limit or the memory limit.

6. file_uploads - This determines whether or not PHP will allow file uploads. It must be set to 'On'.

7. upload_tmp_dir - This specifies the temporary directory where PHP stores uploaded files.

The most common issue caused by this setting is an open_basedir warning.  In this situation, your server administrator has restricted the files that PHP can work with to a certain directory.  If he does not create and specify a temporary directory within the open_basedir restriction, PHP will attempt to use the OS temporary directory, and it will be rebuffed by the open_basedir restriction.

8. allow_fopen_url - This controls PHP's ability to read files using URL/URIs.  If it is disabled, Coppermine will not be able to upload from URLs


That's what i did but the result of displaying picture is error

- Second i tried to upload with ftp.
I created a folder in album folder after reading this : do not create folders or ftp upload to the userpics- nor to the edit-folder by ftp: these folders are used by coppermine internally and must not be used for any other purpose! Folder names must not contain dots. We also highly recommend refraining from the use of any other special characters - use only a-z, numbers and - (dashes) or _ (underscores) to fill blank spaces. Make sure to upload in binary or auto-mode
Then I set the mode of folder to 777
After that i upload some test pictures
I check again the mode and permision of my albums
Finally i go batch add pictures And i got the result of no display pictures


What else i can do plz, Help
I do want to work this because Copermine looks great and it took me so long to design a new template for my gallery
I would love to creat a admin acc for u to help me fixing http uploading  at http://nhimbi.grinhost.net/gallery
So plz respond me as soon as possible


nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Re: Uploading and Batch adding files problems
« Reply #6 on: November 24, 2006, 10:45:35 pm »

When i upload by http it appeared with error


The file 'albums/userpics/IMG_0752.jpg' can't be inserted in the album

Unable to create thumbnail or reduced size image.

File: /home/nhimbi/public_html/gallery/db_input.php - Line: 402

And i go find the line 402 but i didnt see any code
Here is the code for line 401 and 403
   $category = FIRST_USER_CAT + USER_ID;

            $query = "UPDATE {$CONFIG['TABLE_ALBUMS']} SET title='$title', description='$description', thumb='$thumb',  comments='$comments', votes='$votes', visibility='$visibility', alb_password='$password', alb_password_hint='$password_hint',keyword='$keyword' WHERE aid='$aid' AND category='$category' LIMIT 1";

        }

 Plz help me futher to fix this problem

nhim

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
    • NhimBi
Re: Uploading and Batch adding files problems
« Reply #7 on: November 24, 2006, 11:01:47 pm »

Hey, i finnally find it. I used Imagegick which is not competiable for my gallery. I changed it to GD and now it worked. Thx for helping ^_^
I am so happy now
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.