Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Registered user uploads get "Impossible to move" error  (Read 3582 times)

0 Members and 1 Guest are viewing this topic.

hg_sup1

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Registered user uploads get "Impossible to move" error
« on: November 09, 2006, 04:46:15 am »

My gallery is located here ... http://www.highgroundindustries.com/SLMGallery/ [Edit GauGau] Warning: link not worksafe [/Edit]

I have followed the mandatory steps. The group settings etc. are set.

The test user account is...

username: testuser
password: testpass

Problem: registered user can not upload files to their albums via http. admin, batch upload still works but I can not upload via http to my own album when loggrd in as admin.
« Last Edit: November 14, 2006, 09:33:19 pm by Nibbler »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Registered user uploads get "Impossible to move" error
« Reply #1 on: November 09, 2006, 04:59:42 am »

You're running cpg1.4.3, which is completely outdated and has serious security flaws. Upgrade to the most recent version (currently cpg1.4.10) asap.

When asking for support on uploading issues, do exactly as suggested in the upload troubleshooting section of the docs.

When posting a link to an adult site, make sure to post a warning with it in the future. I edited your posting accordingly.
Logged

hg_sup1

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Registered user uploads get "Impossible to move" error
« Reply #2 on: November 09, 2006, 05:20:33 am »

Yes, it's out of date. I am afraid to run the update because it is critical that the gallery continue running properly. I have had some problems in the past. Also my hosting company is still offering 1.4.9 as the next update. My control panel lists my current ver. as 1.3.3 so I don't trust it.

If there are any experts out there that can help me create a proper backup then upgrade the gallery (and my skins) to the latest version I would be willing to pay them for their time.



 
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Registered user uploads get "Impossible to move" error
« Reply #3 on: November 09, 2006, 05:36:02 am »

Don't use any versions provided by your webhost - Fantastico and similar auto-installers are buggy and outdated and known to cause issues. Upgrade as suggested in our docs.
Back up the files using FTP and the database using mySqlDumper or phpMyAdmin before upgrading, it's dead easy. If you want paid help, start a new thread on the board "Looking for Freelancers / Paid help" after having read the sticky thread "sub-board rules, read first!" there.

What's the use of sticking to an old, outdated version if you don't even have a backup? Do you think it's better to have your gallery hacked instead of risking the upgrade? Being afraid of upgrading doesn't make sense.
Logged

hg_sup1

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Registered user uploads get "Impossible to move" error
« Reply #4 on: November 09, 2006, 06:02:20 am »

Right. I would like to be more in control so I will do this upgrade manually however...

Is there anything you can tell me about the upload issue I am having. (other than that the upgrade will fix it) I would like to see it work again if only for the learning experience. Plus I will need some time to perform the upgrade properly.

The gallery is bridged with a phpbb2 forum located at ... http://www.highgroundindustries.com/Streetlow/

Does this matter? Can I still do the update?

Thanks for your help.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Registered user uploads get "Impossible to move" error
« Reply #5 on: November 09, 2006, 06:11:12 am »

I already told you what to do if you want help:
When asking for support on uploading issues, do exactly as suggested in the upload troubleshooting section of the docs.

However, I'm reluctant to look into issues that might be solved by upgrading. There's a reason why we release new versions: they fix issues that existed in previous versions. Uploading issues might be fixed as well.
Logged

hg_sup1

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Registered user uploads get "Impossible to move" error
« Reply #6 on: November 14, 2006, 09:18:16 pm »

Okay All the galleries were fixed by the upgrades. I did have backups. I was more concerned with the themes. I'm getting some help to upgrade those. this issue is solved.

Thanks
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.