Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: bridge problem phpbb 2.0.21 cpd 1.4.10  (Read 3716 times)

0 Members and 1 Guest are viewing this topic.

dartagnan32

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
  • Asia is a wonderful place
    • Asian Addict the ultimate asian community
bridge problem phpbb 2.0.21 cpd 1.4.10
« on: November 11, 2006, 09:05:50 pm »

I have the following issue when trying to bridge coppermine and phpBB2.0.21: login redirects me to phpbb i login, go back to cpg and actually can't login. I saw in this forum this was usually due to a cookie problem but I have the feeling i already tried to change everything. But obviously i didn't as it can't work.

Coppermine install: http://dartagnan.9999mb.com/pictures
Forum install: http://dartagnan.9999mb.com/forum
Coppermine version: cpg1.4.10
Forum version: phpbb2.0.21
[]

BridgeManager settings:
Forum URL:  http://dartagnan.9999mb.com/forum
Relative path to your BBS's config file:  ../forum/
Use post-based groups?:  1
Cookie name/preifx : phpbb2mysql

in the forum, you can check cokie settings with the same admin name/password.  The cookie is phpbb2mysql (tried also 9999mb_forum while changing it in the bridging info because the mod cookie.php from phpbb website proposed me to change it so),  cookie domain is .9999mb.com (but tried 9999mb.com,  dartagnan.9999mb.com, .dartagnan.999mb.com),, the cookie path is /forum

I guess the answer is trivial but i'm lost now cause i tried to change a lot of things.
So any help would be appreciated
thanks a lot
« Last Edit: November 11, 2006, 10:43:48 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: bridge problem phpbb 2.0.21 cpd 1.4.10
« Reply #1 on: November 11, 2006, 10:32:09 pm »

Cookie path MUST be '/' as explained in the manual. Posting admin data on a public board is not a very bright idea, neither is configuring your board with a cookie domain of .9999mb.com - you are allowing anyone on your free host to read and alter your users' cookies.
Logged

dartagnan32

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
  • Asia is a wonderful place
    • Asian Addict the ultimate asian community
Re: bridge problem phpbb 2.0.21 cpd 1.4.10
« Reply #2 on: November 11, 2006, 10:40:00 pm »

Oops ok thanks a lot now it works ;-)
I changed the domain to .dartagnan.9999mb.com i suppose this would be better?

thanks again
Logged

Nibbler

  • Guest
Re: bridge problem phpbb 2.0.21 cpd 1.4.10
« Reply #3 on: November 11, 2006, 10:43:32 pm »

Much better.
Logged

NitroRules

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 101
Re: bridge problem phpbb 2.0.21 cpd 1.4.10
« Reply #4 on: January 25, 2007, 03:26:43 pm »

I had the same problem.

But it didn't work just with setting the cookie path in phpBB to
Code: [Select]
/
The clue was to edit the cookie domain in the phpBB settings. Former I had
Code: [Select]
www.mydomain.com
I changed it to
Code: [Select]
.mydomain.com
Now it works. So just delete the "www" (not the dot) if there are still some problems although having set the cookie path to "/"
Logged
Florian
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.