Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 [3] 4 5 6 7 ... 22   Go Down

Author Topic: Displaying videos from Youtube in Coppermine.  (Read 372441 times)

0 Members and 1 Guest are viewing this topic.

Justttt

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 170
    • Trippy-ILLusion.Co.Uk
Re: Displaying videos from Youtube in Coppermine.
« Reply #40 on: December 10, 2006, 04:09:45 pm »

how cpomes when i have added this code i get this error

Parse error: syntax error, unexpected $end in /home/www/trippyEUi/album/upload.php on line 2775

but i dont have this line ??.

i have reveiwed the code and dont see any mistakes.
Logged
J U S T T T T

Justttt

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 170
    • Trippy-ILLusion.Co.Uk
Re: Displaying videos from Youtube in Coppermine.
« Reply #41 on: December 10, 2006, 04:53:36 pm »

it wil not let me edit my last post , but that problem is solved i just took out the first step ..
but now when i try to upload a youtube vid i get this error

Fatal error: Call to undefined function: file_put_contents() in /home/www/trippyEUi/album/upload.php on line 2087
Logged
J U S T T T T

Nibbler

  • Guest
Re: Displaying videos from Youtube in Coppermine.
« Reply #42 on: December 10, 2006, 05:03:18 pm »

There was a typo in the first step, try again.
Logged

Justttt

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 170
    • Trippy-ILLusion.Co.Uk
Re: Displaying videos from Youtube in Coppermine.
« Reply #43 on: December 10, 2006, 07:58:41 pm »

right i have that bit sorted now . but when i upload a youtube link . it only becomes a jpg. i have read this topic and still no help . if i upload the theme.php could sombody please hlep me. thanks in advance
Logged
J U S T T T T

Nibbler

  • Guest
Re: Displaying videos from Youtube in Coppermine.
« Reply #44 on: December 10, 2006, 09:40:55 pm »

You have not applied the mod to that file as far as I can see.
Logged

Justttt

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 170
    • Trippy-ILLusion.Co.Uk
Re: Displaying videos from Youtube in Coppermine.
« Reply #45 on: December 11, 2006, 09:03:52 am »

ahh right i see. i have now added the code to the theme.php . but now instead of a jpg. i get a white box with nothing there  ???
Logged
J U S T T T T

Nibbler

  • Guest
Re: Displaying videos from Youtube in Coppermine.
« Reply #46 on: December 11, 2006, 01:34:06 pm »

Looks ok to me, do you have a flash plugin installed?
Logged

enver

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
    • health
Re: Displaying videos from Youtube in Coppermine.
« Reply #47 on: December 13, 2006, 01:02:42 pm »

thanks  ;)

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Displaying videos from Youtube in Coppermine.
« Reply #48 on: December 13, 2006, 08:14:11 pm »

Morning,

I'm tryng to play with this mod on Funpic.org
Unfortunately, i get an error just after enter video's URL (like h t t p://www.youtube. com/watch?v=kritugh8ks

CPG said :
0 uploads were successful.
YT errors:
URI                                                  Error message
1. h t t p://www.youtube. com/watch?v=kritugh8ks

And no Error message

Perhaps Funpic.org do not have fopen in action !

Phpinfo() said : allow_url_fopen   Off
Bad luck !

PYAP
« Last Edit: December 13, 2006, 08:24:14 pm by PYAP »
Logged

sigepjedi

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 111
Re: Displaying videos from Youtube in Coppermine.
« Reply #49 on: December 15, 2006, 02:27:16 am »

I use the hardwire theme, and i know you said to copy the code from the sample theme.php, but there is a considerable difference in the two...

simply replacing it doesnt work... adding the function doesnt work, and there isnt any similar functionality location to add it into on my hardwired theme.php...

please advise!
Logged

sigepjedi

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 111
Re: Displaying videos from Youtube in Coppermine.
« Reply #50 on: December 15, 2006, 02:38:52 am »

I missed your post on page 2... added that function before ?> and atleast now my theme file saved works..

Though, upon upload I got the following:

Quote
0 uploads were successful.   

Error Report
The following uploads encountered errors: 

YT errors: 
URI Error message
1. http://www.youtube.com/watch?v=7PZK8koGcmM

4Missing required parameter

Logged

mrairbrush

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Displaying videos from Youtube in Coppermine.
« Reply #51 on: December 25, 2006, 06:20:44 pm »

It works fine but i dont have a file names themes.php, online a file names themes.inc.php in includes.
No youtube uploads working but no jpeg upload. when i upload an jpeg and change the site to order the jpeg to albums there an upload search button again.

Logged

mrairbrush

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Displaying videos from Youtube in Coppermine.
« Reply #52 on: December 25, 2006, 06:33:11 pm »

The error is in the upload.php
When i works with the original file the upload of jpeg is ok. With the edit file for youtube it works wrong an i cant upload jpegs
Logged

Topfrog007

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Displaying videos from Youtube in Coppermine.
« Reply #53 on: December 27, 2006, 12:33:01 am »

Hello Nibbler! First off a big thanks to you for producing this. I've searched for what seems like ages trying to find some way that I could have a "YouTube gallery" on my site. I was just about to purchase a program when I found this thread.

I have Coppermine and decided to give this thread a shot. I edited the upload.php and theme.php to your specifications. When I go to upload a file, and put in the entire youtube address I get this error " HTTP/1.0 200 OK ". I can't seem to figure out what is causing this problem.

Can you help me?

Excellent job on Coppermine BTW.
Logged

Nibbler

  • Guest
Re: Displaying videos from Youtube in Coppermine.
« Reply #54 on: December 27, 2006, 12:50:23 am »

Did you put the link into one of the 2 new youtube boxes or the standard URI boxes?
Logged

Topfrog007

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Displaying videos from Youtube in Coppermine.
« Reply #55 on: December 27, 2006, 07:15:12 am »

Hmm... I don't see that... All I have is the File Uploads: and the URI/URL uploads.
I'm guessing I missed something in the upload.php??
Logged

Topfrog007

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Displaying videos from Youtube in Coppermine.
« Reply #56 on: December 27, 2006, 08:46:00 am »

Ok I went over it and got it the Youtube upload options to show up. Whenever I try to upload I get a blank box in the error message, but it says upload unsuccesful. Any thoughts?

And thanks for your time.
Logged

Topfrog007

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Displaying videos from Youtube in Coppermine.
« Reply #57 on: December 27, 2006, 09:06:28 am »

I've gone through the tutorial twice since my last post, re-done everything and still can't figure out what the problem is. When I try to submit a Youtube video I get an upload unsuccessful but the error box is just blank. The site is www.Politicalrundown.com ... Is it possible to just post the correct upload.php and theme.php files?

Regards,
Preston
Logged

Topfrog007

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Displaying videos from Youtube in Coppermine.
« Reply #58 on: December 30, 2006, 08:55:37 am »

Please will someone help me get my gallery working? I'm willing to pay a small ammount... contact me through PM please!!
Logged

mrairbrush

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Displaying videos from Youtube in Coppermine.
« Reply #59 on: January 02, 2007, 06:34:39 pm »

can you updating or extend this hack for playing videos from googlevideo or myvideo?
Youtube needs an developerid, googlevideo also.
This were great
Logged
Pages: 1 2 [3] 4 5 6 7 ... 22   Go Up
 

Page created in 0.168 seconds with 19 queries.