Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Pb affichage {SUB_MENU} après modif de template.html  (Read 9351 times)

0 Members and 1 Guest are viewing this topic.

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Pb affichage {SUB_MENU} après modif de template.html
« on: October 04, 2006, 11:51:04 pm »

Bonsoir à tous,

J'utilise depuis peu Coppermine (version 1.4.9) et j'en suis ravi.

Je tiens tou d'abord à remercier tous ceux qui qui on participé à sa mise au point ainsi que ceux qui contenu de le maintenir à jour et de le faire évoluer. C'est vraiment LE code pour créer facilement un album photo collaboratif.

Mais afin de le personnaliser un tout petit peu, je voudrais modifier une thème proposé.

Je suis donc parti du thème "connections" que j'ai modifié pour qu'il s'affiche sur toute la largeur de la page.
Pour cela j'ai donc modifier les fichiers template.html et style.css.

Afin de reproduire les bordures, j'ai mis deux petites images de chaque coté de la page, à la place d'une seule image en fond.
Pour cela j'ai du créer un tableau à 3 colonnes, la première contient l'image de gauche, la deuxième : le contenu de la page, et la troisième : l'image de gauche.

Jusque là pas de problème majeur.
Mais comme auparavant les largeurs des différentes parties (main, content, sidebar, ...) étaient fixes, et que maintenant elles peuvent être variables j'ai du refaire un sous tableau dans la deuxième colonne. Cela me permet de fixer les largeur des deux parties "content" et "sidebar" (respectivement 85 et 15%).
Et c'est la que vient le problème : tout les menus s'affichent correctement sauf {SUB_MENU}.
Je ne vois pas du tout d'où vient le problème, car les menus qui se situe dans l'autre partie du sous-tableau fonctionne parfaitement.

Pourriez-vous m'éclarer sur ce problème.

Voici l'adresse de mon site (avec le thème en cours de modification) : http://provost.julien.free.fr/Album2/index.php?theme=connect
Et voici le répertoire contenant les fichiers relatifs à ce thème : http://provost.julien.free.fr/Album2/themes/connect/

Merci d'avance.

--
Julien PROVOST
« Last Edit: October 14, 2006, 06:20:28 pm by Frantz »
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #1 on: October 05, 2006, 07:36:47 am »

Bonjour,

dans le fichier template.html vous avez deux fois la balise {sub_menu}
je ne sais pas si c'est ce qui cause problème (pas testé) mais déjà c'est pas normal.
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #2 on: October 05, 2006, 07:46:09 am »

Bonjour,

Excusez-moi, en effet j'aurai ddu enlever le {sub_menu} qui était en dessous de {vanity}.

En fait, même sans celui-là, ça ne marche pas.
J'en avais mis un là pour tester si il marchait à cet endroit.

Donc, voilà je l'ai supprimer, et la page est maintenant telle que je la voudrait.

Merci
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #3 on: October 05, 2006, 08:24:08 am »

C'est une impression ou la galerie est intégrée à un blog ?
Si oui, le problème peut venir de là.
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #4 on: October 05, 2006, 11:24:06 am »

Bonjour,

Dans votre-CPG/themes/connections/TEMPLATE.HTML,
recherchez :
Code: [Select]
<h2>Gallery Menu</h2>

                {SUB_MENU}

et essayez
Code: [Select]
<h2>Gallery Menu</h2>
<div>{SUB_MENU}</div>

PYAP
« Last Edit: October 05, 2006, 11:35:56 am by PYAP »
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #5 on: October 05, 2006, 11:32:27 am »

Non, il n'y a pas de blog.

Pourquoi dites-vous ça?
Qu'y a-t-il de spécial par rapport aux autres galleries?

J'ai juste copier le dossier coppremine sur mon ftp, et fait l'installation, ainsi que l'ajout de quelques photos et commentaires, mais rien de plus.
Il n'y a aucun lien vers l'extérieur.

Par contre je viens d'essayer en mettant le menu de l'autre coté, et ça marche.
Voyez, ça marche http://provost.julien.free.fr/Album2/index.php?theme=connect2
et ça marche pas http://provost.julien.free.fr/Album2/index.php?theme=connect

Etrange, non? Et pourtant j'ai juste inversé les deux parties du tableau.
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #6 on: October 05, 2006, 11:34:09 am »

Bonjour,

Dans votre-CPG/themes/connections/TEMPLATE.HTML,
recherchez :
Code: [Select]
<h2>Gallery Menu</h2>

                {SUB_MENU}

et essayez
Code: [Select]
<h2>Gallery Menu</h2>
<div>{SUB_MENU}</div>

PYAP


J'ai essayé, mais sans succès.
Par contre j'ai soumis une autre information, cf. post précédent
« Last Edit: October 05, 2006, 11:36:10 am by PYAP »
Logged

Pascal YAP

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #7 on: October 05, 2006, 11:37:28 am »

Weird !  ???

Avez-vous "retouché" le fichier votre-CPG/themes/connections/THEME.PHP ?

PYAP
Logged

François Keller

  • Moderator
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #8 on: October 05, 2006, 11:40:07 am »

Quote
Non, il n'y a pas de blog.

Pourquoi dites-vous ça?
Qu'y a-t-il de spécial par rapport aux autres galleries?
Parce que j'avais pas bien lu le footer ou il étatit question de doclear  :-\

Sinon pour votre problème, il doit s'agit d'une balise mal fermée ou quelque chose comme ça
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #9 on: October 05, 2006, 11:49:52 am »

Weird !  ???

Avez-vous "retouché" le fichier votre-CPG/themes/connections/THEME.PHP ?

PYAP

Non pas du tout, je viens même de retester en remettant le fichier theme.php du thème connections (les themes en cours de modif s'appellent connect, connect2, et connect3, afin de visualiser en même temps plusieurs versions)
Logged

Titooy

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 736
    • under construction...
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #10 on: October 05, 2006, 11:57:39 am »

Je n'ai pas encore analysé en profondeur le système de thèmes de Coppermine mais à première vue, {SUB_MENU} doit être placé avant {GALLERY} sinon il n'est pas interprété.
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #11 on: October 05, 2006, 12:01:37 pm »

Parce que j'avais pas bien lu le footer ou il étatit question de doclear  :-\

Sinon pour votre problème, il doit s'agit d'une balise mal fermée ou quelque chose comme ça

Je viens de vérifier encore une fois mon fichier template.html, mais toutes les balises sont fermées (j'y ai d'ailleurs fait attention lors de l'édition en faisant des décalages dès que j'ouvrais une nouvelle balise.)
De plus, dans ce cas, pourquoi cela marcherait lorsque je modifie l'ordre des colonnes.

Dans le cas qui marche : connect2 , j'ai :
Code: [Select]
<td width="15%">       
  <div id="sidebar">
    ...
    ...
  </div>
</td>
<td width="85%">
  <div id="content">
    ...
    ...
  </div>
</td>

et dans l'autre : connect , j'ai :
Code: [Select]
<td width="85%">
  <div id="content">
    ...
    ...
  </div>
</td>
<td width="15%">       
  <div id="sidebar">
    ...
    ...
  </div>
</td>

Donc les balises ouvertent et fermées ne changent pas.

Apparement, ce problème n'est pas si simple que ça à résoudre.
Merci de votre aide, et de vous penchez sur la question
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #12 on: October 05, 2006, 12:03:48 pm »

Je n'ai pas encore analysé en profondeur le système de thèmes de Coppermine mais à première vue, {SUB_MENU} doit être placé avant {GALLERY} sinon il n'est pas interprété.

Ok, merci, je vais essayé dans des cas tout simples, pour voir.
Donc dans ce cas, je mettrai mon menu à gauche de la page.

Encore merci pour votre info
Logged

Titooy

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 736
    • under construction...
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #13 on: October 05, 2006, 12:09:59 pm »

Rien n'empêche qu'il soit à droite, comme dans le thème original. Il suffit de positionner vos blocs différemment avec la feuille de style.
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #14 on: October 05, 2006, 12:12:28 pm »

Je n'ai pas encore analysé en profondeur le système de thèmes de Coppermine mais à première vue, {SUB_MENU} doit être placé avant {GALLERY} sinon il n'est pas interprété.
En effet après vérification sur le thème classic, il faut mettre {SUB_MENU} et {SYS_MENU} avant {GALLERY}.

Merci beaucoup pour votre aide.
Même si je n'ai pas pu obtenir ce que je voulais, l'important est de savoir pourquoi. Ce qui est chose faite.

donc en résumé : il faut toujours mettre {SUB_MENU} et {SYS_MENU} avant {GALLERY}

Et du coup, je vais mettre mon menu à gauche. C'est pas la peine que je cherche plus loin.
A moins que quelqu'un connaisse une bidouille, permettant d'outre-passer cette limitation.

Je considère donc le problème comme résolu pour ma part.

Encore merci à tous pour votre soutien.
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #15 on: October 05, 2006, 12:22:24 pm »

Rien n'empêche qu'il soit à droite, comme dans le thème original. Il suffit de positionner vos blocs différemment avec la feuille de style.

Je n'ai pas réussi à obtenir de résultat correct.
Le problème vient du fait que si j'affecte une largeur de 85% à la partie "content" et de 15% à la partie "sidebar", si je réduis la taille de ma fenêtre, la partie "content" passe en dessous de la partie "sidebar" et non plus à côté.
Il me semble qu'il est moins facile de gérer les proportions des largeurs des deux barres, et de plus la variations de largeur n'est pas prise en compte pour les images du menu sidebar.

Donc je crois que je vais me contenter de mettre le menu à gauche.

Merci
Logged

Titooy

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Posts: 736
    • under construction...
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #16 on: October 05, 2006, 12:41:18 pm »

Pour ajouter un élément à la compréhension des thèmes : il y a 2 grands blocs au sein desquels l'ordre n'a pas d'importance. Mais ces blocs ne peuvent pas être mélangés et doivent être de part et d'autre de {GALLERY}.

pageheader
{LANG_DIR}
{TITLE}
{CHARSET}
{META}
{GAL_NAME}
{GAL_DESCRIPTION}
{SYS_MENU}
{SUB_MENU}
{ADMIN_MENU}
{CUSTOM_HEADER}

pagefooter
{CUSTOM_FOOTER}
{VANITY}



{LANGUAGE_SELECT_FLAGS}
{LANGUAGE_SELECT_LIST}
{THEME_SELECT_LIST}
{THEME_DIR}
peuvent être placés n'importe où.
Logged

arbrezhoneg

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
    • L'album photo de ma copine
Re: Pb affichage {SUB_MENU} après modif de template.html
« Reply #17 on: October 14, 2006, 03:00:17 pm »

Aux modérateurs : ce message peut-être marqué comme résolu

[edit] c'est fait [/edit]
« Last Edit: October 14, 2006, 06:19:54 pm by Frantz »
Logged
Pages: [1]   Go Up
 

Page created in 0.061 seconds with 19 queries.