Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problem with a self-written plugin  (Read 4678 times)

0 Members and 1 Guest are viewing this topic.

peng12341

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Problem with a self-written plugin
« on: September 10, 2006, 01:37:05 am »

I have written a littel plugin by myself. On my local webserver it works really great, but on my friends online webserver it doesn't work.
Could anyone of you please test the plugin and help me finding out what could be the problem.

Thanks in advance,

Patrick
« Last Edit: September 10, 2006, 01:41:41 pm by Nibbler »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Problem with a self-written plugin
« Reply #1 on: September 10, 2006, 03:15:01 am »

Do you get any error messages?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Problem with a self-written plugin
« Reply #2 on: September 10, 2006, 06:52:51 am »

It's working fine for me ,
ask your friend for any other plugin installed , may be it's a conflict problem
Post a link to that gallery (with this plugin install and enable) for error checking
Logged
‍I don't answer to PM with support question
Please post your issue to related board

peng12341

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Problem with a self-written plugin
« Reply #3 on: September 10, 2006, 12:04:42 pm »

The problem is, I can't install the plugin, because I only see a blank screen if I click on install. (Headers are fine but no HTML)
In both galleries no other plugin are installed, so there can't be any conflicts.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Problem with a self-written plugin
« Reply #4 on: September 10, 2006, 12:33:45 pm »

try to install sample plugin (checking CPG core file )
Logged
‍I don't answer to PM with support question
Please post your issue to related board

peng12341

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Problem with a self-written plugin
« Reply #5 on: September 10, 2006, 12:51:29 pm »

The sample plugin and the sef-URLs plugin both work. Just my plugin doesn't work.
Logged

Nibbler

  • Guest
Re: Problem with a self-written plugin
« Reply #6 on: September 10, 2006, 12:53:39 pm »

file_put_contents is a PHP5 function.
Logged

peng12341

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Problem with a self-written plugin
« Reply #7 on: September 10, 2006, 01:26:04 pm »

Hey, that's the problem. My friends webserver has just php 4.4.2 .
And there was even one more php5 function.
I've changed it and now it works!
Thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 20 queries.