Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problems with login for existing users  (Read 3860 times)

0 Members and 1 Guest are viewing this topic.

stuarta

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 88
Problems with login for existing users
« on: September 03, 2006, 03:52:08 pm »

Coppermine install: http://www.simpilots.co.uk/gallery
Forum install: http://www.simpilots.co.uk/forums
Coppermine version: cpg1.4.8
Forum version: phpBB2 2.0.21
Test user account: stutest/stutest

BridgeManager settings:
Forum URL:  http://www.simpilots.co.uk/forums
Relative path to your BBS's config file:  ../forums/  
Use post-based groups?:  1

Just looking again at bridging my gallery with my forums to make it easier for my guys.

In my CPG users I have 6 users, in my forum I have 56.

I can bridge it and if I login with a user that is in my coppermine it logs in fine.  If I login with a user that is in the forum but not the gallery, when it takes me back to the gallery it doesn't log me in.  I click on 'Log In' in Coppermine, it takes me to the forums, I log in there, it takes me back to the gallery but still shows as 'Log In'

New users that I register through the gallery that take me through the forums work fine.  I can log into both ok, but not with existing members of the forum.

The user stutest/stutest is one that I have registered since bridging, but paddy/hewlett is one that I created before the bridging and doesn't work.

Is it worth me trying to populate the coppermine users somehow with the forums users or is there some simpler solution?

Thanks
Logged
Comptia A+ / Network + certified

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems with login for existing users
« Reply #1 on: September 04, 2006, 06:17:07 am »

Login works as expected. Clear your cookies and cache in your browser, then try again.
Logged

stuarta

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 88
Re: Problems with login for existing users
« Reply #2 on: September 04, 2006, 10:09:57 am »

Did you get the paddy login to work?
Logged
Comptia A+ / Network + certified

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems with login for existing users
« Reply #3 on: September 04, 2006, 10:25:04 am »

I tried stutest. If paddy doesn't work for you, make sure that the user group paddy is member of is actually being populated in coppermine.
Logged

stuarta

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 88
Re: Problems with login for existing users
« Reply #4 on: September 04, 2006, 10:32:04 am »

Yep Paddy is the one that I can't get to work.  He's a registered moderator in the forums and I have the Registered group in coppermine.

Where else do I need to check?
Logged
Comptia A+ / Network + certified

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems with login for existing users
« Reply #5 on: September 04, 2006, 01:44:43 pm »

Is he member both of "registered" as well as "moderator"?
Logged

stuarta

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 88
Re: Problems with login for existing users
« Reply #6 on: September 04, 2006, 01:56:35 pm »

He is a moderator although have no moderator group in my coppermine.  Just made him an admin which I have in coppermine but made no difference.  Just added him to my staff group and it worked.   ???
« Last Edit: September 04, 2006, 02:09:43 pm by stuarta »
Logged
Comptia A+ / Network + certified

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems with login for existing users
« Reply #7 on: September 04, 2006, 08:19:19 pm »

Make him a member of the registered group, not the admin group. If you don't trust him to be an admin in your forum, why would you trust him to be an admin in your gallery?
Logged

stuarta

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 88
Re: Problems with login for existing users
« Reply #8 on: September 05, 2006, 06:00:41 pm »

he is obviously a registered member of the forum, so assumed he would be under the registered group in cpg
Logged
Comptia A+ / Network + certified
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 20 queries.