Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Cannot upload via HTTP  (Read 3800 times)

0 Members and 1 Guest are viewing this topic.

mofro

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Cannot upload via HTTP
« on: August 31, 2006, 08:32:04 pm »

I am running 1.4.9, mysql 4.1.21 and PHP 4.4.4 with the gd2 extensions. It is running on iis6.

With the file upload boxes set to 1 and the URI set to 0 on all groups, I can upload just fine. If I change it back to the default it DOES NOT give me an error, just tells me that 'the previous file could not be placed'. I have turned debug on.


Judging from previous posts, it seems like the default answer here will be either a link to your documentation, or a suggestion to move to ImageMagick. I have spent 3 days reading posts and documentation on this and various other sites. If I missed something, a link will be welcome. As for ImageMagick, I would have for sure rather used that application over the gd2... but Coppermine setup stated the converter could be found and not used and did not know why. It suggested that I move to gd2.

Thanks in advance for your help with this.

Also, I have checked and verfied all permissions on the folders stated. The IUSR acct has been granted view/modify/execute on all of the directories.

The upload_tmp_dir is pointing to a valid location.

Mo
« Last Edit: August 31, 2006, 09:57:05 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Cannot upload via HTTP
« Reply #1 on: August 31, 2006, 08:48:25 pm »

It's probably a IIS permissions issue. See if http://forum.coppermine-gallery.net/index.php?topic=35440.msg167499#msg167499 helps you.
Logged

mofro

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Cannot upload via HTTP
« Reply #2 on: August 31, 2006, 09:40:59 pm »

Yeah, that is a very popular post to be linked to. I have verified the permissions on those folders many times and have even given IIS full rights to them. I guess I will download a FTP application tonight and FTP them from me to me so I can set that 777 stuff and see if it helps.

Does anyone know what the 'checkversion.php' he was speaking of in the coppermine folder? I have searched my drive and cannot find anything related.

Logged

Nibbler

  • Guest
Re: Cannot upload via HTTP
« Reply #3 on: August 31, 2006, 09:50:16 pm »

It's versioncheck.php. You can't set unix permissions on windows afaik, even with an FTP client.
Logged

mofro

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Cannot upload via HTTP
« Reply #4 on: August 31, 2006, 09:54:00 pm »

Dang it... I hate it when someone else is right. Permissions, related to IIS, it was.

By default the IUSR account already has rights to these folders/files. I had added write/modify/execute to them, and propogated, but did not notice special permissions was checked. Removed IUSR from the files where varying permissions was needed and re-added the user with straight up write-etc, permissions and all is functional now.

Maybe I can be the next 'quick draw' support-link-to post?

Thanks again...errr Nibbler.

Mo
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Cannot upload via HTTP
« Reply #5 on: August 31, 2006, 11:53:05 pm »

Logged

mofro

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Cannot upload via HTTP
« Reply #6 on: September 01, 2006, 05:44:06 pm »

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#permissions_iis_windows

All very true. I did read that several times. Not being a linux person I did not comprehend the CHMOD info within that document (or else I would not have made the FTP comment regarding permissions above). But, your documentation says nothing about the default Windows IIS permissions and the manner in which explicit denials works. I followed your documentation to a 'T' and that was the problem. If I would have relied on what I already knew, I would have had this up and going 3 days ago.

Oh well, maybe some other will 'happen' upon my post here and come to understand that you must:

- Right-click on the folder
- Click advanced
- Uncheck box to Inherit from parent the permission...
- Click Copy to copy the permissions
- Click apply, not OK
- Find IUSR in the Permission entries box and highlight the user
- Click the edit button
- Make sure the drop-down box states 'This folder, subfolders, and files
- Uncheck any denys
- Check the allow for the permissions listed in the Coppermine documentation
- Click OK
- Check the box that states Replace permission entries...
- Click Apply
- Click yes, ok or whatever comes up on the warning
- Click ok to close the properties of the folder
- Move to next folder and replicate the process

By default IIS explicitly (at least iis6 does) denies those permissions to the IUSR and since these permissions are inherited from the default website in IIS, then any folder you place in WWW root will already have IUSR. Now if you have already manipulated websites on this server then you (or someone else) may have removed the IUSR. If you have to add the user manually, then the steps listed in the Coppermine documentation will work perfect.

Not saying that your documentation should have had these steps (I appreciate the documentation in general) but linking someone to that documentation to absolve the issue I experienced will not actually provide the user with 'support'.

Again, thanks for all

Mo
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Cannot upload via HTTP
« Reply #7 on: September 01, 2006, 06:18:24 pm »

This must have changed from previous versions of IIS (for which I created the section of the docs) to the current version IIS6, that's why it isn't being mentioned in the docs explicitely. We can't re-check every possible flavor of OS / webserver wether the instructions posted actually apply in detail, simply because those settings keep on changing, and there's no saying for us what particular version and environment users have.
However, it is not a coppermine issue. After all, the docs say that the user the webserver runs under needs rwx permissions. How this is being accomplished is not our business - after all, someone who runs a webserver should know how permissions work and how to apply them properly, even without reading any document at all. We're aware though that most people who come here looking for support on IIS issues are not actual fulltime webserver admins, but usually amateur or part-time (or even wannabe-) admins if at all. That's one of the reasons why we don't recommend self-hosting: running and maintaining a webserver requires a lot of skills and time.
Don't get me wrong: I'm not trying to be confrontational, and I appreciate your readiness to post your actual, detailed step-by-step instructions here for the benefit of others. However, I want to point out (basically to others who might come across this thread looking for answers on similar issues) that you have to know and understand both your server operating system and your webserver before you should consider running a webserver of your own. This means: you have to understand how permission propagation and inheritance works on your operating system and apply the needed permissions.

You have to understand that the permissions section in our docs is an extra for our users and not directly related to coppermine. Of course it doesn't go into details (as there are libraries full of books that explain webserver setup in details), simply because of the scope. Other PHP-driven apps just have instructions that tell users to apply rwx permissions and go someplace else to find out about how to do this exactly on their setup. As a courtesy to our users we provide more details, but let me repeat: we don't care what issues you have setting up your webserver properly in the first place. We're developers of a platform independant, PHP-driven web application. Our basic goal is to improve this piece of software. Our mission on this forum is to help users with their coppermine issues. It is not our mission to help them set up a webserver of their own, nor is our target the improvement of webserver apps. We're not particularly fond of IIS anyway and recommend Apache instead.

I hope this clarifies my above postings. Once again: please don't get me wrong - I am not trying to be rude nor is this yet another attempt of Microsoft-Bashing. Just my 2 cent.

Joachim
Logged

mofro

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
Re: Cannot upload via HTTP
« Reply #8 on: September 01, 2006, 08:14:59 pm »

I understand completely... other than the fact Apache is free and would seemingly attract more noobs? But, I have always dealt only with IIS so I would not know. I am sure you get quite a variety here. Hopefully my steps will help some IIS people who come here to pester you. I may wind up posting some detailed step by step on one of my sites for the WIMP installation of this. It is truly a great application.

Thanks again for the information, the application and your expedient replies.

Mo
Logged
Pages: [1]   Go Up
 

Page created in 0.031 seconds with 20 queries.