Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: timeout when uploading large files  (Read 2444 times)

0 Members and 1 Guest are viewing this topic.

kevin11

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
timeout when uploading large files
« on: August 12, 2006, 07:53:26 am »

The time limit may be changed by adding the following declaration near the beginning of the file:
set_time_limit(x);

where x is the number of seconds you desire. A setting of 0 removes the time limit restriction.  Remember that this call is subordinate to the setting in php.ini, so you cannot use it to overcome a restriction there. More information can be found in the PHP manual:

http://us4.php.net/manual/en/function.set-time-limit.php

and i went into the php.ini and changed it to "0" but how come i'm still getting timeout?  is there another file i need to change?

Thanks
« Last Edit: August 12, 2006, 03:44:01 pm by kevin11 »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: timeout when uploading large files
« Reply #1 on: August 12, 2006, 06:52:00 pm »

1) If you're web-hosted, you simply may not have permissions to (re-)set this. When in doubt, ask your webhost.
2) Server-sided time-outs may be one issue. Client-sided time-outs (browser, OS, connection) might have to be taken into account as well.
3) Other server-sided restrictions (see sticky thread on this sub-board) might have to be taken into account as well.
4) You (as coppermine admin) should use FTP-upload plus batch-add anyway (refer to documentation)
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 21 queries.