Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2 3   Go Down

Author Topic: Connections-Theme for cpg1.4.x and WordPress 1.5  (Read 50019 times)

0 Members and 1 Guest are viewing this topic.

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Connections-Theme for cpg1.4.x and WordPress 1.5
« on: August 09, 2006, 07:00:02 pm »

Hey All,

After being away for many weeks this summer (mostly working but still having fun in France and the US Mid-West  :D), I worked on a new Coppermine theme to break up the travel. Meeting several people who write blogs and wanting to incorporate a photo gallery into their blogs, I decided to look to see what I could come up with. I came across a competition for WordPress themes, so, I decided to port the winner, "Connections" byPatricia Muller - http://www.patriciamuller.com/ for use in Coppermine. I think it's a very good theme and have found many variations of it on the web. The contest link is http://www.alexking.org/software/wordpress/themes/blog/2005/02/27/theme-competition/.

The width of the gallery table is 520 pixels so to prevent the scroll bar from being visible, it's best to use 4 columns for thumbnails (Config => Thumbnail view => Number of columns on thumbnail page = 4) and 4 items in the film strip (Config => Image view => Number of items in film strip = 4). The scroll bar allows for a couple of the configuration menu items to display correctly since the table width is less than 600 pixels.

[Edit] Also, this theme is really geared towards intermediate photos sizes of less than 460 pixels. The default in Coppermine is 400 and works great but if you try to go above 460 or so, you will get the scroll bar as when viewing the Coppermine demo. The popup size can be any size though. This setting is in Config => Files and thumbnails settings => Max width or height of an intermediate picture/video ** = 400 (default).

I'm also nearly finished with "Red Train" theme that won the "Mini Poobah" award and should have it posted over the weekend. I'd like to also port the "Plain Ol� Poobah - Rin" theme but it has a much smaller main content window and will require some extra work and testing. Testing themes is what takes all the time!   ;)

The screenshots show the theme with and without the configuration menu.

Enjoy!

Cheers,

Billy
« Last Edit: August 10, 2006, 02:45:42 am by Gizmo »
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #1 on: August 09, 2006, 09:33:57 pm »

Nice work Billy & welcome back :)
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #2 on: August 10, 2006, 12:04:18 am »

Demo - Download Download [Edit GauGau] Reflecting release of new version with a new download link [/Edit]

Excellent work. I added the custom_header token to the zip - it must be there, won't hurt if you don't use it.
« Last Edit: August 14, 2008, 03:03:30 pm by Joachim Müller »
Logged

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #3 on: August 10, 2006, 01:07:03 am »

Thanks guys and sorry GauGau about the header tag missing, I knew there was something I was suppose to add and just couldn't think of it and figured someone would point it out.
« Last Edit: August 10, 2006, 01:16:00 am by Gizmo »
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision

Davide Renda

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #4 on: August 10, 2006, 11:53:53 pm »

Very nice theme which I'd like to use, but doesn't work on my modded gallery (Stramm's mod). It bugs when calling login.php and logout.php, sending back to an error page; I had to maually erase the folder as I could not log back in.
I suppose it has to deal with the login form, but can't figure out how to work around it. Any idea?

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #5 on: August 11, 2006, 12:59:53 am »

I downloaded the theme from GauGau's link above and it ran fine on my gallery. Logging in and out gave no problems so I'll have to download Stramm's mod and install it since my galleries are standard CPG installs with only minor, tried and trusted plugins.
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #6 on: August 11, 2006, 07:12:43 am »

@lontano: can you post the error message here?
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Davide Renda

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #7 on: August 11, 2006, 08:06:55 am »

@lontano: can you post the error message here?
I will re-install it this evening and paste a screen-shot (sorry, but must go to work now!!)

Davide Renda

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #8 on: August 11, 2006, 07:32:49 pm »

Here's the error message I get after having logged out

Code: [Select]
Template error
Failed to find block 'my_friends'(#(<!-- BEGIN my_friends -->)(.*?)(<!-- END my_friends -->)#s) in :

                                        <ul id="topnav">

<!-- BEGIN home -->
                                                <li><a href="{HOME_TGT}" title="{HOME_TITLE}">{HOME_LNK} | </a></li>
<!-- END home -->
<!-- BEGIN my_gallery -->
                                                <li><a href="{MY_GAL_TGT}" title="{MY_GAL_TITLE}">{MY_GAL_LNK} | </a></li>
<!-- END my_gallery -->
<!-- BEGIN allow_memberlist -->
                                                <li><a href="{MEMBERLIST_TGT}" title="{MEMBERLIST_TITLE}">{MEMBERLIST_LNK} | </a></li>
<!-- END allow_memberlist -->

<!-- BEGIN faq -->
                                                <li><a href="{FAQ_TGT}" title="{FAQ_TITLE}">{FAQ_LNK} | </a></li>
<!-- END faq -->


<!-- BEGIN upload_pic -->
                                                <li><a href="{UPL_PIC_TGT}" title="{UPL_PIC_TITLE}">{UPL_PIC_LNK} | </a></li>
<!-- END upload_pic -->
<!-- BEGIN register -->
                                                <li><a href="{REGISTER_TGT}" title="{REGISTER_TITLE}">{REGISTER_LNK} | </a></li>
<!-- END register -->
<!-- BEGIN login -->
                                                <li><a href="{LOGIN_TGT}" title="{LOGIN_LNK}">{LOGIN_LNK}</a></li>
<!-- END login -->

                                        </ul>

The only way to have the gallery up and running again is to erase the "connection" folder from ftp and log in with the standard theme.

I must add I also run "Final Extract" plugin and have removed the LOGIN field (as there is already a login form with the Stramm's mod).

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #9 on: August 11, 2006, 07:37:28 pm »

Happens because you use Stramm's mod pack. Will happen with all regular coppermine themes that haven't specifically been modified to be used with Stramm's modpack. Clearly, this is a modpack issue, not an issue of this particular theme (which works fine with regular coppermine installs) and should therefor not be discussed in this thread. If you have issues related to the modpack, you should reply to the one and only modpack thread - because that's the only place we allow modpack questions to be posted. Make sure to have read the instructions that come with the modpack before asking questions.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #10 on: August 11, 2006, 07:39:22 pm »

as the error said you probably should have a button with my_friends name it's not regular button and as you are using stramm's mod so it's related to his mod ,BTW you can add these two tags to your button definition before <!-- BEGIN home -->
Code: [Select]
<!-- BEGIN my_friends -->
<!-- END my_friends -->
and then it should work ...

Edit:
sorry I didn't see the post of Gaugau , he is right let's take this issue to modpack threads !
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #11 on: August 11, 2006, 08:42:50 pm »

in $template_sys_menu
Code: [Select]
<!-- BEGIN my_friends -->
                                                <li><a href="{MY_BUDDY_TGT}" title="{MY_BUDDY_LNK}">{MY_BUDDY_LNK} | </a></li>
<!-- END my_friends -->

Davide Renda

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #12 on: August 11, 2006, 08:50:26 pm »

Oki doki, didn't mean to mess around with the thread ;-)

PS. Since 3 years I'm using CPG I never had such error message for a theme, so I panicked!!  ::)

PS2. with that little amendment it works fine also on the modded CPG - thx all  :)

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #13 on: September 22, 2006, 07:14:56 pm »

Thanks for creating and providing these Wordpress themes, Gizmo! It's pretty nifty... I modified the links between the blog and gallery so that when switching between the apps, the same theme is used for both. I also used Connections as the basis of porting my blog theme, Ocadia, to Coppermine. I tried to start from an existing Coppermine theme, but that failed pretty quickly. Thanks for providing the themes and the starting point for future WP themes. :)
Logged

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #14 on: September 23, 2006, 02:38:33 am »

Hey Tranz,

Thanks for the kind words but believe me, the hardest part was already done by the talented people who created these WordPress themes. It's funny that you use Ocadia as I have nearly finished this port to Coppermine. I find Rebecca's themes to be really elegant and have a couple in the starting phases so keep a look out for them. If only I had that kind of artistic ability but since I don't, the least I can do for the Coppermine community is port some great themes for everyone to use.

Cheers  :D

Gizmo
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #15 on: September 23, 2006, 02:44:48 am »

Yeah, I really like Rebecca's sense of artistry. I would like to redo the header but wouldn't know where to start.

I'm glad that you are porting Ocadia. I had to resist the urge to make the request since you've done so much anyway.  I couldn't wait, plus I'm on vacation so I had time to kill. It would be great if you release the port because that means I don't have to prep my theme for release. I would do it, but as you said, testing takes a lot of time. It was a huge accomplishment for myself to even make it work for my site, but to make it generic for others to use... aiya. :)

I'm looking forward to those upcoming themes. Thanks!
Logged

linx

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 8
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #16 on: November 05, 2006, 03:49:15 am »

Only thing i miss in this theme is the button "Upload files" for registered users... Am i the only thats missing that?
Logged

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #17 on: November 05, 2006, 05:20:12 am »

Did you look at the very top of the page to the left of the logout button? It's there for me if I login in as a registered users (non-admin).
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision

danibo

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 24
    • boschungfoto
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #18 on: November 17, 2006, 09:18:47 am »

Hallo

Thanks for the wonderful work.
After solving the problem with Stramms Mod, which I use only because the thumbnails become much nicer
I adapted the very nice and clean layout to a more neutral one.

http://www.bilderbank.ch/cpg149_test

If anybody is interested let me know.

The only problem I have is, that "Final Extrac" works only for the links on the top-menue (login, etc) and not for the ones on the right side in the Gallery-Menue like "search".

For the moment I do not use the theme in connection with WordPress.

Thanks
Daniel
« Last Edit: November 17, 2006, 09:24:36 am by danibo »
Logged

Gizmo

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1015
    • BullsEye Photos
Re: Connections-Theme for cpg1.4.x and WordPress 1.5
« Reply #19 on: November 17, 2006, 12:09:26 pm »

Glad you like it. Unfortunately the Final_Extract plugin doesn't work on every menu structure (at least not yet) but you can remove the menus by removing or commenting out (the preferred method) the links in the theme.php file. If any menu you wish to remove has a BEGIN and END tag, you must leave them there and only edit what's between them. To remove the search link this is what the code for the $template_sub_menu would like like...

Code: [Select]
// HTML template for sub menu
$template_sub_menu = <<<EOT
                                        <ul>
<!-- BEGIN custom_link -->
                                            <li><a href="{CUSTOM_LNK_TGT}" title="{CUSTOM_LNK_TITLE}">{CUSTOM_LNK_LNK}</a></li>
<!-- END custom_link -->
<!-- BEGIN album_list -->
                                            <li><a href="{ALB_LIST_TGT}" title="{ALB_LIST_TITLE}">{ALB_LIST_LNK}</a></li>
<!-- END album_list -->
                                            <li><a href="{LASTUP_TGT}" title="{LASTUP_LNK}">{LASTUP_LNK}</a></li>
                                            <li><a href="{LASTCOM_TGT}" title="{LASTCOM_LNK}">{LASTCOM_LNK}</a></li>
                                            <li><a href="{TOPN_TGT}" title="{TOPN_LNK}">{TOPN_LNK}</a></li>
                                            <li><a href="{TOPRATED_TGT}" title="{TOPRATED_LNK}">{TOPRATED_LNK}</a></li>
                                            <li><a href="{FAV_TGT}" title="{FAV_LNK}">{FAV_LNK}</a></li>
                                            <!-- <li><a href="{SEARCH_TGT}" title="{SEARCH_LNK}">{SEARCH_LNK}</a></li> -->
                                        </ul>

EOT;
Logged
Did you read the manual first???? Taking 2 minutes to backup your files can save you hours of wondering what you screwed up.
Billy Bullock - BullsEyePhotos Blog of Indecision
Pages: [1] 2 3   Go Up
 

Page created in 0.025 seconds with 19 queries.