Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch File Upload Complication  (Read 3447 times)

0 Members and 1 Guest are viewing this topic.

cgc0202

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 199
Batch File Upload Complication
« on: August 04, 2006, 12:43:21 am »

The issue presented here is different from the issues encountered by jarodsafehouse71 in posts:

http://forum.coppermine-gallery.net/index.php?topic=34555.0

http://forum.coppermine-gallery.net/index.php?topic=34564.0

OK, here is my current setup.  I use cpg1.4.8 with the correponding latest Stramm plugin. The latter is used mainly to create fixed (squared) thumbnails, giving a cleaner thumbnail presentation. Also, I generally use the setup:  "http://mysite.com/cpg/files and directories" which is the default procedure.  One difference for my setup is this: I have multiple photogalleries; thus I decided to place the photos outside of the CPG, instead of placing them in the "albums" present in each CPG.  Also, the appropriate changes were done using the "configurations" so that a properly installed CPG will recognized the outside album where the photos were  stored.  The appropriate permissions were also done in both the CPG and the outside directories where the photos are stored.

The above setup has always worked before for batch upload and the standard upload files procedure.

Here is what I experienced today.  I decided to place the entire downloaded CPG inside a directory  so that the setup is now:

 "http://mysite.com/common/cpg01/files and directories"
instead of
"http://mysite.com/cpg/files and directories" as I usually did in previous installations.

In the no-support forum

http://forum.coppermine-gallery.net/index.php?topic=34563.msg161926#msg161926

I outlined what happened during the installation but the bottom line was that it eventually worked and I got a working empty CPG, ready for accepting photos. [Note: The aforementioned new post was intended mainly to get general comments rather that support, so I created this separate post for more specific answer to a technical problem I encountered.]

The bottom line, the batch upload procedure no longer works, i.e.,  for the CPG using the level layout:

 "http://mysite.com/common/cpg01/files and directories"

no longer recognizes the photos found in

/public-album/photos/contributors/A to Z*/name of photographer1/photo1.jpg

The permissions were correct and I made sure that the proper files and directories had the appropriate CHMOD specifications.  The only way it would work is if I place the CPG in the public album, i.e., the revised layout setup for the same CPG is now:

 "http://mysite.com/cpg01/files and directories"

I understand that the aforementioned is what was stated in the Manual.  I reread the installation procedure and the DAQ but I did not find anything which stated that it is not possible to use layout:


 "http://mysite.com/common/cpg01/files and directories"

Did I miss something?  Or, is the only allowed layout for the CPG is "http://mysite.com/cpg01/files and directories"?

cgc0202


Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.