Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 2 3 4 [5] 6 7   Go Down

Author Topic: [Unsupported]: Email images to your gallery  (Read 134316 times)

0 Members and 1 Guest are viewing this topic.

nolageek

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Email images to your gallery
« Reply #80 on: July 08, 2007, 09:01:28 am »

Hey guys.  I need to get my cellphone's e-mail address out of this thread.. I've been getting slammed with spam the last week and this is the only place it's listed that I can find! it's the one with 504609 in it.  I can't edit the posts or I'd do it myself.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Email images to your gallery
« Reply #81 on: July 08, 2007, 09:19:45 am »

Done !
Never post email address to a public forum
Logged
‍I don't answer to PM with support question
Please post your issue to related board

nolageek

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Email images to your gallery
« Reply #82 on: July 08, 2007, 10:04:04 am »

Like I said, this is the only place it was at because I don't normally  post my addresses like that.. I probably just cut and pasted without thinking about the the content. :)

I've gotten almost 200 pieces of spam sent to my cell phone the last 5 days and I just about nearly tore my hair out trying to find where it was coming from. 

Thank you very much.
Logged

nolageek

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Email images to your gallery
« Reply #83 on: July 09, 2007, 03:33:44 pm »

Wow. I'm glad I don't use this gallery anymore.  Talk about verbally abusive moderators.

I'm very sorry I asked you to help me, but that's no reason to call me stupid over and over in PMs.

(I'm sorry I PMed you.)

Please, ban me.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Email images to your gallery
« Reply #84 on: July 09, 2007, 10:23:08 pm »

What !?  :o
I did not send you any PM at all  ???
What are you talking about ?
Logged
‍I don't answer to PM with support question
Please post your issue to related board

nolageek

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24
Re: Email images to your gallery
« Reply #85 on: July 11, 2007, 10:00:37 am »

What !?  :o
I did not send you any PM at all  ???
What are you talking about ?


Not you, Sami. GauGau.

I came here in a panic after receiving hundreds of spam e-mails to my cell phone (waking me up about 8 or 9 times a night) and since I saw GauGau was online and a moderator I PMed him asking if he could edit my messages on this board and remove my cellphone's e-mail address (which I admit I shouldn't have posted in the first place.. but I wasn't thinking.)

He then wrote back, talking down to me like a child, accusing me of mass-PMing all of the moderators - which I most certainly did NOT do. Scolding me for PMing a moderator and that it was 'against the rules'

I wrote back to him explaining that I was sorry for PMing him and clarifying that I did NOT pm anyone but him and he again scolded me like a child and threatened to ban me if I continued PMing him.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Email images to your gallery
« Reply #86 on: July 11, 2007, 10:39:42 am »

GauGau's as an admin receive many PMs and it is disgusting cause people keeps sending him support request without his permission check his signature , managing hundreds of PMs a day would make anybody angry
We can finish this here , this kind of discussions doesn't belongs here ....

Next time please be more careful with PMing Devs and supporters
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Email images to your gallery
« Reply #87 on: July 12, 2007, 09:45:00 am »

Wow. I'm glad I don't use this gallery anymore.
OK, bye.

Please, ban me.
Did as suggested. Thanks for cluttering this thread with your remarks.
Logged

Dwilliams

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Email images to your gallery
« Reply #88 on: July 13, 2007, 05:20:51 pm »

Good afternoon everyone,
  I hope that this topic is still being monitored because this is an excellent mod. I am having an issue with getting mine to work with my gallery page and wanted to know if someone with experience in this would be able to send me in the right direction.

  • I have uploaded the 3 files to the root of my coppermine directory
  • I created a new email account for the images to go to
  • I Set the folder permissions
  • Configured the newcam file
  • Added a case to the index file as suggested in one of the first messages of this thread
  • Allow visitors to upload files
When I copy the new index.php to the coppermine root, I get a ton of garbage up on my screen and not the main gallery page example:

Code: [Select]
$lang_album_admin_menu['confirm_delete'], '{DELETE}' => $lang_album_admin_menu['delete'], '{MODIFY}' => $lang_album_admin_menu['modify'], '{EDIT_PICS}' => $lang_album_admin_menu['edit_pics'], ); $template = template_eval($template_album_admin_menu, $params); } $params = array('{ALBUM_ID}' => $id, ); return template_eval($template, $params); } /** * get_subcat_data() * * Get the data about the sub categories which are going to be shown on the index page, this function is called recursively * * @param integer $parent Parent Category * @param array $cat_data * @param array $album_set_array * @param integer $level Level being displayed * @param string $ident String to use as indentation for Categories * @return void **/ function get_subcat_data($parent, &$cat_data, &$album_set_array, $level, $ident = '') { global $CONFIG, $HIDE_USER_CAT, $FORBIDDEN_SET, $cpg_show_private_album; $album_filter = ''; $pic_filter = ''; if (!empty($FORBIDDEN_SET) && !$cpg_show_private_album) { $album_filter = ' and ' . str_replace('p.', 'a.', $FORBIDDEN_SET); $pic_filter = ' and ' . str_replace('p.', $CONFIG['TABLE_PICTURES'] . '.', $FORBIDDEN_SET); } if ($CONFIG['categories_alpha_sort'] == 1) {$cat_sort_order = 'name';}else{$cat_sort_order = 'pos';} $result = cpg_db_query("SELECT cid, name, description, thumb FROM
I have also included my newcam.php file:
Code: [Select]
<?php
define
('IN_COPPERMINE'true);
require(
'include/picmgmt.inc.php');
require_once(
"attachmentread.class.php"); 
$host="{mail.gallery.hlcmarketingcorner.com:110/pop3}"// pop3host 
$login="****@gallery.hlcmarketingcorner.com"//pop3 login 
$password="****"//pop3 password 
$filepath=$_SERVER["DOCUMENT_ROOT"]."/albums/Custom/";  ; // attachement will save in same directory where scripts run, otherwise give abs path 
$album="7"// album id #
$folder "Custom/"// foldername with a /
$jk=new readattachment(); // Creating instance of class#### 
$jk->getdata($host,$login,$password,$filepath,$album,$folder); // calling member function 
?>

and added the suggested items to the anycontent.php
Code: [Select]
*/

if (!defined('IN_COPPERMINE')) die('Not in Coppermine...');

starttable("100%", "Welcome");
include("newcam.php");

?>
<tr><td class="tableb" >
and lastly the index.php snippet
Code: [Select]
                    case 'anycontent':
                        if ($cat == 0) {
                            ob_start();
                            /**
                             * Any php code or HTML can be put in this file and will be displayed
                             */
                            include('anycontent.php');
                            $anycontent = CPGPluginAPI::filter('anycontent',ob_get_contents());
                            ob_end_clean();
                            echo ($anycontent);
                        }
                        flush();
                        break;
case 'receivemail':
                if ($cat == 0) {
                    include('RPHMEDIA-FILE.php');
                }
                flush();
                break;
                }
            }
        }
    }

What am I missing here?
Thank you for taking the time to read this.

Does anyone have any suggestions for this issue? I've given this close to a month and tried different things but have no success as yet.

Thanks,
D
Logged

zer0one

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Email images to your gallery
« Reply #89 on: August 16, 2007, 10:43:33 pm »

So is this a dead project? Or should it still work? I have the same issue Dwilliams is having but there seems to be no more support. Is anyone using this mod on their current (latest update) gallery?
Logged

Nibbler

  • Guest
Re: Email images to your gallery
« Reply #90 on: August 16, 2007, 11:05:18 pm »

Post your anycontent.php
Logged

rphMedia

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 515
  • ***muvipix.com***
    • muvipix - Music | Video | Pictures
Re: Email images to your gallery
« Reply #91 on: August 16, 2007, 11:06:54 pm »

So is this a dead project? Or should it still work? I have the same issue Dwilliams is having but there seems to be no more support. Is anyone using this mod on their current (latest update) gallery?

The problem is...no one asks a question. They post a bunch of code and expect someone to figure it out for them. What IS your question zer0one, Dwilliams? It works fine at my gallery. Email an image to cam@rphmedia.net - you'll see that it works just fine if you follow directions and your host/email supports it. There's no magic to it. And please, don't "expect" support, ask for it. You usually get better response.

Dwilliams

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Email images to your gallery
« Reply #92 on: August 17, 2007, 10:28:45 pm »

So is this a dead project? Or should it still work? I have the same issue Dwilliams is having but there seems to be no more support. Is anyone using this mod on their current (latest update) gallery?

Double and triple check the filepath. example:
Code: [Select]
$filepath=$_SERVER["DOCUMENT_ROOT"]."/albums/Custom/";  ; // attachement will save in same directory where scripts run, otherwise give abs pathWas the original code for my path, however since I did NOT install the coppermine gallery in the root www directory. I had to add "/gallery/coppermine/albums/Custom/" to make the path work. RPH is correct, for the most part this should work out of the "box" with a few modifications to the default coppermine install. However now that I understand more about this, maybe I can assist some now as well. Here's my Exact steps that I follow for install now (now done on 3 different galleries)

  • Upload all 3 files to the root of your coppermine directory
  • If you have never changed or modded your anyconent.php file, rename the anycontent1.php to anycontent.php
  • Pay close attention as you modify your newcam file (see above on the path)
  • Modify your Config settings under Gallery configuration, under the album list view, field "Content of Main Page" reads "breadcrumb/anycontent/catlist/alblist/"
  • Set permissions on the folder for guests to upload files, it can even be a gallery that guests can't see
  • Set the permissions to the folder you are uploading to at "777" or allow everything in that folder.

 
Logged

fallingintoZero

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Email images to your gallery
« Reply #93 on: November 15, 2007, 09:15:37 pm »

i'm starting to think this may not work anymore. i checked my gallery today for the first time in about a week, so i'm not sure how long this issue has been present, and i get this error message:

Quote
can't connect: Certificate failure for mail.redeemedplaces.com: self signed certificate: /C=US/ST=Unknown/L=Unknown/O=Unknown/OU=Unknown/CN=shared8.whbdns.com/emailAddress=ssl@shared8.whbdns.com

this prevents my gallery from loading at all. if anyone is interested in looking at the problem themself, the address is http://img.redeemedplaces.com
Logged

rphMedia

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 515
  • ***muvipix.com***
    • muvipix - Music | Video | Pictures
Re: Email images to your gallery
« Reply #94 on: November 15, 2007, 09:17:16 pm »

Looks like a host problem to me.

Nibbler

  • Guest
Re: Email images to your gallery
« Reply #95 on: November 15, 2007, 09:45:50 pm »

Try without SSL.
Logged

fallingintoZero

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Email images to your gallery
« Reply #96 on: November 15, 2007, 09:56:44 pm »

Try without SSL.

how would i go about doing that?
Logged

Nibbler

  • Guest
Re: Email images to your gallery
« Reply #97 on: November 15, 2007, 09:58:04 pm »

What did you set $host as in newcam.php?
Logged

fallingintoZero

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Email images to your gallery
« Reply #98 on: November 15, 2007, 09:59:25 pm »

What did you set $host as in newcam.php?

set as:
Quote
$host="{mail.redeemedplaces.com:110/pop3}"; // pop3host
Logged

Nibbler

  • Guest
Re: Email images to your gallery
« Reply #99 on: November 15, 2007, 10:15:29 pm »

Try

Code: [Select]
$host="{mail.redeemedplaces.com:110/pop3/novalidate-cert}"; // pop3host
Logged
Pages: 1 2 3 4 [5] 6 7   Go Up
 

Page created in 0.033 seconds with 19 queries.