Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Error Message reads base64_decode() has been disabled for security reasons  (Read 11179 times)

0 Members and 1 Guest are viewing this topic.

beresfordlane

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

My client is receiving the following error message when she accesses her gallery. Anyone who can provide me with any insight into the source of this problem or how to solve it will have my eternal gratitude.

Warning: base64_decode() has been disabled for security reasons in /home/shadowhk/public_html/gallery/include/functions.inc.php on line 368

On a tangental question -- I need to upgrade this client's version from 1.3.2 to the latest. Am I going to encounter problems? Will she lose any part of her gallery?
Logged

Nibbler

  • Guest

The host has disabled a perfectly harmless function that is required by coppermine. It won't work properly unless you get the function enabled, change host, or code a workaround function. You don't lose any data when upgrading, refer to the documentation.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149

You won't lose data, but if you implemented mods/hacks or customized the theme, you will need to reapply the former (if it's not already included in the new version) and update the latter.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 21 queries.