Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: After upload, unable to add photo (get HTTP 500 error)  (Read 2879 times)

0 Members and 1 Guest are viewing this topic.

bkwon

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
After upload, unable to add photo (get HTTP 500 error)
« on: June 24, 2006, 03:06:03 pm »

I'm using 1.4.8, read the sticky upload FAQ and have checked all php.ini settings, chmod etc. and concluded that everything is OK. My config is 2048 for both Max size for uploaded files (KB) and Max width or height for uploaded pictures/videos (pixels). Here's the problem. When I upload a pic with 1864 x 1398 pixel (file size 114 kb), I get the message:

1 uploads were successful.

Please click 'Continue' to add the files to albums.

As soon as I click Continue, I get the Cannot find server (HTTP 500 error) message.

If I resize the picture to 1024 x 768, I'm able to upload and add the photo to an album.

Originally, I had Max size for uploaded files (KB) set to 1024 but changed it to 2048 to see if it'd solve the problem. It didn't. I'm baffled. Please advise if there's anything I should check (again) that I might've missed.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: After upload, unable to add photo (get HTTP 500 error)
« Reply #1 on: June 24, 2006, 03:49:45 pm »

It seems the huge file is just too much for the processor. Image manipulation is very resource intensive. Maybe you can tweak the server settings to allot more resources and such.

Unless you are offering files for people to print, that size is bigger than most people's monitor resolution. Not to mention it will eat up your bandwidth.
Logged

bkwon

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: After upload, unable to add photo (get HTTP 500 error)
« Reply #2 on: June 25, 2006, 01:44:41 am »

Thanks for the reply. The file size of the photo I'm testing is small, only 114 kb. The image size is 1864 x 1398 pixel. I'd have thought that my config of Max width or height for uploaded pictures/videos (pixels) would have allowed it. Based on my tests, it's not the file size that's the cause of the problem, it's the image pixel. I'm setting higher limits basically to see if it works. I'd agree that file size should be smaller and I'm uploading files no larger than 150 kb.
Logged

AnneN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: After upload, unable to add photo (get HTTP 500 error)
« Reply #3 on: June 28, 2006, 01:55:01 am »

I have a user with similar problem.... large pixel size files (small in kb) are causing error messages after the upload. By clicking Continue to place the file after upload he is getting a server error. Reducing the filesize by 50% solved the problem but isn't ideal as he wants the images larger.

The pixel size is well-within that set in the config file (both aspects), and the kb limit is 4096kb. The files causing the problem so far are less than 500kb each, with pixel size 1600 x 1800 approx.  Server allows 20mb of memory to php, max server file size upload is 5mb, so his files should be well-within the parameters of both the server and Coppermine.

I also tried the same images to another installation of Coppermine hosted on the same server and had the same problem, so it's not specific to my installation.

Any thoughts on why this should be happening would be welcome, thanks.
Logged

Nibbler

  • Guest
Re: After upload, unable to add photo (get HTTP 500 error)
« Reply #4 on: June 28, 2006, 03:44:50 pm »

Try disabling the memory limit or using ImageMagick. Be aware that the script needs far more memory to manipulate the file than the actual size of the file.
Logged

AnneN

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: After upload, unable to add photo (get HTTP 500 error)
« Reply #5 on: July 03, 2006, 12:14:33 pm »

Thanks for the suggestion but on a shared server making changes like that isn't an option for me. I'll bear it in mind for future reference though. :)
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.