Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Last additions - 'User' - No image to display  (Read 6513 times)

0 Members and 1 Guest are viewing this topic.

Vargha

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 223
  • Persian Soldier
    • Rangarang
Last additions - 'User' - No image to display
« on: June 23, 2006, 04:07:15 am »

hi guys
on my gallery
when i go to someones profile and check their Last additions their thumbnails will show but when i click on the pic to view the picture it says
No image to display 

my gallery is
www.Rangarang.co.nr/buddies
« Last Edit: July 01, 2006, 05:31:34 am by Paver »
Logged
Haalaa Boro Ye Chayi Vasam Dorost Kon Ta Man Ye Fekri Be Halet Bokonam ;) Ye Hendooneye Shotoriham Biyar Bizahmat :)
Visit My Site www.Rangarang.co.nr
Check Out My Gallery
www.Rangarang.co.nr/buddies
(http://img157.imageshack.us/img157/838/rangarang4xn.jpg)

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Last additions - 'User' - No image to display
« Reply #1 on: June 23, 2006, 04:38:19 am »

Next time, please post a link directly to the page with the problem.  Here's one example I found: http://www.rangarang.co.nr/buddies/thumbnails.php?album=lastupby&uid=14

I think you've found a bug.  I see the same problem on my 1.4.8 testbed.  The problem is that the uid is not being set in the thumbnail view of the lastupby meta-album.
Logged

Vargha

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 223
  • Persian Soldier
    • Rangarang
Re: Last additions - 'User' - No image to display
« Reply #2 on: June 23, 2006, 04:41:39 am »

yeah i guess and sorry yes i will post a link directly to the page with the problem next time
Logged
Haalaa Boro Ye Chayi Vasam Dorost Kon Ta Man Ye Fekri Be Halet Bokonam ;) Ye Hendooneye Shotoriham Biyar Bizahmat :)
Visit My Site www.Rangarang.co.nr
Check Out My Gallery
www.Rangarang.co.nr/buddies
(http://img157.imageshack.us/img157/838/rangarang4xn.jpg)

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Last additions - 'User' - No image to display
« Reply #3 on: June 23, 2006, 04:42:33 am »

Hmm.... I take that back.  It might be a bug, but maybe not.  The uid is set correctly in the classic theme on my testbed.  On your site, it's not set correctly using the classic theme.  Have you modified your core scripts?  Oh wait, you have since you are using Stramm's modpack.  I need to check this some more on the other theme I was playing with.

edit: And it works on my testbed using the hardwired theme (which is the one you are using).  It just doesn't work with a test theme I use based on the sample theme or on the sample theme itself.  So maybe the sample theme has a bug.  But that doesn't address your issue.  So my guess is that one of mods in Stramm's modpack may have affected this meta-album.
« Last Edit: June 23, 2006, 04:59:12 am by Paver »
Logged

Vargha

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 223
  • Persian Soldier
    • Rangarang
Re: Last additions - 'User' - No image to display
« Reply #4 on: June 23, 2006, 07:20:02 am »

no Paver it is not because of the mod
i have another album
which does not use the stramms mod
look
http://rangarang.co.nr/videos/thumbnails.php?album=lastupby&uid=1
and yes it still does the same problem
Logged
Haalaa Boro Ye Chayi Vasam Dorost Kon Ta Man Ye Fekri Be Halet Bokonam ;) Ye Hendooneye Shotoriham Biyar Bizahmat :)
Visit My Site www.Rangarang.co.nr
Check Out My Gallery
www.Rangarang.co.nr/buddies
(http://img157.imageshack.us/img157/838/rangarang4xn.jpg)

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Last additions - 'User' - No image to display
« Reply #5 on: June 23, 2006, 02:16:52 pm »

Ok.  Looking at the demo, I randomly selected themes.  So far, I've only found one that has this problem - the Simplicity theme.  As I said already, the sample theme has this problem too.  So I'm thinking there's a theme customization that certain themes use and others don't that causes this problem.  The sample theme, which includes all theme customizations, has this error so theme writers who use the sample theme as their starting point, start with this error before they change one line of code.

I found the problem.  There are a bunch of differences between include/themes.inc.php and themes/sample/theme.php in regards to $uid_link.  I need to go through and make sure all are correct before applying the changes to the sample theme.

Moving to bugs board.
Logged

Vargha

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 223
  • Persian Soldier
    • Rangarang
Re: Last additions - 'User' - No image to display
« Reply #6 on: June 24, 2006, 12:06:30 pm »

so is there a way i can fix this paver?
Logged
Haalaa Boro Ye Chayi Vasam Dorost Kon Ta Man Ye Fekri Be Halet Bokonam ;) Ye Hendooneye Shotoriham Biyar Bizahmat :)
Visit My Site www.Rangarang.co.nr
Check Out My Gallery
www.Rangarang.co.nr/buddies
(http://img157.imageshack.us/img157/838/rangarang4xn.jpg)

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Last additions - 'User' - No image to display
« Reply #7 on: July 01, 2006, 05:31:25 am »

To keep things in one place, please see this thread for how to fix this error in your theme.

The sample theme has been re-synced and no longer has this bug (committed to SVN 'stable').  This will be available in the next release (1.4.9).
Logged
Pages: [1]   Go Up
 

Page created in 0.035 seconds with 19 queries.