Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Mehrere Probleme: Sprache + Alben + Layout  (Read 4486 times)

0 Members and 1 Guest are viewing this topic.

TabbyXP

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Mehrere Probleme: Sprache + Alben + Layout
« on: July 17, 2006, 01:27:26 pm »

Hallo!
Also ich muss Euch leider mit einigen Fragen/ Problemen bombardieren. Hoffentlich kann mir jemand helfen! :)


1. Egal wie oft ich in den Einstellungen "Deutsch" als Sprache wähle, die Galerie bleibt bei mir in englisch! Interessanterweise sehen aber Gäste und der Benutzer (Benutzername für eine Schuljahrgangsstufe) die Galerie in deutsch?! Irgendwo ist ein Hänger drin! Leider muss ich trotz relativ guten Englischkenntnissen häufig tüfteln, was wiederum nervig ist.

2. Warum kann ich selbst als Admin keine Alben in der "User Gallery" in andere Kategorien verschieben. Was nutzt einem der registrierte Benutzeraccount, wenn die nur in die User Gallery hochladen können? Somit ergibt sich eine zweigeteilte/doppelte Galerie!
Ehrlich gesagt fände ich diesen Mangel an Adminmöglichkeit bescheuert. Normalerweise sollte ein Admin nahezu alles editieren, vershcieben,... können!?

3. Wie schaffe ich es, die Galerie in ein vorhandenes Layout zu bekommen? Die Albenbreite etc. habe ich zwar angepasst, aber ich schaffe es nicht, das Album in das Homepagelayout einzufügen.


So, ich habe mich etwas kurz gehalten, wenn ihr mehr Infos braucht, dann einfach posten!
Es handelt sich übriegns um folgende Website mit Galerie: www.lugy007.de


Vielen Dank shconmal für jegliche Bemühungen!! :)
« Last Edit: July 18, 2006, 11:47:49 am by fwe77 »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #1 on: July 17, 2006, 06:09:01 pm »

Wir haben eine "nur eine Frage pro Thread" Regel, deren Einhaltung Du bei Registrierung (in Zukunft das Kleingedruckte lesen!) zugestimmt hast. Ich beantworte daher nur Frage 1 - stelle die anderen beiden Fragen in separaten Threads, aber erst nachdem Du die Doku gelesen und das Forum durchsucht hast (da beide Fragen schon in Länge beantwortet wurden).

1. Egal wie oft ich in den Einstellungen "Deutsch" als Sprache wähle, die Galerie bleibt bei mir in englisch! Interessanterweise sehen aber Gäste und der Benutzer (Benutzername für eine Schuljahrgangsstufe) die Galerie in deutsch?!

Die Anzeigesprache der Galerie ist ein mehrstufiges Konzept; folgende Stufen werden durchlaufen:
  • Abfrage "hat Benutzer (per Cookie oder als Parameter) eine Sprache explizit gewählt?". Wenn ja, dann wird die Galerie in dieser Sprache angezeigt (weitere Schritte werden ignoriert).
  • "Welche Sprache hat der Benutzer als Standard-Sprache in seinem Browser eingestellt?". Wenn diese Sprache ebenfalls als Coppermine-Sprachdatei existiert, dann wird diese benutzt (weitere Schritte werden ignoriert).
  • "Was hat der Admin als Standard-Sprache in den Einstellungen definiert?". Nur wenn die beiden vorhergehenden Schritte kein Ergebnis erbracht haben wird die Galerie in der Sprache angezeigt, die der Admin als Standard festgelegt hat.

Zusammenfassung: Bei all Deinen Besuchern wird die Galerie in Deutsch angezeigt, weil sie einen Deutsch-sprachigen Browser benutzen. Du jedoch (als Admin) hast anscheinend einen Cookie gesetzt (im Zuge Deiner "Experimente"), der Englisch (oder was auch immer) vorschreibt - diese Einstellung hat Vorrang vor allen anderen oben genannten Schritten.

Lösung: lösche Deine Cookies oder erzwinge eine Sprache per Adresszeilen-Parameter (durch Anklicken von http://www.lugy007.de/galerie/index.php?lang=german zum definitven setzen Deines Cookie auf Deutsch oder http://www.lugy007.de/galerie/index.php?lang=xxx zum Löschen der Cookie-Einstellung und Rückkehr zur Methode "Browser-Sprache setzt Galerie-Sprache").

Joachim
Logged

TabbyXP

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #2 on: July 17, 2006, 06:54:04 pm »

Ups! Normalerweise lese ich die Forenregeln, wobei sie einfach immer (es gibt ja offensichtlich Ausnahmen) das gleiche waren - bisher. *schäm*
Ich gelobe Besserung!

Allerdings konnte ich so nicht definitiv etwas finden. Werde also zu 2.+3. nochmal suchen müssen...

Zum Sprachproblem:
1. Der Benutzer hat nicht explizit eine Sprache gewählt
2. Der Browser hat Englisch als Standardsprache, beim Benutzer
3. Der Admin (Ich) hat Englisch als Browser-Sprache; ich schätze mal, dass da das Problem liegt. Im Forum kann ich unter "config" auswählen was ich will, nach "save new configuration" steht jedes mal wieder English drinnen, egal wie oft ich die Cookies lösche. :/

Ich schaff das irgendwie nicht, obwohl ich eigentlich ncoh jedes Problem meistern konnte. Aber danke jedenfalls für deine ausführliche Hilfe!!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #3 on: July 18, 2006, 07:15:01 am »

Wenn Dein Browser auf Englisch ist, dann wird http://www.lugy007.de/galerie/index.php?lang=german die Sprache doch für Dich umstellen. Gehe halt zu http://www.lugy007.de/galerie/admin.php?lang=german, dann ist auch das Sprach-Feld der Coppermine-Einstellungen auf Deutsch. Nochmal zum Verständnis: es geht nicht darum, in welcher Sprache die Menüs Deines Browsers daher kommen, sondern welche Sprache als bevorzugte Sprache darin festgelegt ist: in Firefox geht das so: "Extras" - "Einstellungen" - "Erweitert" - "Allgemein" -"Sprachen bearbeiten". Im Internet Explorer "Extras" - "Internetoptionen" - "Allgemein" - "Sprachen...".
Logged

TabbyXP

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #4 on: July 18, 2006, 07:26:05 am »

Das heißt auf gut Deutsch, dass ich garkeine andere Möglichkeit habe, die Galerie auf Deutsch zu lesen, als diesen direkten Link.
Selbst wenn ich Deutsch in die Sprachauswahlliste hinzu nehme, klappt es nicht. :(
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #5 on: July 18, 2006, 07:30:55 am »

Nein, das bedeutet es eben nicht ::)! Wenn http://www.lugy007.de/galerie/index.php?lang=german einmalig aufgerufen wird, dann sollten alle weiteren Klicks ebenfalls auf Deutsch sein, da Deine Sprach-Präferenz im Cookie gespeichert wird. Sollte das nicht der Fall sein, dann lösche mal Deinen Cookie. Die Holzhammer-Methode wäre, einfach alle Dateien ausser german.php im lang-Verzeichnis zu löschen - das geht immer, ist aber nicht empfohlen.
Logged

TabbyXP

  • Coppermine newbie
  • Offline Offline
  • Posts: 16
Re: Mehrere Probleme: Sprache + Alben + Layout
« Reply #6 on: July 18, 2006, 11:30:05 am »

Hm, dankeschön für deine Hilfe!! Nach dem xten Versuch hats nun endlich geklappt! :)  :-*
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 21 queries.