Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: userpics folder vs. albums sub-folders  (Read 3740 times)

0 Members and 1 Guest are viewing this topic.

salvemeum

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
userpics folder vs. albums sub-folders
« on: January 22, 2004, 11:33:40 pm »

I have a problem here... that is.. I dont know if it is a problem or not, since I dont know how the gallery works. Well.. last time I cheked, and to be honest, that is a while ago... maybe it was when I used 1.1.. not sure.. but then all the pics was uploaded into a folder called userpics under albums.. But now with this version, no pics goes into that folder.. but there is made alot of wpw_ catalogs, with 2 thumbs and one original in each catalog... dont need to say that with a couple of thousand pics, it get a lot of catalogs.. Not that this is a problem, but I dont know if it is ment to be this way, or if it is a bug.  Another problem, and this problem isnt the gallery's fault... in a way.. but using the xp publish wizard, or the upload function of the gallery, the webserver gets ownership of the files.. so if I want to delete som pics from the server, using a shell or ftp, I get premission denied, since the webserver owns the files... hm hm..  well...
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
userpics folder vs. albums sub-folders
« Reply #1 on: January 23, 2004, 12:25:28 am »

Next time, only ask one question per thread, and don't hijack other's threads (your posting has originally been posted as a reply to a totally unrelated topic) :evil: .
The folder "userpics" within albums has been in coppermine since the very first version, and you never were meant to upload to it by ftp!

wpw_xxx folders are maybe generated by xp_publisher, can't answer this (as I don't use Windows XP). As xp publisher is a comparatively new feature, the folder is new as well - yes. Hard to tell details, as it hasn't been coded by us, but in Redmond. Ask them about it... :wink:

Your third remark on ownership: it's not the gallery's fault, that's true, but you simply aren't meant to fiddle over ftp with files once they're uploaded and inside the database. Instead, use the built-in controls of coppermine admin interface!
If you must play with them by ftp, you should do a CHOWN. If you can't, you're probably on safe_mode server. Take a look at the documentation on "silly_safe_mode"...

GauGau
Logged

salvemeum

  • Coppermine newbie
  • Offline Offline
  • Posts: 10
userpics folder vs. albums sub-folders
« Reply #2 on: January 23, 2004, 12:59:55 am »

sorry about that :) I posted it there because I downloaded the video mod, and thought it was something in the mod that did the wpw_ folder thingy. I forgot to write that I was using the mod, since I already had posted a couple of times in the same thread about my experience with the modded cpg. I am usining 1.2.0 on another server, and also using xp_publish wizard there, but there all the pics are in the userpics folder, and there is no wpw_ folders att all, but looking at wpw.. it could me short for windows publishing wizard..
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 18 queries.