Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Missing Image Descriptions - Help!  (Read 2841 times)

0 Members and 1 Guest are viewing this topic.

uvgoth

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 33
    • TheDigitalAngel
Missing Image Descriptions - Help!
« on: June 23, 2006, 12:00:51 am »

I modyified the Anime theme for my website:

www.thedigitalangel.co.uk

and imputted three custom fields for image description in Config.

In the Edit Files menu, they all appear as fields as well as title and description and on thumbnail view, the title and description both appear but on image view, none of the three custom fields appear.

I assume I may have missed something in the re-write but not sure what it could be.
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Missing Image Descriptions - Help!
« Reply #1 on: June 23, 2006, 12:46:10 am »

The custom fields appear in the "File Information" section under the image.  You can see this section by clicking on the "I" button in the top navbar of the image.

If you want the custom fields to appear below the image, you need to customize your theme.  I'm fairly sure someone has already posted how in another thread, but I'm not 100% sure.

By the way, you are running Coppermine version 1.4.3.  There are some important security fixes in the current version 1.4.8 and so it's mandatory that you upgrade.  Your theme will work fine in 1.4.8, and if you haven't modified any core scripts, the upgrade is simple.
Logged

uvgoth

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 33
    • TheDigitalAngel
Re: Missing Image Descriptions - Help!
« Reply #2 on: June 24, 2006, 01:18:51 am »

Shall download upgrade now then.

As for the custom fields problem, when you click the i nothing happens so if anyone could please tell me what part of the code might need tweaking, I can check it as I have no idea where/what it could be right now.
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Missing Image Descriptions - Help!
« Reply #3 on: June 24, 2006, 03:18:25 am »

I can see the file information box on your site right now - there's no code to tweak.

When you click the "i" button (at the top left of your image), a "File Information" box opens up between the "rate this image" and the "comment on this image" boxes.  It opens up automatically without re-loading the page because it uses JavaScript.  If you have JavaScript disabled on your browser, it might not work.  A lot of Coppermine uses JavaScript so I would think lots of things wouldn't work if you disabled JavaScript.

The custom fields only show up in the "File Information" box if you entered text for them.  They don't show up if you don't.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.