Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: DIVX DOESNT PLAY  (Read 17044 times)

0 Members and 1 Guest are viewing this topic.

graeme_smiffy

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 2
    • Web-Helper
DIVX DOESNT PLAY
« on: June 07, 2006, 02:20:11 pm »

I have just installed the latest version of CPG 1.4.1 which works great ;D

I resolved the issue about uploading none standard files (changed the extesion list in the SQL DB).   ;D and can now upload DIVX files.

I just cant play them  :-\

any clues  ???

Thanx Graeme
Logged
Race you to the top

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: DIVX DOESNT PLAY
« Reply #1 on: June 07, 2006, 02:23:58 pm »

1) cpg1.4.1 is far from being the most recent version, upgrade!
2) Your browser needs to be configured to play divx files as well as Coppermine's filetypes table. Out of the box, Windows media player is usually configured to play avi files, which is not capable to play divx-encoded files afaik.
Logged

graeme_smiffy

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 2
    • Web-Helper
Re: DIVX DOESNT PLAY
« Reply #2 on: June 07, 2006, 02:59:29 pm »

Soz 1.4.7 (stable) I looked at one of the source files which said 1.4.1  :-[ (the web page shows 1.4.7)

I have now resolved the issue, I had set the SQL DB to DIVX not WMP, once changed back to default it worked a treat  :o


Is there a way that the video can be viewed larger/full screen ???  as the file uploaded (640x480) is a lot larger than the small screen shown :P


Thanx Graeme  ;)
Logged
Race you to the top

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: DIVX DOESNT PLAY
« Reply #3 on: June 08, 2006, 01:30:12 am »

If you don't want the player to be embedded into your page, add a video download link at the bottom of your page. There are threads that explain how to accomplish this, please search.
Logged

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #4 on: September 23, 2006, 10:38:12 am »

I have now resolved the issue, I had set the SQL DB to DIVX not WMP, once changed back to default it worked a treat  :o
How did you do that ? I've kind of same problem, in the gallery the movie is not showing
http://fabski.com/images/displayimage.php?album=48&pos=0

but if I go straight to it, working fine
http://fabski.com/images/albums/donk-laquais%2006/La_dure_vie_de_passager.avi

it works on some computer, but typically not on the Mac with all browser (safari, firefox, explorer) installed - I've installed the DivX coded, but not better...

thks
« Last Edit: September 23, 2006, 10:46:51 am by kromega »
Logged
fabski - novice

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: DIVX DOESNT PLAY
« Reply #5 on: September 23, 2006, 11:00:27 am »

Morming Kromega,

Quote
it works on some computer
Yes, both links work fine for me (Win BoxXP, FF, IE, Opera, NetScape)
There is a grey 911 behind you a never before you  ;)

PYAP
Logged

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #6 on: September 23, 2006, 06:46:50 pm »

Morming Kromega,
Yes, both links work fine for me (Win BoxXP, FF, IE, Opera, NetScape)
There is a grey 911 behind you a never before you  ;)

PYAP

OK, thanks, if anyone else sees the problem, please flag.

PS: he was probably warning up  ;D
Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #7 on: September 26, 2006, 01:44:09 am »

Is there actually any way to use DivX Web player in the gallery ?
Using attached code (remove ".txt").

Much nicer user experience (download status) than when using the Windows Media Player which is loaded by default today.

Cheers

Fabien
Logged
fabski - novice

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: DIVX DOESNT PLAY
« Reply #8 on: September 26, 2006, 10:35:23 am »

Quote
Using attached code (remove ".txt").
Humm ! where's your file ?

PYAP
Logged

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #9 on: September 26, 2006, 03:52:00 pm »

oups...
Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #10 on: September 28, 2006, 10:25:42 pm »

hi,
no one can help on that ? where's the code that generate the HTML around the *.avi file ?

thks

f
Logged
fabski - novice

rphMedia

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 515
  • ***muvipix.com***
    • muvipix - Music | Video | Pictures
Re: DIVX DOESNT PLAY
« Reply #11 on: September 29, 2006, 08:26:35 am »

This is not a coppermine issue, but a lack of a codec on the end user's machine.  AFAIK, there's no way to force someone to view divx - they would physically have to download the codec themselves. This format doesn't "stream" anyway (divx has to load the entire video to play, wmv is a streaming format - buffers a little of the video, then plays). 

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #12 on: September 30, 2006, 12:37:54 am »

my request is slightly different - I'd like coppermine to use that code:
<object classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616" width="320" height="260" codebase="http://go.divx.com/plugin/DivXBrowserPlugin.cab">

instead of
<object id="MediaPlayer" classid="" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" type="application/x-mplayer2" width="320" height="285">

so the browser use DivX WEB Player instead of MS MediaPlayer - it's not a codec issue, it's a media player issue.

is it planned to have an option (in a future release) to be able to choose which player the gallery shall use ?

fabien
Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #13 on: September 30, 2006, 11:34:54 am »

2) Your browser needs to be configured to play divx files as well as Coppermine's filetypes table. Out of the box, Windows media player is usually configured to play avi files, which is not capable to play divx-encoded files afaik.
not exactly, MS media player can play divx if the codec is installed. but the issue with media player is that there's absolutly no info on what's going on, if it's downloading, percentage done, or codec missing... as with divx webplayer, there's info on the status/error...

Joachim, do you know which part of the code creates the link for the .avi adding the <embed> tag ?

cheers

Logged
fabski - novice

Nibbler

  • Guest
Re: DIVX DOESNT PLAY
« Reply #14 on: September 30, 2006, 12:22:21 pm »

It's all in the theme system. Search for the code in the sample theme, copy the block to your own theme and modify your copy.
Logged

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #15 on: September 30, 2006, 12:44:06 pm »

I've found a list of player in themes.inc.php, with a list of players, but not DivX... I'll add it, and suggest the mod so it can be re-used and/or integrated to next release.

But what refers $players['WMP'] to ? a value in the DB ?

Thanks

Fabien

Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #16 on: October 01, 2006, 04:21:20 pm »

hi,
to enable divx WEB player:
1) add
        $players['DIVX'] = array('id' => 'DivX',
                                'clsid' => 'classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616"',
                                'codebase' => 'codebase="http://go.divx.com/plugin/DivXBrowserPlugin.cab"',
                                'mime' => 'type="video/divx"'
                               );
in themes.inc.php
after the $players['WMP'] section

2) change in  cpg130_filetypes the avi entry with
avi     video/divx     movie     DIVX

seems to work, check out on
http://fabski.com/images/displayimage.php?album=48&pos=0

cheers
Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #17 on: October 02, 2006, 08:13:09 am »

I still have an issue on Macs, where it can't play the audio track, but I guess that's linked to the way I convert .mov to .avi. Anyone can confirm/correct ?

Logged
fabski - novice

kromega

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 47
    • my gallery
Re: DIVX DOESNT PLAY
« Reply #18 on: November 19, 2006, 10:47:42 pm »

hi,
is there any script/crontab that modify the cpg130_filetypes values in the DB ???

3 times now, I've modified the "avi     video/divx     movie" with "DIVX", and after couple of days, it's changed again !!!

any clue ?

fabien
Logged
fabski - novice

dke

  • Guest
Re: DIVX DOESNT PLAY
« Reply #19 on: September 29, 2007, 10:49:34 pm »

thanks for this kromega, it works perfectly! however, is there a chance to code so the gallery automaticly applies the right width and length for the video? or do i have to do this manually for each video i add? most divx i have are widescreen so 320x240 looks kinda bad :)

thanks again for this great mod!
Logged
Pages: [1] 2   Go Up
 

Page created in 0.024 seconds with 19 queries.