Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 500 Server Errors when uploading  (Read 3195 times)

0 Members and 1 Guest are viewing this topic.

furtherup

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
500 Server Errors when uploading
« on: May 31, 2006, 04:14:47 am »

I've uploaded a good number of files to my server but whenever I try to batch add them - no matter how many at a time - I get a ton of errors - firstly, when selecting the images, these:
Quote
/include/functions.inc.php
    * Warning line 2922: cannot yet handle MBCS in html_entity_decode()!

/searchnew.php
    * Notice line 101: Undefined variable: sel_album
    * Notice line 169: Undefined variable: fullimagesize

Then, when I keep going, I get "click for details or to reload" and then it goes to a 500 server error page.  Attempting to upload manually, it tells me it has been successful but when I go to edit the files it gives me another 500 error.  They do, however, show up in the FTP.

I have checked the file permissions on /albums, /include, and the individual folders multiple times.  I've tried resetting them to both 755 and 777 with no luck.  I've read the documentation, Google searched, searched the forums, and found nothing useful.  Any suggestions or help would be muchly muchly appreciated.
« Last Edit: May 31, 2006, 04:22:25 am by furtherup »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: 500 Server Errors when uploading
« Reply #1 on: May 31, 2006, 07:01:07 am »

Those are not errors, but notices. Turn notices_display off in Coppermine's config if they don't mean anything to you (as suggested in the docs). There's a section in the docs as well that is labelled "upload troubleshooting". Do exactly as suggested there.
Keep in mind that an internal server error is just what it says: there is something fishy on your server, usually not caused by the script, but your server settings. Take a look at your server logs (not the logs of Coppermine).
Logged

furtherup

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: 500 Server Errors when uploading
« Reply #2 on: May 31, 2006, 08:12:53 pm »

OK, I've followed those but it doesn't seem to help any.  I guess the next thing is just to contact my host?
Logged

Nibbler

  • Guest
Re: 500 Server Errors when uploading
« Reply #3 on: May 31, 2006, 08:57:32 pm »

What do you mean it doesn't help? You haven't done any of what it says.

Quote
4.11.4 Upload troubleshooting

If you are experiencing issues with coppermine's upload process, temporarily change your coppermine settings as suggested below to get more detailed error messages:

    * Go to your coppermine page and log in as admin
    * Go to the config screen
    * Scroll to the bottom of the page
    * Expand the "Maintenance settings" section by clicking on it
    * Enable debug mode for everyone
    * Leave display of notices switched off
    * Save the new settings by clicking on "Save new configuration"
    * Go to the "groups" panel
    * Set the upload form configuration for all groups to "Single file uploads only" (set File upload boxes to "1", URI upload boxes to "0" and No. of boxes to "fixed")
    * Save your new settings

Then try to upload (using http uploads, even if you experienced troubles using another upload method) - you should get a more detailed error message that tells you what exactly goes wrong with your uploads. If the error message doesn't mean anything to you, search the support board for the error message you get.
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.
Logged

furtherup

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: 500 Server Errors when uploading
« Reply #4 on: May 31, 2006, 10:36:44 pm »

I did it all but reset the maintenance settings again.

I'll put them back up immediately.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: 500 Server Errors when uploading
« Reply #5 on: June 01, 2006, 04:37:40 am »

Re-read the upload troubleshooting section I already told you to read as well as Nibbler. Pay attention particularly to the section
Quote
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.
::)
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 19 queries.