Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Cannot Upload Pics  (Read 4187 times)

0 Members and 1 Guest are viewing this topic.

dhrehor

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Cannot Upload Pics
« on: June 02, 2006, 07:40:57 pm »

I have setup the following test user and have the site in debug mode.

username: test
password: test

http://69.15.170.125


I get the following message when uploading a picture and attaching it to an album.

The previous file could not be placed.

You have successfully placed all the files.

I have read several posting about this error but to no avail.  I am running this on Windows 2003 Server.

Thanks
« Last Edit: June 02, 2006, 08:31:16 pm by Nibbler »
Logged

Nibbler

  • Guest
Logged

dhrehor

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Cannot Upload Pics
« Reply #2 on: June 02, 2006, 07:45:40 pm »

I have been through this document already, to no avail.

Don
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Cannot Upload Pics
« Reply #3 on: June 02, 2006, 07:47:32 pm »

Please re-read the troubleshooting section in the documentation and make the necessary changes to your gallery.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

dhrehor

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Cannot Upload Pics
« Reply #4 on: June 02, 2006, 07:49:56 pm »

Sounds like you feel it is a permissions problem.  I see that it should be 777 or 755 on a UNIX server. 

What should it be on a windows server?

Don
Logged

dhrehor

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Cannot Upload Pics
« Reply #5 on: June 02, 2006, 08:03:52 pm »

I am getting this debug message:

Warning line 155: unlink(./albums/edit/no_FTP-uploads_into_this_folder!) [function.unlink]: Permission denied


The no_FTP.... does not seem to be a folder, but a file.

Don
Logged

Nibbler

  • Guest
Re: Cannot Upload Pics
« Reply #6 on: June 02, 2006, 08:11:51 pm »

test account is gone, did you reinstall ?

Do exactly as suggested or we can't do much to help you.

Quote
4.11.4 Upload troubleshooting

If you are experiencing issues with coppermine's upload process, temporarily change your coppermine settings as suggested below to get more detailed error messages:

    * Go to your coppermine page and log in as admin
    * Go to the config screen
    * Scroll to the bottom of the page
    * Expand the "Maintenance settings" section by clicking on it
    * Enable debug mode for everyone
    * Leave display of notices switched off
    * Save the new settings by clicking on "Save new configuration"
    * Go to the "groups" panel
    * Set the upload form configuration for all groups to "Single file uploads only" (set File upload boxes to "1", URI upload boxes to "0" and No. of boxes to "fixed")
    * Save your new settings

Then try to upload (using http uploads, even if you experienced troubles using another upload method) - you should get a more detailed error message that tells you what exactly goes wrong with your uploads. If the error message doesn't mean anything to you, search the support board for the error message you get.
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.
Logged

dhrehor

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Cannot Upload Pics
« Reply #7 on: June 02, 2006, 08:16:46 pm »

Got it fixed.  Not permission problem.  Was a ImageMagick problem.  Switched to G2 and it worked like a charm

Don
Logged

Nibbler

  • Guest
Re: Cannot Upload Pics
« Reply #8 on: June 02, 2006, 08:32:17 pm »

Nobody said it was a perms problem. Marking as solved and thanks for posting your solution.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.