Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: CPG worked all fine, now error and totally down, help?  (Read 5610 times)

0 Members and 1 Guest are viewing this topic.

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
CPG worked all fine, now error and totally down, help?
« on: May 28, 2006, 11:05:31 pm »

Hello everyone, its been a while since i've been here, with a lot of help from the devs here, i got my gallery up and running for a good while. All seemed to be fine untill i just got home from my honeymoon and saw only "fatal error: " and thats it when visiting my gallery. I have no idea what happened, i didn't touched anything in the gallery and already asked m y host about it. They said its an error in the script. I've deleted the install lock file, and tried to re install, but when doing that i got the following error:

mySQL Error: Table 'cpg140_albums' already exists on query ' CREATE TABLE cpg140_albums ( aid int(11) NOT NULL auto_increment, title varchar(255) NOT NULL default '', description text NOT NULL, visibility int(11) NOT NULL default '0', uploads enum('YES','NO') NOT NULL default 'NO', comments enum('YES','NO') NOT NULL default 'YES', votes enum('YES','NO') NOT NULL default 'YES', pos int(11) NOT NULL default '0', category int(11) NOT NULL default '0', thumb int(11) NOT NULL default '0', keyword VARCHAR( 50 ), alb_password VARCHAR( 32 ), alb_password_hint TEXT, PRIMARY KEY (aid), KEY alb_category (category) ) TYPE=MyISAM'

Now i have NO idea how to take care of this error, could anyone help me out? And i have no idea how it got there lol...thanks in advance!
My gallery is located here: http://www.janetplanet-pictures.net/gallery


Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #1 on: May 28, 2006, 11:17:52 pm »

Ok, i found a somewhat similar topic, and followed the instructions to put it in debug mode. Now on the left side of my phpadmin panel, before i put it in debug mode, there was already the following notice:

SQL-query: 

SELECT COUNT( * ) AS num
FROM `janet_pics`.`cpg140_sessions`

MySQL retourneerde: 

#1016 - Can't open file: 'cpg140_sessions.MYI' (errno: 145)


And now when i visit my gallery, i get this:

While executing query "delete from `janet_pics`.cpg140_sessions where time<1148847046 and remember=0;" on Resource id #6

mySQL error: Can't open file: 'cpg140_sessions.MYI' (errno: 145)

I'm puzzled....... ???
Logged

Nibbler

  • Guest
Re: CPG worked all fine, now error and totally down, help?
« Reply #2 on: May 28, 2006, 11:18:59 pm »

Please read the sticky that explains how to fix this error.
Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #3 on: May 28, 2006, 11:25:22 pm »

Nibbler, tnx for responding, i'm doing that now...but the problem i have, is that i can't even find the table cpg140_sessions.... it seems to be not there? So weird.. I'm in phpadmin now, do you know where i should look to find this table?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #5 on: May 28, 2006, 11:32:06 pm »

yeah thats the one i'm reading now...

Use your website's Control Panel to repair the table, or use phpMyAdmin to execute this sql query: repair table cpg131_pictures
(Replace cpg131_pictures with your table name)

Now i'm embarrassed to ask this question, but how do I execute a sql query??? I'm sorry but this is totally new to me, i'm inside phpmyadmin, and trying to find this table of mine cpg140_sessions but its not there so far...I must be overlooking something?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: CPG worked all fine, now error and totally down, help?
« Reply #6 on: May 28, 2006, 11:35:33 pm »

You run a query in phpMyAdmin by going to the tab labelled "SQL".
Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #7 on: May 28, 2006, 11:36:40 pm »

THANKS!!!! i did it and it works now :D Thanks for the help!

ps. Is there anything i can do to prevent this from happening in the future? I mean that tables get corrupted? Just asking, maybe its someting simple to prevent it lol
Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #8 on: May 29, 2006, 12:00:42 am »

......it was all fine again..and now some other error appears, maybe you could look at this?

While executing query "SELECT a.aid, a.title, a.description, visibility, filepath, filename, url_prefix, pwidth, pheight FROM cpg140_albums as a LEFT JOIN cpg140_pictures as p ON a.thumb=p.pid WHERE category=2 ORDER BY a.pos LIMIT 0,4" on 0

mySQL error: Got error 127 from storage engine

(and on top it said - translated from dutch - "unable to get data from the database")

Any idea how i can fix this?
Logged

Nibbler

  • Guest
Re: CPG worked all fine, now error and totally down, help?
« Reply #9 on: May 29, 2006, 12:09:50 am »

MySQL error code 127: Record-file is crashed

Try a repair or contact your host.
Logged

Syree

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 43
    • Janet Planet
Re: CPG worked all fine, now error and totally down, help?
« Reply #10 on: May 29, 2006, 12:11:44 am »

Nibbler, how do i do this repair?? Cause my host isn't particularly helpfull unfortunately :(...i dont'even know where i can find this thing lol...i know i sound dumb now, but if you could tell me how i can do this repair i'd be happy! Thanks!
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: CPG worked all fine, now error and totally down, help?
« Reply #11 on: May 29, 2006, 03:13:37 pm »

phpmyadmin -> select the table -> Operations ->  Repair table
or ask your host
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.