Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: "albums" problem  (Read 9988 times)

0 Members and 1 Guest are viewing this topic.

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
"albums" problem
« on: May 24, 2006, 01:28:45 am »

When clicking "albums" in the admin panel, a white page shows up on firefox.  "Page cannot be displayed" shows up on IE.  I replaced the albmgr.php with a fresh one but the problem persists.

What should I do?
« Last Edit: May 25, 2006, 07:13:57 am by GauGau »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #1 on: May 24, 2006, 04:43:51 am »

Enable debug mode in Config and post the error message when you go to the albums page.
Logged

miss1030

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: "albums" problem
« Reply #2 on: May 24, 2006, 05:47:55 am »

Maintenance mode has already been enabled.  Click both categories and Albums from the admin panel results to a blank white page on FF and a page cannot be displayed on IE.  No error message visible so far.

(I run the site with the album problem)
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #3 on: May 24, 2006, 06:35:01 am »

So this happens to more pages than the albums manager? Try reuploading the file, lest it was corrupted.
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #4 on: May 24, 2006, 06:55:07 am »

Yup, so far only 2 pages are giving this error.   I deleted the 2 files and replaced them with fresh ones from a 1.4.6 install.  Same result

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #5 on: May 24, 2006, 07:11:23 am »

What's your gallery url?
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #6 on: May 24, 2006, 07:21:11 am »

http://avril-images.net

Test account:

username: test
password: 123456

If you need admin access to actually view the culprit pages, you may change the password and tell me here so I can promote the account :)

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #7 on: May 24, 2006, 03:45:35 pm »

I don't understand what you meant about changing the password. I hope you didn't post an admin account. I was unable to log in. Can you doublecheck that the login works?
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #8 on: May 24, 2006, 04:33:50 pm »

The login works but for some reason, after it welcomes you, you are logged out again.  I cleared my cookies but nothing.  It's fine with the admin account though.  So I enabled Maintenance Mode Again and I tried making a new account because I thought I may ahve somehow bungled the registration of test somewhere.  I got the following error upon submitting the registration form:

Quote
While executing query "INSERT INTO cpg135_users (user_regdate, user_active, user_actkey, user_name, user_password, user_email, user_profile1, user_profile2, user_profile3, user_profile4, user_profile5, user_profile6) VALUES (NOW(), 'NO', '29df6deb6cbd1d612bd2e428abab1b92', 'dummm', '123456', 'wacky_lokpo@hotmail.com', '', '', '', '', '', '')" on 0

mySQL error: Duplicate entry '0' for key 1

Oh, dear.  I also changed the password for test to "cattle" but it gives the same effect as the previous login attempt.

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #9 on: May 24, 2006, 04:52:28 pm »

You have the same issue as your batch upload thread: http://forum.coppermine-gallery.net/index.php?topic=31724

You will need to do the same suggested fix to the users table.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #10 on: May 24, 2006, 04:57:23 pm »

Since you have the same issue on 2 tables so far, you likely have them on all of them that require autoincrement.

Checkout http://avril-images.net/sql/schema.sql. And do a search for auto_increment. That will tell you which tables need to be fixed, along with which field to auto increment.
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #11 on: May 24, 2006, 05:44:52 pm »

I've auto incremented every specified field and now everything is working perfectly.  At least the parts that were bothering me earlier :)  Well, if something else comes up, I'll start a thread right away. 

Thank you for your help!   ;D

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: "albums" problem
« Reply #12 on: May 24, 2006, 05:46:42 pm »

Was the problem in your first post here solved with the autoincrement?
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #13 on: May 24, 2006, 05:50:22 pm »

Yes.  I had to auto increment pid in cpg135_pictures and do this:

ALTER TABLE cpg135_pictures AUTO_INCREMENT = 1

Following your suggestion, I auto incremented every field said to so in the schema and also did the above query, changing only the tables names :)  It seems to be working now! 

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #14 on: May 24, 2006, 06:40:44 pm »

Oopsy, yet another problem!

When you click a category, there are spaces for random images from that category and the latest additions to that category and its subcategories.  Scroll to the latest additions.  The pictures appearing there are not just for the category but for the whole gallery itself. 

second thing is the random pictures in a category.  Some pictures are also lost and when you click a thumbnail, it doesn't take you to its picture page but to an error page.  The error it gave out was:

Quote
The selected album/file does not exist !

File: /home/melissa/public_html/displayimage.php - Line: 266

Test Account:

Username: test
password: cattle

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: "albums" problem
« Reply #15 on: May 24, 2006, 07:21:18 pm »

one issue per thread!
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #16 on: May 25, 2006, 12:00:10 am »

Oh, sorry!

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #17 on: July 17, 2006, 12:25:23 am »

I noticed that this seems to happen everytime a gallery is moved. Why?

Nibbler

  • Guest
Re: "albums" problem
« Reply #18 on: July 17, 2006, 01:07:45 am »

You need to make sure the auto_increment values are preserved when you dump the database. I think it might be a non-default option in phpmyadmin.
Logged

Flaunt

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 56
    • http://flaunt.nu
Re: "albums" problem
« Reply #19 on: July 17, 2006, 01:59:22 am »

How do I do that?  My phpmyadmin skills are limited to drop :)
Pages: [1] 2   Go Up
 

Page created in 0.024 seconds with 19 queries.