Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: REGISTERED USERS can't upload and moderator (group) can't  (Read 2691 times)

0 Members and 1 Guest are viewing this topic.

kyro_02

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
    • http://www.zacknetwork.net/gamezone/
REGISTERED USERS can't upload and moderator (group) can't
« on: January 16, 2004, 11:18:43 pm »

yo
This has been answered before (i'm think) but doesn't help, i searched and said that somone uploaded upload.php and fixed the problem:

I create new group: Moderator
Get my friend to register.
Put him in Moderator group.
Get him to login.
Tell him to click on "upload Picture"
tells him "Sorry there is no album where you are allowed to upload pictures"
-----------------------------
Create a new user
leave him in group: Registered
Try and upload somthing
tells me: Sorry there is no album where you are allowed to upload pictures"
-------------
Login to my administrator account
Go into User mode.
tells me "Sorry there is no album where you are allowed to upload pictures"
Go back into admin mode.
and it works fine.

Any ideas???

I've uploaded a fresh UPLOAD.PHP and it still doesn't help. I've changed themese, no go.

I haven't touched any theme as i'm a newbie and don't know how to edit templates, and i don't have the time at the moment, I have alot more stuff I goto worry about. But I need this resolved so it will be out of my way, and I won't forget about it. And later on the track think "why dun anyone like my gallery"...lol

Thanks in advanced.

Cheers.

- KyRo

::[::-EDIT-::]:: #1
LOGIN: test
PASSWORD: test
URL: http://zacknetwork.net/gamezone/gallery/

Test if for your self, maybe it might give you an idea.

Thank you.


::[::-EDIT-::]:: #2

ADMINISTRATOR GROUP PERMISSIONS:
Group name: Administrator    
Disk quota: 0(zero)
Can rate pictures: YES
Can send e-cards: YES
Can post comments: YES
Can upload pictures YES
Pub upload aproval(1) NO
Can have a personal gallery: YES
Priv. upload approval: NO

MODERATOR GROUP PERMISSIONS:
Group name: Moderator
Disk quota: 0(zero)
Can rate pictures: YES
Can send e-cards: YES
Can post comments: YES
Can upload pictures YES
Pub upload aproval(1) NO
Can have a personal gallery: NO
Priv. upload approval: NO

REGISTERED GROUP PERMISSIONS:
Group name: Registered
Disk quota: 1024(zero)
Can rate pictures: YES
Can send e-cards: YES
Can post comments: YES
Can upload pictures YES
Pub upload aproval(1) YES
Can have a personal gallery: NO
Priv. upload approval: YES
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
REGISTERED USERS can't upload and moderator (group) can't
« Reply #1 on: January 16, 2004, 11:41:00 pm »

Hi, it sounds like you have not changed the album permissions for the albums you created.
The default setting for these is 'visitors can upload' is NO.  You need to change the settings for the albums themselves, by clicking on the 'properties' box next to the album icon (only visible when in admin mode).

Note, you can only see this 'visitors can upload' box, if 'users can have private album' is set to YES in config.  Also, although it says 'visitors', it only allows members from groups you have set in the group settings.

Hope this is clear.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

kyro_02

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
    • http://www.zacknetwork.net/gamezone/
REGISTERED USERS can't upload and moderator (group) can't
« Reply #2 on: January 17, 2004, 12:34:48 am »

Quote from: "casper"
Hi, it sounds like you have not changed the album permissions for the albums you created.
The default setting for these is 'visitors can upload' is NO.  You need to change the settings for the albums themselves, by clicking on the 'properties' box next to the album icon (only visible when in admin mode).

Note, you can only see this 'visitors can upload' box, if 'users can have private album' is set to YES in config.  Also, although it says 'visitors', it only allows members from groups you have set in the group settings.

Hope this is clear.


Thank you mate,

It worked, except I think it should be somewhere in the administartion panels (not at the front of the gallery) - because I thought everything was in administartion panel, and it's not. :(

anyhow, thank very much for helping me, much appreciated.

Cheers.

- KyRo
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
REGISTERED USERS can't upload and moderator (group) can't
« Reply #3 on: January 17, 2004, 10:44:33 am »

Glad to help.

Quote from: "kyro_02"
It worked, except I think it should be somewhere in the administartion panels (not at the front of the gallery) - because I thought everything was in administartion panel, and it's not.


As each album can be set differently, it would make the main admin pages unmanageable for sites with a large amount of albums.  Done like this, you know exactly which album you are setting the permissions for.

Once you are used to the system, it is very easy.  :wink:
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.