Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: red x's when loading pics  (Read 6008 times)

0 Members and 1 Guest are viewing this topic.

Mannzlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
red x's when loading pics
« on: May 16, 2006, 03:29:13 am »

I followed the directions to get the error message -

here is what we get when we try to load now :

Quote
The file 'albums/userpics/10001/joyful_soul_2~0.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 126


Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 99x100 'albums/userpics/10001/joyful_soul_2~0.jpg' 'albums/userpics/10001/thumb_joyful_soul_2~0.jpg'



The convert program said:
sh: /usr/bin/convert: Permission denied



File: /home/mann6/public_html/gallery/db_input.php - Line: 391


so totally foreign to me - what do I need to do to fix this?

Thanks for the assistance! 
« Last Edit: May 16, 2006, 05:33:38 am by Paver »
Logged

Mannzlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: red x's when loading pics
« Reply #1 on: May 16, 2006, 04:44:18 am »

here is the whole slew of messages I get:



The file 'albums/userpics/10001/DaddyJaceMarineWorld.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 126

Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 100x98 'albums/userpics/10001/DaddyJaceMarineWorld.jpg' 'albums/userpics/10001/thumb_DaddyJaceMarineWorld.jpg'


The convert program said:
sh: /usr/bin/convert: Permission denied



File: /home/mann6/public_html/gallery/db_input.php - Line: 391
   
   
   
« Last Edit: May 16, 2006, 05:03:46 am by Mannzlady »
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: red x's when loading pics
« Reply #2 on: May 16, 2006, 04:56:37 am »

Why don't you use GD instead?  It seems like from your error message that you are not allowed to use the convert program (presumably by your webhost).  This is not a Coppermine error message.

Generally you shouldn't provide debug_info (the stuff starting from USER: on down), unless requested by a supporter.  You should also generally provide a link to your site and a non-admin test user account.
Logged

Mannzlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: red x's when loading pics
« Reply #3 on: May 16, 2006, 05:05:41 am »

Oh - the thing said to copy it all and post it in the support forum when requesting help - sorry - new to this still


well, the CPG has been running fine until today.  That is why I was wondering what happened and wasn't sure where to start - I have researched it on google too.

If I change to GD - will it delete all my members stuff?
here is the link to my gallery:
http://www.fromhere2scrapternity.com/gallery/index.php
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: red x's when loading pics
« Reply #4 on: May 16, 2006, 05:13:07 am »

I don't know why the permission for /usr/bin/convert would change.  Check with your webhost.

GD or ImageMagick is only used when creating the thumbnails & intermediate images, either upon upload or when using one of the admin tools that re-creates those files.  It won't affect current images because those are already created.

It is of course recommended that you backup your files & database regularly.

You are using 1.4.2 - it is strongly recommended that you upgrade to the current version 1.4.5 which includes two important security fixes among other minor fixes.  They won't affect the error you are getting because it's not a Coppermine error as I said.  The upgrade will be simple (read the docs) unless you have applied any mods or hacks.  In that case, you'll have to re-apply those mods or hacks after the upgrade.
Logged

Mannzlady

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
Re: red x's when loading pics
« Reply #5 on: May 16, 2006, 05:15:48 am »

Okay - I changed over to GD2 and it works fine now :)

I am not very computer literate when it comes to these changes and upgrades.  I will upgrade though if it means that it will make my gallery more secure and run better.

Thank you very much for your help :)
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: red x's when loading pics
« Reply #6 on: May 16, 2006, 05:33:27 am »

You're welcome.  Yes, you should upgrade ASAP, for the security reasons I mentioned.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.