Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: HELP!!!  (Read 9342 times)

0 Members and 1 Guest are viewing this topic.

amber80

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
HELP!!!
« on: May 12, 2006, 03:01:41 pm »

I need some help, I can't access my gallery, it gives me some type of critical error.


Notice: Undefined index: debug_mode in /home/lyndsy-f/public_html/gallery/include/functions.inc.php on line 96
Fatal error :
There was an error while processing a database query




http://lyndsy-fonseca.com/gallery/

Please help!
« Last Edit: May 14, 2006, 02:49:39 am by GauGau »
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: HELP!!!
« Reply #1 on: May 12, 2006, 04:19:53 pm »

If you have v1.3.x, upgrade to the latest version of Coppermine.  The undefined index error will be fixed (earlier versions didn't add the debug_mode entry to the config table).  To fix this error without upgrading, just run the upgrade script that's already present as it'll add the necessary entry.

Next, you'll have to use a tool like phpMyAdmin to set debug_mode to 1.  Once you do that, you'll get a more descriptive error message that you can post here.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

amber80

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: HELP!!!
« Reply #2 on: May 13, 2006, 12:45:45 am »

how would I run the upgrade script?
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: HELP!!!
« Reply #3 on: May 13, 2006, 12:48:23 am »

First, use your FTP client or cPanel file manager app and look in your Coppermine directory.  There's should be a file called upgrade.php or update.php (I don't quite remember which one).  If it's there, just point your browser to yoursite.com/upgrade.php.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

amber80

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: HELP!!!
« Reply #4 on: May 13, 2006, 01:28:54 am »

First, use your FTP client or cPanel file manager app and look in your Coppermine directory.  There's should be a file called upgrade.php or update.php (I don't quite remember which one).  If it's there, just point your browser to yoursite.com/upgrade.php.

That doesn't work. How would I upgrade without losing all of my files.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: HELP!!!
« Reply #5 on: May 13, 2006, 01:47:32 am »

What doesn't work?  Is the file not there?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

amber80

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: HELP!!!
« Reply #6 on: May 13, 2006, 05:40:32 am »

no, I don't have an upgrade.php I have an update.php but that doesn't work. It says the same error message.
Logged

Nibbler

  • Guest
Re: HELP!!!
« Reply #7 on: May 13, 2006, 03:51:39 pm »

Make sure include/config.inc.php has the correct information to connect to your database.
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: HELP!!!
« Reply #8 on: May 13, 2006, 05:18:29 pm »

Do you still get the debug_mode message, or just the critical error message?
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

amber80

  • Coppermine newbie
  • Offline Offline
  • Posts: 9
Re: HELP!!!
« Reply #9 on: May 13, 2006, 05:29:16 pm »

I got the debug_mode message. But I just upgraded, so thanks for all your help.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.