Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Thumbnail display not alphabetical  (Read 4114 times)

0 Members and 1 Guest are viewing this topic.

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 380
    • Skolai Images - Nature, Travel and Adventure stock photos
Thumbnail display not alphabetical
« on: May 08, 2006, 12:37:20 am »

Hey folks,

Last night I was looking over my site and seeing what google had cached. Google had an older version of one of my albums that didn't have all the new images on it. What's really weird is since I did that, when I view any of the albume on Safari, the thumbnails no longer display in alphabetical order. On this page:

http://www.skolaiimages.com/stock/thumbnails.php?album=33

the image atl_centpk_003.jpg should be the first image on the page. When  view the page in Firefox, IE, or Netscape, it works fine, but Safari displays that image halfway down the page, and has all the images posted incorrectly. Does anyone know what the problem might be and how I fix this?

Thank you

Cheers

Carl
« Last Edit: May 08, 2006, 01:08:48 am by TranzNDance »
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 380
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: Thumbnail display not alphabetical
« Reply #1 on: May 08, 2006, 01:07:05 am »

Hey Folks,

Well, I just tweaked a few other things in the lang folder and this appears to now be fixed. I have no idea what changed but for the last 24 hours the display was all over the place.

Mark this solved or delete it necessary.

Thank you

Cheers

Carl
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Thumbnail display not alphabetical
« Reply #2 on: May 08, 2006, 07:07:03 am »

Mark this solved or delete it necessary.
I'm glad you got your issues fixed. As you have been around on this board you should be aware that we never delete threads though. ;)
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 380
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: Thumbnail display not alphabetical
« Reply #3 on: May 08, 2006, 04:44:57 pm »

hey GauGau,

Oh, I forgot. Thanks for the reminder. (By the way, speaking of as long as I've been around, is there any way the little tag under my name can be changed from Coppermine Wizard to something more honest, like Complete Coppermine Idiot? :) )

However, the site is doing it's thing again. I logged in (using the login.php page) and checked the Lightbox funtion, and now the thumbnail displays are all over the place again. it only does this in Safari. Once I add a larger image to the lightbox (not the thumbnails ith the plugin) it goes back to normal .. I guess because the image being displayed is not REALLY image # 2 .. it's just what Safari seems to be displaying at the time). I don' tknow if any of this makes sense, but it seems to go back and forth between working correctly and not working correctly.

Thank you

Cheers

Carl
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 380
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: Thumbnail display not alphabetical
« Reply #4 on: May 09, 2006, 09:12:22 pm »

Hello

Well, this still is not working correctly, so maybe this thread sholdn't be marked sovles (sorry about that). It works sporadically. If I view a gallery, it will display the thumbnails in the wrong order. When I open a full size image and click the button 'Add to Lightbox',  it doesn't add an image to the lightbox, but it does refresh the page and display what should be the correct image for that number in the album. Then when I go back to view that album, it will correctly display the images in the right order. Could this have something to do with the referrer thing mentioned in this thread?

http://forum.coppermine-gallery.net/index.php?topic=25554.0

I tried to make the changes regarding the referrer as mentioned there, but I might have done it incorrectly. Again, the problem seems to be using Safari.

I appreciate your help.

Thank you

Cheers

Carl
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Thumbnail display not alphabetical
« Reply #5 on: May 09, 2006, 11:27:21 pm »

clear your cookies to clear individual per-user sort order
Logged

Walkinman

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 380
    • Skolai Images - Nature, Travel and Adventure stock photos
Re: Thumbnail display not alphabetical
« Reply #6 on: May 10, 2006, 05:32:57 am »

Hey GauGau,

Thank you. That worked perfectly. I'm still having trouble getting the "Add to Lightbox" to work, but I'll post in another thread if I have to. :) The order is sorted correctly now, thank you.

Cheers

Carl
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 22 queries.