Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Upload Problem  (Read 2303 times)

0 Members and 1 Guest are viewing this topic.

javierin79

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Batch Upload Problem
« on: April 23, 2006, 08:08:59 pm »

Hi. I am running Coppermine 1.4.5 under Apache 2.0.55 with gd version 2.0.33 and PHP 5.1.2 on a linux environment

I have uploaded to a directory all my fioles (which are quite a few, 300, 2-3 Mbyte jpg each (8mpx))

When I try to batch upload them to a newly created album, it takes some time to generate the intermediate thumbnails, but it does. Then I select the target album, leave all the files selected as it does by default and click on the button that would add them to the album.

Here comes the problem. When I click the button, it redirects to http://myalbum.tld/searchnew.php?insert=1 and displays the following message:

Error   
No tienes permisos para acceder a esta página.
Fichero: /var/www/localhost/htdocs/album/searchnew.php - Línea: 25

Which would translate into english as: Error, you don't have permissions to access this page

Uploading individual files works flawlessly, but being 300 + 100 the pictures i want to upload, i can't consider that as an option.

Any help with this?

« Last Edit: April 23, 2006, 08:47:48 pm by TranzNDance »
Logged

javierin79

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Batch Upload Problem
« Reply #1 on: April 23, 2006, 08:15:12 pm »

Well It seems there are some limits reached here as my apache log shows. I'm sorry and hope this helps someone with the same problem as me.

[Sun Apr 23 19:58:51 2006] [error] [client 192.168.0.1] ALERT - configured request variable limit exceeded - dropped pics[] (attacker '192.168.0.1', file '/var/www/localhost/htdocs/album/searchnew.php'), referer:

Never mind I found someone with the same problem as me. I'm heading towards the sticky posts section to follow instructions.
« Last Edit: April 23, 2006, 08:39:51 pm by javierin79 »
Logged

javierin79

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Batch Upload Problem
« Reply #2 on: April 29, 2006, 07:29:31 pm »

The problem seemed to be with the hardened php  I had. Compiling php explicitly for coppermine with no security enhancements made everything go fine.

Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.