Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: 1 2 3 [4] 5 6 7 8 ... 26   Go Down

Author Topic: Permanant watermark with undo possibility (GD2+IM working!) + better admin tools  (Read 415013 times)

0 Members and 1 Guest are viewing this topic.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Setup:
just apply the following code, replace include/picmgmnt.inc.php with the attached file and run update.php

GoTTi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24

ok i did that, and now i have the settings set to on, and the path to watermark is images/watermark.png

first, is that images folder meaning inside the gallery folder? /public_html/gallery/images/ ??

second, when i set the option to on, and i have the watermark image in the folder, what do i do next? i uploaded a few test pics and i added them to gallery, and the watermark did not show.

thanks for your help.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

yes, that's the folder.
If it's not working then you probably made a mistake somewhere. Have you replaced the picmgmnt.inc.php (with the one added to the first post in here or the improved one http://forum.coppermine-gallery.net/index.php?topic=29817.msg143122#msg143122 )

GoTTi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 24

ok i changed the php file and now its working.

its only watermarking the preview image though, not the original and i have the setting set to both.

what would cause that?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Please read this thread

DarioDN

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

i've installed all and on single upload it's worked.

Now i've uploaded batch files and it shows the watermark only the intermediate image but not on the large image... how can i do?

tnx
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

the last guy who posted in here had the same problem  ::)

DarioDN

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

yes, but the link reported don't resolve the problem (i'd the update but only the intermediates change)
Logged

DarioDN

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

ok.. the permission is to be set on 666 and not on 644...  :D
Logged

Armstrong

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20

I've searched this entire post. Where is the attached file picmgmnt.inc.php

Could someone please point me in the right direction?
Logged

Armstrong

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20

cancel that. once i logged in it showed up.
Logged

claude258

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 150
    • Album photos Brière

I am trying to install this mod on:
http://www.fur4x-hebergement.net/claude/cpg149/index.php
but I get a critical error (as administrator) and a blank page (as visitor) when I try to add an image via HTTP.
Via FTP the image is not added.

Can you help?
Thanks




Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #73 on: September 05, 2006, 07:51:25 am »

Have you updated the SQL and replaced the picmgmnt.inc.php file?
If yes, then check the modifications you did again. Somewhere you've made a mistake while applying the mod. Even better would be to restart from scratch

claude258

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 150
    • Album photos Brière

I have updated the SQL and replaced the picmgmnt.inc.php. I have done all the modifications asked by the mod (restarted from scratch).

I still get the following error with HTTP upload (as administrator):
Quote
Erreur d'upload - './albums/edit/'

Fichier: /home/www/claude/cpg149/upload.php - Ligne: 2261

I get a blank (white page) with a upload as visitor.

With FTP upload, the image can't be added.

My image watermarking config:
The link used for the watermark file: www.fur4x-hebergement.net/claude/cpg149/images/watermark.png
Transparency:50
Set color transparent x (GD2 only): (blank)
Set color transparent Y (GD2 only): (blank)

I have to mention that I modified the french.php file instead of english.php. Is that the problem?

Link to the site:
http://www.fur4x-hebergement.net/claude/cpg149/index.php
debog is available.

Thanks.



Logged

light2fire

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5

Hi everyone.

Quote
- possibility to assign different watermarks to certain users.

Is this also possible for this mod? (1.4.x)
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #76 on: September 06, 2006, 01:35:20 am »

Claude, I just uploaded a test pic and all worked smooth (no white page or any error at all) except that no watermark got applied. But that's no wonder at all cause you've set a web URL for the path. That'S plain wrong. Either use the absolute or relative path
relative path: images/watermark.png

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #77 on: September 06, 2006, 01:36:13 am »

Hi everyone.

Is this also possible for this mod? (1.4.x)

would be possible if you code the necessary changes

light2fire

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #78 on: September 06, 2006, 01:38:03 am »

would be possible if you code the necessary changes
:-\ What are the changes I have to make?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #79 on: September 06, 2006, 01:40:58 am »

similar to the ones for 1.3... nothing major has changed. I do not know out of mind and would have to look that up myself too. If I remember right, then it was just some lil thingies in picmgmnt.inc.php - > compare that file with the standard modpack 1.3 picmgmnt.inc.php
Pages: 1 2 3 [4] 5 6 7 8 ... 26   Go Up
 

Page created in 0.037 seconds with 20 queries.