Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 ... 10 11 12 13 [14] 15 16 17 18 ... 26   Go Down

Author Topic: Permanant watermark with undo possibility (GD2+IM working!) + better admin tools  (Read 386707 times)

0 Members and 2 Guests are viewing this topic.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #260 on: December 20, 2007, 07:38:38 am »

should work... but better use the up to date one from the modpack
http://forum.coppermine-gallery.net/index.php?topic=28367.0

thegap

  • Coppermine newbie
  • Offline Offline
  • Posts: 1

Hello,
Everything work fine with this MOD by Stream,but water mark show only on  the resise image not both (Resise +Original picture), i don't know and understand why  :o ? May someone can help , thank ,i'm using CPG ver 1.12
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

When batch adding the watermarking process needs extra permissions. That's ause the image you uploaded to the server gets modified and saved again. If permissions don't match, then the server doesn't allow the saving. So chmod the images you want to batch add to 644 or 666 (depending on server setup) and the folders they are in to 777 or 755. 

Upgrade to 1.4.14 asap

rosner

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

Stramm,

Sorry for bother you.

I've no problem to install watermark,but while i enter to "admin config" of  "Image Watermarking",I cannot choose "Watermark Image" :(yes or no),I choose "yes",after continue,it is still "no"....

What is the problem?

the php script is correct no error,please help.

My version is CPG ver 1.4.14

link:www.milenarosner.com/gallery
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

from the first post
Quote
Setup:
just apply the following code, replace include/picmgmnt.inc.php with the attached file and run update.php

rosner

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

from the first post

sorry,i'm a newb
what you mean by run update.php?
Logged

rosner

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

Stramm,

I fixed the problem finally,thank for the great hack for watermarking.

That's a very good hack to stop do stupid watermark form some photo software.

A useful watermark anyway!

I love u stramm! ;D
Logged

slYbYte

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Logged

rosner

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Logged

vladale

  • Coppermine newbie
  • Offline Offline
  • Posts: 6

I installed this without any problems, but found some bug in it, well, if it's a bug.

Watermarking works perfectly with Upload File (upload.php) but doesn't work fully with batch uploading. Actually, it works, but it watermarks only pictures which are resized. When you open original one, watermark is not shown, not sure why? Thanks!
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Has been asked and answered at least 10 times before. Last time just a few posts above

vladale

  • Coppermine newbie
  • Offline Offline
  • Posts: 6

Yeah, I know and I finally managed to see where the problem was. The problem was in image permissions, I had to chmod them all to 777 in order to watermark properly. Thanks!
Logged

pcp20us

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 74
  • Go the open sources
    • noosaimages.com.au

Hi all

Hope this is the right place for this

I applied this mod about a yaer ago. I remeber it took a lot of configuring. I have a local test server, which i upgraded to the latest version, hence lost the great watermark. is there a way to stop this from happening. ie: back up these files then copy theme back over the upgrade or will that cause drama, is there a list of what files you mod for this watermark hack, so i know what to backup.

Any suggestion appreciated.

Happy New Year
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

The list what you modify is in the instructions... backing up the modded files and overwriting the upgraded ones isn't recommended at all cause you undo the upgrade with that.

This is a mod. Means you'll have to mod each upgrade yourself. If you'd use the modpack, you can apply premodded files. 

pcp20us

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 74
  • Go the open sources
    • noosaimages.com.au

Hi Stramm.

Thanks for that. I read the instructions, mmm i should r thought of that !

I am a bit confused re mod packs and strammpacks
I have a stramm 1.4x plugin pack v3 and a stramm mod1 1_4_13_bridge.

Now i understand that the mod pack is for when you are bridging ?? i am not i have stand alone coppermine.

Under plugin pack i had great problems with cpgmark (and see not much has happened with it)

This hack seems to be the only one i could get to work, this is about 2 years ago. Are there an watermark tools like tis stramm one which is a plugin as apoosed to a hack

You say"If you'd use the modpack, you can apply premodded files.  "
Do i have the right mod pack?? cause theres nothing in there re watermarking.

Cheers

Pete
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

There's a plugin pack, but no stramm plugin pack... it contains some of my plugins afaik. However I haven't written a watermark plugin as I have not seen a practical way to implement the functions I wanted using th plugin api.

The modack is a bundle of files that contain my mods. It's premodded filed so users get rid of applying the changes to each upgrade themselves. As I don't use a bridge myself, the modpack was intended for an unbridged coppermine. Later I've added bridge support (for some forums, not all supported by the original coppermine).

Features of the modpack you can see in its announcement thread http://forum.coppermine-gallery.net/index.php?topic=28367.0 :
Watermarking, thumb cropping, custom thumb tool (my new favourite: http://forum.coppermine-gallery.net/index.php?topic=47538.0), avatars, pm, comment notification, buddies etc.

pcp20us

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 74
  • Go the open sources
    • noosaimages.com.au

Stramm

Thanks mate for clearing that up. I shall apply the upgrade when i get a chance.

Cheers

Pete
Logged

torontokills

  • Coppermine newbie
  • Offline Offline
  • Posts: 6

Just applied my first mod, and it worked, cant believe it.  Thanks for this Mod Stramm.  It works..
but i do have one small issue, or something i noticed.

I believe the Watermark will only work on pictures that are at least the intermediate size value that is set in config

Many photos I have on coppermine are unresized even though 'create intermediate pictures' is selected, (cause I'm guessing Coppermine doesnt bother to resize originals that are smaller than intermediate value) ..and these originals that never got intermediate files created in the first place did not get affected by the mod.

So bottom line is if u have originals that are smaller than your intermediates they will not be affected by the mod, even when selecting 'both' in watermark config?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

should work without problems...
post a link and a login with upload permissions. Also tell me your settings so I can test it.

tinorebel

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 87
  • live long and prosper!
    • www.tripodart.net
Re: Permanant watermark with undo possibility (GD2+IM working!) + better admin t
« Reply #279 on: February 01, 2008, 06:55:23 pm »

Hy Stramm, first of all thanks for all the great mods!

I'm runnin a CPG 1.4.14
I Just needed this kind of feature, so applied this mod.

Just one problem afer doing all the process described in first post:
In the configuration I change settings of " image watermarking"  but the changes I made dont get memorized.
Each time I get Back to config, the whatermarking is set on NO and the path to the file is deleted....

Tried anyway uploading pictures and they dont get modified.

Some sugestion on where is the little error???
 :o :o
Logged
Live long and prosper!
www.tripodart.net
Pages: 1 ... 10 11 12 13 [14] 15 16 17 18 ... 26   Go Up
 

Page created in 0.03 seconds with 19 queries.