Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Imagemagick  (Read 6694 times)

0 Members and 1 Guest are viewing this topic.

TonTon

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Imagemagick
« on: March 19, 2006, 08:56:11 pm »

ERROR Message :

============================================================================================================


Error executing ImageMagick - Return value: 137

Cmd line :
/usr/local/ImageMagick-6.2.5/convert -quality 100 -antialias -geometry 75x100 'albums/TonTon/me/2006/P1050386.jpg' 'albums/TonTon/me/2006/thumb_P1050386.jpg'


The convert program said:
ld.so.1: convert: fatal: libMagick.so.9: open failed: No such file or directory

=============================================================================================================

how can i do to slove this problem ?

 libMagick.so.9 is alive . .

help me
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Imagemagick
« Reply #1 on: March 19, 2006, 10:37:41 pm »

readable and executable for the webserver?
Logged

TonTon

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Imagemagick
« Reply #2 on: March 20, 2006, 06:10:23 am »

webserver is ok ~

when I install CPG and Imagemagick complete !

It's ok !

It can  contract  picture size success !

but one day ! it can't contract !

anyways ~ I use one picture to upload or batch upload !

then show these message !

if I use cmd line :

/usr/local/ImageMagick-6.2.5/convert -quality 100 -antialias -geometry 75x100 'albums/TonTon/me/2006/P1050386.jpg' 'albums/TonTon/me/2006/thumb_P1050386.jpg'

it can contract success ! . . .

I try to reinstall Imagemagick . . . . The result is the same . . .

My OS is Sun Solaris 10 ! CPG is 1.43 ( stable ) ! Imagemagick is 6.2.5 ( ImageMagick-sparc-sun-solaris2.10.tar.gz )

I don't know do you understand What I say . .

Sorry  ~ My english is no good ! I come from Taiwan . .

I Hope you can understand My trouble . .

and thank you answear for My question . .
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Imagemagick
« Reply #3 on: March 20, 2006, 07:01:50 am »

well, what could I say: obviously, coppermine can't use your ImageMagick install. Fix your ImageMagick install or use GD instead of ImageMagick. I have no idea what else to recommend. Search the web and the ImageMagick site for the error message you get ("Error executing ImageMagick - Return value: 137")
Logged

lombo34

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Imagemagick
« Reply #4 on: March 29, 2006, 08:45:20 pm »

Gau

I am getting sort of a similar response, do you know how to work around it?

Here's the error message I'm getting:
Quote
Error executing ImageMagick - Return value: 1

Cmd line :
/usr/local/bin/convert -quality 80 -antialias -geometry 100x75 'albums/orlando_06/Orlando_06_001.jpg' 'albums/orlando_06/thumb_Orlando_06_001.jpg'


The convert program said:
convert: no decode delegate for this image format `albums/orlando_06/Orlando_06_001.jpg'.
convert: missing an image filename `albums/orlando_06/thumb_Orlando_06_001.jpg'

Please help,
Lombo34
« Last Edit: March 29, 2006, 09:19:11 pm by lombo34 »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Imagemagick
« Reply #5 on: March 29, 2006, 09:47:01 pm »

Your issue differs, so you shouldn't have replied to this thread. Same advice as I gave to TonTon applies to you as well though. Use GD.
Logged

lombo34

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Imagemagick
« Reply #6 on: March 29, 2006, 11:54:03 pm »

installing GD as we speak, thanks and sorry for the misplaced post....

Is ImageMagick that bad????
Logged

kegobeer

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 4637
  • Beer - it does a body good!
    • The Kazebeer Family Website
Re: Imagemagick
« Reply #7 on: March 30, 2006, 01:58:21 am »

No, ImageMagick is great.  If you don't have a properly installed and configured setup, it doesn't work.
Logged
Do not send me a private message unless I ask for one.  Make your post public so everyone can benefit.

There are no stupid questions
But there are a LOT of inquisitive idiots

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Imagemagick
« Reply #8 on: March 30, 2006, 06:26:20 am »

ImageMagick is a bit harder to set up, that's why we recommend to use GD when users have issues with ImageMagick, as GD comes bundled with PHP packages. Unless you have compiled your own PHP install, you should already have GD.
Logged

lombo34

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Imagemagick
« Reply #9 on: March 30, 2006, 04:27:24 pm »

I already have PHP installed and running but I can't remember what the heck I did to install it.  I can't locate what I have running, I think I may just have changed hhtpd.conf to accept and interpret php pages.  not sure though, if you can think of anything that might help, or that i should install a complete php package, please lmk asap.  like i said, i have some sort of php installed and working as i have a phpbb on my site, but i'm not sure the extent of php.

plz help
thank
Logged

lombo34

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Imagemagick
« Reply #10 on: March 30, 2006, 04:29:52 pm »

also, i isntalled GD but now it's telling me that the version of php that i have doesn't support GD, etc.  what exactly do i need to do to fix this???
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Imagemagick
« Reply #11 on: March 30, 2006, 11:11:19 pm »

you can't install GD separately from PHP - PHP has to be compiled with GD support built in, or you have to use a pre-made PHP-package. Post your server details (OS, PHP-version, packaged or self-compiled), although this is not a coppermine issue, but a matter of webserver setup that does not belong on this board. There are better places on the web to find out how to setup and run a webserver.
Logged

lombo34

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Imagemagick
« Reply #12 on: March 30, 2006, 11:58:53 pm »

understood and it's fine if you don't want to spend the time helping me on the webserver details, I just didn't know if it would matter for you to know it.  I will find the info and let you know, you can help as much as you want, any is fine with me.

Thanks, details to come tomorrow.
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.