Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Trouble w/ Batch or XP Publish  (Read 2986 times)

0 Members and 1 Guest are viewing this topic.

bcarpman

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Trouble w/ Batch or XP Publish
« on: March 24, 2006, 03:43:23 pm »

I am sorry if I am missing something stupid.  I have checked my permissions and tried everything I can find in every thread relative to this topic.

I am able to upload single photos at a time, and everything works great including thumbnails, but when I try to Batch upload I get all the way to the "adding new files to gallery" screen and all the thumbnails are red x's.  When I click on them I get "Unable to create thumbnail or reduced size image."  One the page before this, the thumbnails displayed just fine.

When I use XP Publish, it goes all the way through the process, tells me it's published the photos, but when I go to the site they are not there.

I have followed the instructions for debug mode, but this works just fine and doesn't result in any error messages at all.

If you would like me to put it back into debug mode and give you a non-admin user ID I can do that, but I'm assuming you will get no error messages just as I do.  It only happens in Batch mode.

Any suggestions?
« Last Edit: March 25, 2006, 06:50:59 pm by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Trouble w/ Batch or XP Publish
« Reply #1 on: March 24, 2006, 05:04:39 pm »

did you try switching the batch-add interface from "browsable" to "classic"?
Logged

bcarpman

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Trouble w/ Batch or XP Publish
« Reply #2 on: March 24, 2006, 07:30:21 pm »

Sorry, we found the problem.

Seems my FTP clients was showing the directories as 777 when in fact they weren't.  Not sure why, but resetting them did the trick.

Thanks
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Trouble w/ Batch or XP Publish
« Reply #3 on: March 25, 2006, 06:53:56 pm »

From the docs, FTP-App section:
Quote
FTP application
Setting the permissions using your FTP application will be the option available for most users who are webhosted. Depending on the FTP app you use, the user interface will slightly differ: some apps will allow you to enter the CHMOD command by entering the numbers (777 or 755), others will provide you with checkboxes where you can tick the permissions separately for each group. More advanced FTP apps may even provide you with both mechanisms. As this documentation can't cover all individual FTP apps that are available, the exact method might differ a bit from what you have.
Your FTP app will probably have two windows, one showing your local files, the other one showing the files on your server. In the window that shows the remote files on the server, navigate to the folder your coppermine files reside in. Highlight the "albums" folder that resides within the coppermine folder. From the context menu (right-click!), choose "properties" (might be named "chmod" or similar as well). The permissions dialog will then pop up. Choose the proper permissions as suggested above (777 or 755, depending on your server setup). If you have a checkbox that enables the permissions to propagate for all sub-folders and files, tick it. If you don't have it, nevermind. Then click "OK" on the dialog box to apply the permissions. Keep in mind that your FTP app might not have the power to actually find out about the current permissions that are applied, so you mustn't trust the information displayed in the dialog box: even if it appears that the permissions are already set as needed, this may not be the case, so you should re-apply the permissions no matter what.
After having applied the permissions for the albums folder, do the same thing for the include folder that resides within your coppermine folder.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 19 queries.