Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Upload Approval Button Gone  (Read 15382 times)

0 Members and 1 Guest are viewing this topic.

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Upload Approval Button Gone
« on: March 20, 2006, 07:46:22 am »

I am using cpg1.4.4 and have the permissions set so that users can have a private gallery but that uploads must be aprroved. Also, I have config set to email me if an upload is awaiting appoval. 

However, I am having 2 problems:
  • 1. Uploads to private galleries don't require appoval.
  • 2. There is no "Upload Approval" button.

I have made a test user, made his album visible only to him, uploaded a pic and it still doesn't require admin approval. Nor does the "Upload Approval" button show up.  The only changes I have made were made to only one theme (Hardwired), and that was just adding a couple user menu buttons.  Switching to a different them makes no difference.
« Last Edit: May 17, 2006, 09:28:18 pm by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #1 on: March 20, 2006, 04:56:10 pm »

post a link and non-admin test user account with upload privileges.
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #2 on: March 20, 2006, 06:06:14 pm »

www.clanfga.com/FGAGallery/

user: testuser
PW:  testuserpw
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #3 on: March 21, 2006, 12:44:30 am »

I have a slightly older version running on a different website and the "upload approval" button is present.  All config settings and group permissions are the same.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #4 on: March 21, 2006, 07:11:55 am »

well, it appears that you haven't enabled admin approval - the file I uploaded was visible instantly: http://www.clanfga.com/FGAGallery/displayimage.php?pos=-45
Review your groups page settings. If you think that they are correcty, but approval still doesn't work for you, post a screenshot of your groups page (attach it to your posting by using "additional options" when composing your message).
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #5 on: March 22, 2006, 02:46:57 am »

Here is screenshot of group permissions.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #6 on: March 22, 2006, 09:16:23 am »

well, I uploaded to a public album (because you allowed me to do so) - the approval setting for public albums is set to "no" in your setup, so (surprisingly ;)) my upload was visible instantly. Take a deep breath and review your settings. ::)
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #7 on: March 22, 2006, 07:33:38 pm »

Maybe I didn't make it clear. I am talking about private albums - not public.  Members who make a personal album (whether or not they make the upload private) get the pics posted immediately - without admin approval.  I believe my permissions require personal gallerys to have admin approval.  If I am doing something wrong I would sure like to know what it is. 
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #8 on: March 23, 2006, 10:27:23 am »

I can confirm that my upload to an album within the personal gallery was visible instantly: http://www.clanfga.com/FGAGallery/displayimage.php?pos=-49
Did you apply any mods?
Upgrade to cpg1.4.4
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #9 on: March 23, 2006, 06:57:20 pm »

No. Did not install any mods.  I guess I'll have to uninstall and intstall it again.  I don't want to have to constantly be checking to see what is being put in private gallerys.  I like the idea of an email when there is content waiting approval.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #10 on: March 24, 2006, 07:31:15 am »

upgrade as suggested
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #11 on: March 24, 2006, 06:50:38 pm »

Upgrade?  I am using v 1.4.4. 
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #12 on: March 25, 2006, 07:49:01 pm »

no, you're not. You're using cpg1.4.3.
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #13 on: March 25, 2006, 07:56:58 pm »

hmm, thought I applied the 1.4.4 changes.  Guess not.
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #14 on: March 25, 2006, 10:10:46 pm »

Actually, I did manually apply the "fix" mentioned here:

http://forum.coppermine-gallery.net/index.php?topic=28445.msg131584#msg131584

I am upgrading to the full version of 1.4.4 now.
Logged

Doulos

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Upload Approval Button Gone
« Reply #15 on: March 25, 2006, 10:30:44 pm »

Upgrade didn't fix the problem. Still no "upload approval" button and ppl are able to upload and view pics in personal galleries immediately.  :(
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #16 on: March 26, 2006, 02:52:28 am »

send me a PM that contains:
* a link to this thread
* an admin account
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #17 on: March 26, 2006, 10:50:26 am »

OK, I was able to replicate this issue both on your page as well as on a vanilla test gallery, so actually you have found a bug. Moving this thread to the bugs board. Please have a little patience to let the dev team figure out what is wrong.

Summary for the devs: when upload for registered users is allowed both to public and personal albums, and public upload approval is set to no, but personal gallery upload approval is set to yes, the pics uploaded to a personal gallery by that user are visible instantly without needing admin approval. Happnes both for bridged and unbridged installs.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Upload Approval Button Gone
« Reply #18 on: March 26, 2006, 12:19:41 pm »

picmgmnt.inc.php

replace
Code: [Select]
    } elseif (!$USER_DATA['pub_upl_need_approval']) {with
Code: [Select]
    } elseif (!$USER_DATA['pub_upl_need_approval'] && $category < FIRST_USER_CAT) {

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload Approval Button Gone
« Reply #19 on: March 26, 2006, 01:31:01 pm »

[slightly off topic]

@Stramm: thanks for looking into this. Please review the dev-only posting http://forum.coppermine-gallery.net/index.php?topic=9118.msg137073#msg137073 . Imo you should have CVS access to be able to commit both this fix to stable and devel branch as well as some features from your modpack into the devel branch. Please do as suggested on the above mentioned thread and start a new thread in the dev-only section to discuss what features of your modpack should go into the future core of coppermine.

[/slightly off topic]
Logged
Pages: [1] 2   Go Up
 

Page created in 0.022 seconds with 19 queries.