Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Upload problem  (Read 4089 times)

0 Members and 1 Guest are viewing this topic.

mocangiu

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Upload problem
« on: March 16, 2006, 07:16:59 am »

I have read the post on this forum an the bach upload work but i get this problem:

Parse error: parse error, unexpected T_ARRAY, expecting T_STRING in /home/vhosts/photo.orgfree.com/include/mailer.inc.php on line 2168


the debug code is:

USER:
------------------
Array
(
    [ID] => 2dbffca4c341bf7fda75b049d44b9820
    [am] => 1
    [lang] => english
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => mocangiu
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg143_filetypes; (0s)
  • [1] => select * from cpg143_plugins order by priority asc; (0s)
        [2] => delete from `47182`.cpg143_sessions where time<1142486192 and remember=0; (0s)
        [3] => delete from `47182`.cpg143_sessions where time<1141280192; (0s)
        [4] => select user_id from `47182`.cpg143_sessions where session_id=md5("551ecd16893e7887c7b09f9d0ba15267fe835c68a8a5cd6ff56d078a7f9da45e"); (0s)
        [5] => select user_id as id, user_password as password from `47182`.cpg143_users where user_id=1 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `47182`.cpg143_users AS u INNER JOIN `47182`.cpg143_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `47182`.cpg143_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg143_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg143_usergroups WHERE group_id= 1 (0s)
        [10] => update `47182`.cpg143_sessions set time='1142489792' where session_id=md5('551ecd16893e7887c7b09f9d0ba15267fe835c68a8a5cd6ff56d078a7f9da45e'); (0s)
        [11] => SELECT user_favpics FROM cpg143_favpics WHERE user_id = 1 (0s)
        [12] => DELETE FROM cpg143_banned WHERE expiry < '2006-03-16 06:16:32' (0s)
        [13] => SELECT * FROM cpg143_banned WHERE (ip_addr='81.196.196.235' OR ip_addr='81.196.196.235' OR user_id=1) AND brute_force=0 (0s)
        [14] => SELECT aid, title FROM cpg143_albums WHERE category < 10000 ORDER BY title (0s)
        [15] => SELECT aid, title FROM cpg143_albums WHERE category='10001' ORDER BY title (0s)
        [16] => DELETE FROM cpg143_temp_data WHERE timestamp < 1142486192 (0s)
        [17] => SELECT COUNT(*) FROM cpg143_pictures WHERE approved = 'NO' (0s)
        [18] => SELECT cat.name FROM cpg143_categories cat, cpg143_albums alb WHERE alb.aid='1' AND cat.cid=alb.category (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
    )

    ==========================
    VERSION INFO :
    ------------------
    PHP version: 4.4.1 - OK
    ------------------
    mySQL version: 4.0.26-standard
    ------------------
    Coppermine version: 1.4.4(stable)
    ==========================
    Module: GD
    ------------------
    GD Version: bundled (2.0.28 compatible)
    FreeType Support: 1
    FreeType Linkage: with freetype
    T1Lib Support:
    GIF Read Support: 1
    GIF Create Support: 1
    JPG Support: 1
    PNG Support: 1
    WBMP Support: 1
    XBM Support: 1
    JIS-mapped Japanese Font Support:

    ==========================
    Module: mysql
    ------------------
    module doesn't exist
    ==========================
    Module: zlib
    ------------------
    module doesn't exist
    ==========================
    Server restrictions (safe mode)?
    ------------------
    Directive | Local Value | Master Value |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
    ==========================
    email
    ------------------
    Directive | Local Value | Master Value |  |  |  |  |  |  |  |
    ==========================
    Size and Time
    ------------------
    Directive | Local Value | Master Value |  |  |  |  |  |  |  |
    ==========================
    Page generated in 0.019 seconds - 19 queries in 0 seconds - Album set : ; Meta set: ;


    can anyone helpme?
« Last Edit: March 23, 2006, 09:14:02 am by GauGau »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Upload problem
« Reply #1 on: March 16, 2006, 07:39:14 am »

Reupload a fresh copy of include/mailer.inc.php
Logged

mocangiu

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload problem
« Reply #2 on: March 16, 2006, 07:48:39 am »

I have done this!!! didn't work... any other ideea?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload problem
« Reply #3 on: March 16, 2006, 07:51:38 am »

make sure you're using the proper FTP mode, make sure your FTP client is setup correctly (to overwrite existing files on the server). To make sure, first delete include/mailer.inc.php, then upload it from a fresh coppermine package (download it from a different mirror)
Logged

mocangiu

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload problem
« Reply #4 on: March 18, 2006, 11:32:57 am »

I have done that earlyer, I founded a post here that geve a fresh copy I have downloaded that too, the problem still persist!
 Ohter sugestions?
Logged

mocangiu

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload problem
« Reply #5 on: March 18, 2006, 11:40:55 am »

Module: mysql
------------------
module doesn't exist

 may this be the problem? now after I have uploaded a new copy I can't batch upload, I did what it said on the other forum post and it worked until I have uploaded a new copy of mailer.inc.php
o and I do have mysql...
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload problem
« Reply #6 on: March 18, 2006, 01:08:11 pm »

fix the http upload first - do as I suggested and switch back to single file uploads as suggested in the upload troubleshooting section. If you get a parse error in a file that belongs to the coppermine package, then something must have happened to the file during upload to the webserver. It needs fixing - mandatorily. Don't play around in various places. If you actually didn't have mysql at all, coppermine wouldn't do anything at all except displaying an error that says it wasn't able to connect to the mysql database. As this is not the case, you don't have to worry about mysql now.

Delete the file include/mailer.inc.php, then re-upload it. Post what FTP app you are using as well.
Logged

Rdfc

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Upload problem
« Reply #7 on: March 18, 2006, 09:13:14 pm »

I thing the problem is because of the host (orgfree.com), I host my coppermine there too and I have the sames problems you got!

http://forum.coppermine-gallery.net/index.php?topic=29279.0

Maybe the solution is to move to another host   ??? ( the problem is that it is the only free one I found that support PHP and GD  :-[)
Logged

mocangiu

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload problem
« Reply #8 on: March 22, 2006, 05:23:47 pm »

You were right sow I found an other site that suports GD. and it's free.
Sow the problem is solved
Logged

Rdfc

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Upload problem
« Reply #9 on: March 23, 2006, 09:17:32 pm »

Can you tell us which is your new server?  ;D Thank you!
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.