Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Search Wildcards  (Read 7970 times)

0 Members and 1 Guest are viewing this topic.

kickme21

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Search Wildcards
« on: March 06, 2006, 04:36:17 pm »

I want to be able to search for photos that were added over a certian data over the whole bord but not put it down to a spacific name.  Is there anyway of modding the search script to search for a data range only or putting a wildcard in the name tage so it selects all.
« Last Edit: May 17, 2006, 06:30:37 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Search Wildcards
« Reply #1 on: March 06, 2006, 04:45:25 pm »

The asterisk symbol is intended to be a wildcard, but this appears to have been broken at some point. I'm moving this to the bugs board for investigation.
Logged

Nibbler

  • Guest
Re: Search Wildcards
« Reply #2 on: May 17, 2006, 06:30:19 pm »

Fixed as of svn revision 3036.
Logged

kickme21

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Search Wildcards
« Reply #3 on: May 19, 2006, 10:36:09 am »

thank you
Logged

adrianbj

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Posts: 34
Re: Search Wildcards
« Reply #4 on: July 20, 2006, 06:12:04 am »

Nibbler,

I am running 1.4.8 and I still can't use the asterisk symbol as a wildcard. I have run a version check and all my files check out as being 1.4.8 (3116). Is it possible this bug crept back in again. I know I used to be able to use an asterisk on its own in the search term to browse all images and now it doesn't display any images when I do this. I am not sure when it stopped working for me though.

I notice it is working on your demo gallery though - are you running the standard 1.4.8 distribution?

Not sure if it will help, but this is a link to my gallery: http://ian.umces.edu/imagelibrary/

Thanks,
Adrian
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Wildcards
« Reply #5 on: July 20, 2006, 07:11:59 am »

Nibbler fixed it in the subversion repository. This doesn't mean that the fix is in cpg1.4.8 - it will go into the next release though. If you need the fix, check out the subversion repository - http://svn.sourceforge.net/viewcvs.cgi/coppermine/trunk/stable/ (see instructions http://sourceforge.net/svn/?group_id=89658). Please understand that there's no support on the bugs board. The demo is running a more recent checkout from the svn.
Logged

Nibbler

  • Guest
Re: Search Wildcards
« Reply #6 on: July 20, 2006, 12:19:44 pm »

It should be in 1.4.8 since it was released after my commit. Post on the support board if you can't get it to work.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.