Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: gallery went from offline to a reset  (Read 6930 times)

0 Members and 1 Guest are viewing this topic.

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
gallery went from offline to a reset
« on: March 01, 2006, 01:40:38 am »

okay i had a problem because i made my gallery offline, but i couldn't view anypages as admin. anyway i read up on how to change back to online mode. there was this suggestion saying to go to phpmyadmin and edit the value of the config table. so i went onto my phpMyAdmin 2.7.0-pl2, clicked on cpg143_config then edited the VALUE field changing the value to '0'. Previously I believe it was '255' When I went to my gallery index page it asked me to log in but it didnt accept my username and password. also i noticed that my theme was no longer active and it was a default.

i typed in update.php and the top line update was

CREATE TABLE IF NOT EXISTS cpg143_sessions ( session_id varchar(40) NOT NULL default '', user_id int(11) default '0', time int(11) default NULL, remember int(1) default '0', PRIMARY KEY (session_id) ) TYPE=MyISAM COMMENT='Used to store sessions'

maybe that can help point out my mistake. if i could get some assistance asap that would be great. i promise myself that i will not try any funny business anymore because i realize that it backfires on me and i mess things up.

thanks again
Sam
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #1 on: March 01, 2006, 02:29:33 am »

A link would help. If it said 255 then you probably changed the db field length instead of the value.
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #2 on: March 01, 2006, 02:54:44 am »

i'll try that thanks. http://lalaine-fans.com/gallery
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #3 on: March 01, 2006, 02:57:02 am »

Yup, you screwed up your config table. Restore it from a backup or search for other posts by me that explain how to regenerate the config table.
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #4 on: March 01, 2006, 03:56:36 am »

how do you do that?
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #5 on: March 01, 2006, 04:04:12 am »

maybe this will help too
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #6 on: March 02, 2006, 12:05:46 am »

 :o
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #7 on: March 02, 2006, 12:18:56 am »

Restore your config table from a backup or search for other posts by me that explain how to regenerate the config table
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #8 on: March 02, 2006, 12:34:21 am »

i dont think i have a backup. and i searched for "regenerate config table" and didn't get any good results
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #9 on: March 02, 2006, 12:38:02 am »

Empty your config table. Then open sql/basic.sql with a text editor, replace CPG_ with cpg143_, save it and import it with phpmyadmin. That will repopulate the table.
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #10 on: March 02, 2006, 01:27:33 am »

ok i emptied and replaced. the importing is where im stuck at. i do not have that option. is it like 'insert'?

Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #11 on: March 02, 2006, 02:14:18 am »

Go to 'SQL' and either paste in the contents of the file or use the upload form.
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #12 on: March 02, 2006, 02:46:48 am »

oh yeah i uploaded basic.sql into the sql folder, but my gallery index is still default
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #13 on: March 02, 2006, 03:19:19 am »

actually now my index says

There was an error while processing a database query
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #14 on: March 02, 2006, 04:19:47 am »

Edit the config table to switch debug mode on. Click browse, look for debug_mode in the name column and set the value column to 1 for that name.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: gallery went from offline to a reset
« Reply #15 on: March 02, 2006, 07:48:32 am »

oh yeah i uploaded basic.sql into the sql folder, but my gallery index is still default
erm, you uploaded? You were meant to edit the file, copy the contents, modify as suggested and paste it into the textfield on the sql query page of phpMyAdmin. Is this what you did? This is not the same as "uploading".
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #16 on: March 02, 2006, 09:35:35 pm »

ok i foun what you were saying nibbler. okay i had the original basic.sql in the sql folder along with the uploaded new basic.sql
i had renamed the original just in case. ok i deleted the new one i uploaded and renamed the original to its proper name
next i wen to myphpadmin and clicked on browse. i had the edited the basic.sql on my computer, found the 'import' option, and used the form to import the file. so then i went to edit debug_notice and changed the value to 1.

yeah my site is still defaulted.
http://lalaine-fans.com/gallery
Logged

Nibbler

  • Guest
Re: gallery went from offline to a reset
« Reply #17 on: March 02, 2006, 09:53:05 pm »

You don't have default settings - you have *no* settings, that is the problem. Don't use import, copy/paste the lines from the file into the SQL box.
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #18 on: March 02, 2006, 10:46:20 pm »

ok done, but still no change
Logged

samo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: gallery went from offline to a reset
« Reply #19 on: March 03, 2006, 10:50:42 pm »

if i dl cpg143 again and just overwrite the basic.sql file by uploading the dl-ed one, will that screw up my database?
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 20 queries.