Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: 1 ... 15 16 17 18 [19] 20 21 22 23 ... 30   Go Down

Author Topic: Modpack with bridge support: PM, avatar, watermark, cropped/ sharpened thumbs...  (Read 1363508 times)

0 Members and 1 Guest are viewing this topic.

rongxanhnet

  • Coppermine newbie
  • Offline Offline
  • Posts: 7

Sorry about that post
I'm wrong...  :'(
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

I was looking around, and I was wondering if its possible that people on your buddy list get emails or pms when say I upload a pic, or vise versa,

no, there's no built in function for that

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Sorry about that post
I'm wrong...  :'(

OK... I was already wondering ;)

Dr Preacox

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 122
  • Is the Matrix...
    • Dynamic Creations

no, there's no built in function for that

I was wondering if you could aid me in making this :) I can probably code it but I might need some guidance, if you dont mind, if your busy dont worry about it :)

Thanxs, Sam
Logged
My Mods:
Making Memberlist Public - VIEW
Different Way of Displaying Categories - VIEW
Coming Soon - Automated Sub Domains -MOD

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

hmm... look in picmgmnt.inc.php
here I've added a part of the function for 'notification on comments'. If a user uploads a file, then he's on the 'notification' list (no emails sent before a comment). You probably can learn from that function and somewhere there add your own that just reads the buddy list and sends out emails to the posters buddies (maybe a good idea to combine it with some profile switch to enable/ disable that behaviour)
oh, how to call the mail function... for the notification on comments it's in db_input.php

Dr Preacox

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 122
  • Is the Matrix...
    • Dynamic Creations

This is working well, once I have finished and got the code debugged, I'll add it here for everyone
Logged
My Mods:
Making Memberlist Public - VIEW
Different Way of Displaying Categories - VIEW
Coming Soon - Automated Sub Domains -MOD

Steffen

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Uhm... I also can't get the watermark-feature to work, even though I tried out what was discussed here.

Situation is following:
-Installed the latest coppermine-version today, tested, worked ok.
-Installed the latest version of Stramm's mod, but after configuring the settings, realized that watermark-function doesn't work.

-I switched to english language and used both templates Stramm delivered with the mod to avoid having a non-working template
-I tried both batch upload and single/web upload, after that set the folders and images to 666, 755, 777, didn't work.
-Checked that the path to watermark.png works (chmod to 666, 777 as well), tried absolute and relative path (./images/watermark.png and /home/strato/www/ag/www.xyz.de/htdocs/zero/images/watermark.png) - yes, I'm using Strato as provider.
Means I only have GD1-support. I heard there's a possibility to use GD2 using a .htaccess-file, would this be worth a try? But it should work with GD1...
-I also checked if it's a caching problem, but there's no watermark, whatever I do.
-Tried another batch run with the admin tools, no success.

Currently, I'm clueless. Any advice what else I might try?

Also, another problem I have with the tentacle-template mod, the filmstrip and the exif data isn't displayed properly (only 1 pixel height it seems). Anyone stumbled over this bug? (I didn't change anything in the source code)

Oh and hm, if I'm allowed to ask that question here, too: On Stramm's sandbox, there's kind of a shopping cart/payment mod for purchasing pictures. Is that a public mod or a commercial one? Or asked differently; where may I obtain it? ;)
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

The watermark only works with GD2 and Image Magick. GD1 is kinda relict. Still supported by CPG but not by the modpack. That's mentioned in the first post in this thread
Quote
-Watermark (transparent) with undo possibility (GD2, ImageMagick)

Steffen

  • Coppermine newbie
  • Offline Offline
  • Posts: 2

Damn! Sorry, I somehow must have missed that somehow :(
Okay, then I'll have a look for this possibility to use GD2 on a Strato-Server. Grrr...

(Thanks for the quick reply by the way!)
Logged

tibu

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 59
    • Creative Foto Solutions

Oh and hm, if I'm allowed to ask that question here, too: On Stramm's sandbox, there's kind of a shopping cart/payment mod for purchasing pictures. Is that a public mod or a commercial one? Or asked differently; where may I obtain it? ;)

It's a plugin available to everyone, you can find it here: http://forum.coppermine-gallery.net/index.php?topic=32231.0
Logged

JCMoD

  • Guest

Im very sorry that i didnt read the whole thread ... 19 pages...

I hope my probleme wasnt told before...


I really love your modpack and the tantacle Theme is fantastic...

but as setting it up as the default theme, everytime i look it up, it has been changed to "fruity"

Whats the problem

Thx already vor your help

JCMoD
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

clear your cookie... just setting a theme as default not necessarily changes the theme for all users if they have set a valid cookie. Not modpack related though but a general coppermine behaviour

ymca

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 79

Hi Stamm,

There is a problem in the subscribtions/subscriptions.
i think that if a user uploads 10 pics & delete 9 it will show him that he has a subscription of 10
Logged

ymca

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 79

so how do i add translation for it?
For PM and buddylist no lang fallback options are available.
Same for admin and the welcome/ login box on top

The english UK / US ... better ask that on the CPG support forum, but I'd say simply cause there are differences
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Hi Stamm,

There is a problem in the subscribtions/subscriptions.
i think that if a user uploads 10 pics & delete 9 it will show him that he has a subscription of 10

can't reproduce your problem. Please try to be more specific. Tell me exactly what you're doing.
I've uploaded 5 pics and deleted 4 of them using 'edit files' next to the album I uploaded the pics into. Then I called the subscription manager and that user was subscribed to one pic... as it should be

how to translate... I've described that 2 times somewhere in this thread

ymca

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 79

i cannot delete them also...
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

can't reproduce your problem. Please try to be more specific. Tell me exactly what you're doing.

ymca

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 79

Ok...

i think i know what is the problem...
its a problem that was at the begining that no one told me how to solve & now it came back & bite me in the ass.

1) i created a test user.
2) test uploaded a pic.
3) admin approved it.
4) admin deleted the pic.
4.5) pic attach shows the problem that i think is making the new problem.
5) subscription still 1 pic.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

my bad
in delete.php find
Code: [Select]
//$query = "DELETE FROM {$CONFIG['TABLE_NOTIFY']} WHERE picture_id='$pid'";
    //$result = db_query($query);
and replace with
Code: [Select]
$query = "DELETE FROM {$CONFIG['TABLE_NOTIFY']} WHERE picture_id='$pid'";
    $result = cpg_db_query($query);

the pics that are still in the notify table and didn't get wiped out need to be removed manually
« Last Edit: June 19, 2006, 10:07:15 pm by Stramm »
Logged

docgonzo

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30

what modifications do i need to do to the theme to show Mini thumbs in film strips ?

thanks for the wonderfull mod :)

Hi there, i know it's a bit late, but i cannot seem to find the sample theme that is referred to in the answer to your post.
Could you please share how you solved it?
I'd like to use minithumbs in my theme too.
Logged
Pages: 1 ... 15 16 17 18 [19] 20 21 22 23 ... 30   Go Up
 

Page created in 0.033 seconds with 21 queries.