Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 ... 3 4 5 6 [7] 8 9 10 11 ... 30   Go Down

Author Topic: Modpack with bridge support: PM, avatar, watermark, cropped/ sharpened thumbs...  (Read 1308387 times)

0 Members and 1 Guest are viewing this topic.

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

Moving on.... problem was in config phpbb2.... i need to use localhost to see it at home... I had entered the external address... so now we can work localy and only look from the outside.. without loggin in then i mean.. SHoot... i feel someting growing.. Is it knowlegde... Naahhhhhhhh this UberNoob can't solve that mistery.

but Now where up to modtesting... realy need that watermark so test 74 comming up...  ;)
Logged
There is no such thing as strangers,
only friends we haven't met.

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

nope no watermark..

wat do you mean with absolute path... /bla bla  I don't know what that means..
my file is on my root better known for me as my localhost.... so it would be /olnev/watermark.png I guess

c:\apache2traid\httdocs\olnev\watermark.png (httdocs is my webroot)

"Hmmm the looks are already great of the mod, how will that watermark function be....:"

must be abnormaly good because I'm trying to get it alrdeady for so many hours..

keep up the good work..
Logged
There is no such thing as strangers,
only friends we haven't met.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

c:\apache2traid\httdocs\olnev\watermark.png (httdocs is my webroot)

That's the absolute path to the watermark... maybe you want to use / instead of \ if you don't get it going (but it should work with the above path). Enable the watermark, upload a testfile and smile ;)

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

@Stramm and RobbenR - I'm using relative path and it's working fine! In my configuration it's "./images/aoisora.png" being aoisora.png my watermark image I uploaded to the cpg144/images directory.

@Stramm - I completely forgot about the transparency setting on the whole image.. thinked only of the transparency color setting on export properties. Now it's working fine! :D Tks!
Logged

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

I will give it a new try Stramm.... thx so far....

do you know if you can use two dns names in one bridges combi.
now I use localhost or external ip address... need to swap for use at home.

second question: do you use one database or two databases voor de combi

 ;D
Logged
There is no such thing as strangers,
only friends we haven't met.

opulence

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46

Having a slight problem

The avatar beside a comment link is broken, I think because my site is integrated with phpbb2

the link is almost correct, everything about it is correct except the link is:

/forum//545537374441ccf5f22400.jpg

instead of

/forum/images/avatars/545537374441ccf5f22400.jpg

Is there something I can edit in displayimage.php to fix the link path?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

I will give it a new try Stramm.... thx so far....

do you know if you can use two dns names in one bridges combi.
now I use localhost or external ip address... need to swap for use at home.

second question: do you use one database or two databases voor de combi

 ;D

I'm afraid but you prolly can use only one domain name. But it's no problem to move everything and then switch
I'm using one, but it's working with two too. There's only one limitation. Use only one database user or apply the lil fix in this thread

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Having a slight problem

The avatar beside a comment link is broken, I think because my site is integrated with phpbb2

the link is almost correct, everything about it is correct except the link is:

/forum//545537374441ccf5f22400.jpg

instead of

/forum/images/avatars/545537374441ccf5f22400.jpg

Is there something I can edit in displayimage.php to fix the link path?

look in your bridge settings (run the bridge manager again), there you have to set 'images/avatars' for 'Path where avatars are stored'
(for phpbb 2.0.18+)

opulence

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 46

ahh that was it! thanks!

I'm having one last problem but im not sure if this is just coppermine related or related to your mod

Even though under the group settings I have guests set as allowed to comment, when guests leave comments, though I can see them in review comments, they don't appear under pics...

look in your bridge settings (run the bridge manager again), there you have to set 'images/avatars' for 'Path where avatars are stored'
(for phpbb 2.0.18+)
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

If anon comments do not appeare under pics then you run an older modpack. Update or apply the fix (somwhere on page 2-4)

pietervdb

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23

Hi i came across your mod pack. I have only one question:
If i am going to install the mod will it say

Powered by coppermine
Modded by Stramm

as seen at your demo page?

Thanks!
Logged

xsportseeker

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 37
    • Aoi Sora Forum

@pietervdb - Yes, at the page footer.
Logged

pietervdb

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23

@pietervdb - Yes, at the page footer.

wow thanks for the quick responce
Logged

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

Guys..... i'm about to quit....
U just can't figure it out why I can't get that watermark working.

I will list up the things i've done:

installed cpg 1.4.4
installed phpbb2
bridged them
applied the mod

turned on watermark
and watermark for custom thumbs

./olnev/watermerk.png
or
C:/apache2triad/htdocs/olnev

but nothing works..

any idea's.... ???
Logged
There is no such thing as strangers,
only friends we haven't met.

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Give me a link... without it's not that easy to help you

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

Hey Stramm.. checked yure profile en ik kan nederlands praten merk ik..

olnev.mine.nu

Logged
There is no such thing as strangers,
only friends we haven't met.

tedlow

  • Coppermine newbie
  • Offline Offline
  • Posts: 3

Yeah I am having trouble with the watermarking thing as well.  I reloaded and uploaded new pictures and it doesn't seem to work.
http://www.tedlow.com/cpg144/
I tried the relative path method too and it didn't quite work out.
I put the watermark under ./albums/tedlowWaterMark.png

Edit: Hmm I played around and it seemed that uploading the pictures work but the batch add files method doesnt.

Edit:: I think more specifically anything in the albums directory that you did a direct upload on.  I have watermarks on half my images.

Edit: No.  It has to do with batch updating.  Odd.  Cause when you do the update all images under admin tools it will apply your watermark on your old images.  Provided they were not batch updated.  Any solutions to this?
« Last Edit: March 20, 2006, 07:32:27 am by tedlow »
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

has been answered b efore. It's permission problems you have. In a standard coppemine the pics you upload don't get modified.. so they just need read permissions. When you apply a watermark the system needs write permissions too...
chmod the folder to 755 or 777. If that doesn't already work, then chmod the to batch pics to 666 (if that doesn't do the trick 755 or 777)

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

Hey Stramm.. checked yure profile en ik kan nederlands praten merk ik..

olnev.mine.nu



you can, just that others can follow it's better to write english
you've set wrong pathes to the watmark png. At least I can't find it
./olnev/watermerk.png won't work. If you use the relative path (not recommended) you don't consider the dir coppermine's located in
./watermerk.png would look for the file in the coppermine base dir
./images/watermerk.png in coppermines main image dir

absolute addressing
C:/apache2triad/htdocs/olnev/watermerk.png would look for the file in the coppermine base dir
C:/apache2triad/htdocs/olnev/images/watermerk.png ... in coppermine images dir

the solution... instead of watermerk.png (a typo)... use watermark.png
You see the difference !!!

./watermark.png
or
C:/apache2triad/htdocs/olnev/watermark.png

RobbenR

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 15

your so right stramm... let's keep it understandable for all people...

I have tried the change of name of the watermark file but without success.
I have changed te location of the watermark file but without success..
I gave all users mod rights on the album folder... no success..

BTW thx for explaining what a relative and absoluth path is.

Also i discconected the bridge to phpbb2 because that was giving me some extra problems..
Now i can focus on the gallery watermark issue which is giving me enough problems aleady.

Logged
There is no such thing as strangers,
only friends we haven't met.
Pages: 1 ... 3 4 5 6 [7] 8 9 10 11 ... 30   Go Up
 

Page created in 0.045 seconds with 21 queries.