Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: XHTML [Validation errors on login.php]  (Read 5558 times)

0 Members and 1 Guest are viewing this topic.

durley

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
XHTML [Validation errors on login.php]
« on: February 11, 2006, 07:40:25 pm »

I just downloaded and setup Coppermine 1.4 I was pleased to see the W3C logos for XHTML and CSS validation on the site. However, the index page does not validate. Even to XHTML transitional, it generates 6 errors that seem to track back to the login page. Validating to XHTML Strict generates 16 errors.

Any plans to rectify this issue or remove the logos as they are misleading.

Thanks
« Last Edit: February 20, 2006, 03:39:46 am by Nibbler »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: XHTML
« Reply #1 on: February 11, 2006, 07:49:06 pm »

I just downloaded and setup Coppermine 1.4 I was pleased to see the W3C logos for XHTML and CSS validation on the site. However, the index page does not validate. Even to XHTML transitional, it generates 6 errors that seem to track back to the login page. Validating to XHTML Strict generates 16 errors.

Any plans to rectify this issue or remove the logos as they are misleading.

Thanks
Link? If you checked our demo, the pages validate. So your own site might use something that is preventing validation. It's the gallery's admin that is responsible for validating code if they make changes that break it. If that's not possible, the gallery admin is responsible for removing the icons in Config.

It's rude to accuse people of being misleading when you don't have your facts straight.
Logged

durley

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: XHTML
« Reply #2 on: February 11, 2006, 11:54:59 pm »

Thank you for your response - albeit a bit curt. I only asked a question. Searching the forum, it seems that others have experienced validation issues too. The link is www.voc.org.uk/cp/ it is a straight install to test the functionality and evaluate to see if it meets requirements, so no changes have been made to any code at this stage.

The piece of code i referred to on login.php is:

if (!isset($_COOKIE[$CONFIG['cookie_name'] . '_data'])) {
    $cookie_warning = <<<EOT
                  <tr>
                          <td colspan="2" align="center" class="tableh2">
                        <font size="1" color="red"><b>{$lang_login_php['cookie_warning']}<b></font>
                        </td>
                  </tr>

It threw up the second <b> tag as it should be a closing </b> tag. The other errors were to do with Doc type, form tags etc. Run the validation and see for yourself.
I followed the install instructions, if you find anything i have not done correctly, i'll be pleased to know so i can put it right.
Thanks for your time
Logged

Nibbler

  • Guest
Re: XHTML [Validation errors on login.php]
« Reply #3 on: February 20, 2006, 03:39:34 am »

Fixed in cvs.
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 18 queries.