Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Coppermine 1.4.3 and ImageMagick (all the debug information included)  (Read 5299 times)

0 Members and 1 Guest are viewing this topic.

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27

Hello!
Sorry for so bothered question, but for many reasons I need to use Coppermine 1.4.3  (stable) with ImageMagick.
I've tried to search answer on my question on this forum, but unfortunately unsuccessfully.
For me the path to ImageMagick is: /usr/local/bin/ (my hoster has told me that path to installed IM), but thumbnails not generating after upload. All the debug information is accessible on this page:
http://xrays.com.ru/debug.html
I also tried to leave command line blank. Albums folder is setting to 777, and all other permissions established according to the manual.
Help me please to adjust Coppermine for work with ImageMagick.
Beforehand many thanks!

« Last Edit: February 09, 2006, 09:44:46 pm by Nibbler »
Logged

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #1 on: February 09, 2006, 12:00:46 pm »

Sorry for additional posts, please delete all other from me on this theme.
« Last Edit: February 09, 2006, 12:13:52 pm by Nad_F »
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #2 on: February 09, 2006, 02:08:58 pm »

in commandline type

which convert


post the result.

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #3 on: February 09, 2006, 08:12:49 pm »

When in command line to IM: "which convert"
Bottom notices in debug mode:

On first step:
---
/include/functions.inc.php
Warning line 2910: cannot yet handle MBCS in html_entity_decode()!
XXX
---
After upload:
/include/picmgmt.inc.php
Notice line 205: Undefined index: OS
Notice line 210: Undefined variable: retval
Warning line 210: exec() has been disabled for security reasons
Notice line 214: Undefined variable: retval
Warning line 277: chmod(): No such file or directory
Warning line 279: getimagesize(./albums/edit/preview_13023dd5.jpg): failed to open stream: No such file or directory
Warning line 282: unlink(./albums/edit/preview_13023dd5.jpg): No such file or directory
/include/functions.inc.php
Notice line 2660: Undefined variable: i

Thank you for your interest!
Logged

Nibbler

  • Guest
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #4 on: February 09, 2006, 08:15:29 pm »

Warning line 210: exec() has been disabled for security reasons

You can't use IM when exec is disabled. Either use GD2 or search the board for the passthru workaround.
Logged

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #5 on: February 09, 2006, 08:35:33 pm »

Ok, thank you!
Unfortunately "no results found"...
If I make own PHP on server can it help?
« Last Edit: February 09, 2006, 08:47:28 pm by Nad_F »
Logged

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #7 on: February 09, 2006, 09:20:35 pm »

Unfortunately in my case it doesn't help:((((((

Warning line 210: passthru() has been disabled for security reasons

I need to make own PHP.
« Last Edit: February 09, 2006, 11:29:20 pm by Nad_F »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #8 on: February 10, 2006, 12:47:02 am »

Sorry for additional posts, please delete all other from me on this theme.
Don't render a thread useless by editing out previous postings >:(!
Logged

Nad_F

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 27
Re: Coppermine 1.4.3 and ImageMagick (all the debug information included)
« Reply #9 on: February 12, 2006, 11:08:17 am »

I've make own PHP-interpreter on the server and now Coppermine and ImageMagick work perfectly! Big thanks to all Coppermine developers!!!
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 19 queries.