Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: uploading problems, no thumbnails created  (Read 5129 times)

0 Members and 1 Guest are viewing this topic.

tricoven

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
uploading problems, no thumbnails created
« on: February 06, 2006, 05:47:31 am »

I've searched this board for similar problems, and there are a lot of solutions, but none of them solved my problem.

I have a similar problem in batch-add:
Warning: getimagesize(albums/insider2/thumb_brianDepart_01.jpg): failed to open stream: Permission denied in /home/virtual/site53/fst/var/www/html/gallery/include/picmgmt.inc.php  on line 230
Unable to create thumbnail or reduced size image.

1.  I did the troubleshooting process, and the debug is available below.  Below is the error I get in browser upload:

The file you have uploaded is not a valid image !
File: /home/virtual/site53/fst/var/www/html/gallery/db_input.php - Line: 282


Warning: getimagesize(albums/userpics/ym09.jpg): failed to open stream: Permission denied in /home/virtual/site53/fst/var/www/html/gallery/db_input.php on line 278

2. All folders are of 777 permissions, I even reset it and then tried to have it at 755 and still the same problem.
3. This doesn't work for me: http://forum.coppermine-gallery.net/index.php?topic=23342.0
4. And the one adding silly safe mode in config.inc.php is that I already have it and still no development.

I'm sorry, I know there has been a lot of topics like this, the solutions u gave worked in those said users but unfortunately for me, every single one of them does not apply. :(

URL of gallery:
http://www.alyssamilano.ws/gallery

user: testing
pass: user


USER:
------------------
Array
(
    [ID] => 60abfffd4c82c63d1264dd7c6eb384b7
    [am] => 1
    [liv] => Array
        (
           
  • => 4761
  • [1] => 1761
            )

       
[lap] => 2
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_group] => 1
    [user_active] => YES
    [user_name] => tricoven
    [user_password] => ********
    [user_lastvisit] => 2006-02-03 02:01:27
    [user_regdate] => 2005-08-05 10:45:14
    [user_group_list] =>
    [user_email] =>
    [user_website] => http://www.alyssamilano.ws
    [user_location] => Philippines
    [user_interests] => Charmed, Alyssa Milano, drawing, X-Men, Memories of Bali, graphics/website designing, Jasmine Trias, and a whole lot more.
    [user_occupation] =>
    [user_actkey] =>
    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
    [groups] => Array
        (
            [1] => 1
        )

)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content FROM cpg133_filetypes;
  • [1] => SELECT * FROM cpg133_users WHERE user_id='1'AND user_active = 'YES' AND user_password != '' AND BINARY MD5(user_password) = 'aae93c994bd9f81ea4f55ced07e494f3'
        [2] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg133_usergroups WHERE group_id in (1)
        [3] => SELECT group_name FROM  cpg133_usergroups WHERE group_id= 1
        [4] => DELETE FROM cpg133_banned WHERE expiry < '2006-02-04 01:14:36'
        [5] => SELECT * FROM cpg133_banned WHERE ip_addr='203.177.161.100' OR ip_addr='192.168.2.236' OR user_id=1
        [6] => SELECT category FROM cpg133_albums WHERE aid='89'
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[album] => 89
    [MAX_FILE_SIZE] => 5120000
    [title] =>
    [caption] =>
    [keywords] =>
    [event] => picture
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.1 - OK
------------------
mySQL version: 4.0.24-standard
------------------
Coppermine version: 1.3.3
==========================
Module: gd
------------------
GD Support enabled
GD Version bundled (2.0.28 compatible)
FreeType Support enabled
FreeType Linkage with freetype
GIF Read Support enabled
GIF Create Support enabled
JPG Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled
==========================
Module: mysql
------------------
Active Persistent Links 0
Active Links 1
Client API version 3.23.58
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/php/includes:/usr/share/php | .:/php/includes:/usr/share/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 60 | 60
max_input_time | 60 | 60
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 3.026 seconds - 7 queries in 0.001 seconds - Album set :




let me know what things u need!
thanks in advance! :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: uploading problems, no thumbnails created
« Reply #1 on: February 06, 2006, 09:18:21 am »

Don't post debug_output unless requested. Instead, do as suggested in the upload troubleshooting tutorial.
Logged

tricoven

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: uploading problems, no thumbnails created
« Reply #2 on: February 06, 2006, 12:06:24 pm »

I've already did that, and the error is always like this:

The file you have uploaded is not a valid image !
File: /home/virtual/site53/fst/var/www/html/gallery/db_input.php - Line: 282


Warning: getimagesize(albums/userpics/ym09.jpg): failed to open stream: Permission denied in /home/virtual/site53/fst/var/www/html/gallery/db_input.php on line 278

and the debug is the one i posted just in case.
Logged

Nibbler

  • Guest
Re: uploading problems, no thumbnails created
« Reply #3 on: February 06, 2006, 02:24:52 pm »

Please please please follow those instructions, we can't help you if you don't.
Logged

tricoven

  • Coppermine newbie
  • Offline Offline
  • Posts: 15
Re: uploading problems, no thumbnails created
« Reply #4 on: February 07, 2006, 05:08:41 am »

Done!  Sorry... ;)
It has debug enabled now...

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: uploading problems, no thumbnails created
« Reply #5 on: February 07, 2006, 07:09:59 am »

Make sure to CHMOD the albums folder and everything within it as suggested in the docs - the user the webserver runs under needs write permissions. If you're not sure, ask your webhost for support.
Logged
Pages: [1]   Go Up
 

Page created in 0.026 seconds with 19 queries.