Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Upload - Duplicate files/Deleted files?  (Read 6266 times)

0 Members and 1 Guest are viewing this topic.

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Batch Upload - Duplicate files/Deleted files?
« on: January 20, 2006, 02:10:13 am »

Originally I was searching as to why suddenly Coppermine declared all files in a folder to be new, when only one file was new. For example, my Miscellaneous album has 41 files, I FTP'd just one into the folder, select Batch Add, and yet all 42 files are listed as being New.

As it turns out, the problem seems to be something else entirely, as now when I click on any previously uploaded file in albums, it's just blank - only AFTER I attempt to Batch Add into that folder!

http://www.thefotohut.com/pictures

Right now the albums that are "blank" are
http://www.thefotohut.com/pictures/thumbnails.php?album=5: Family - where I added two new photos via FTP but it still showed images fine until I went to Batch Add, where it selected all files as "New". I backed the hell out of there fast without letting it add everything again to the folder as a duplicate, however by even entering Batch Add for that file folder, the gallery denies the pictures in the album exist now.

http://www.thefotohut.com/pictures/thumbnails.php?album=11: Sports - ZERO new uploads, all pictures worked fine until I went into Batch Add, where everything was marked new again.

http://www.thefotohut.com/pictures/thumbnails.php?album=12: Miscellaneous - I entered debugging mode, as per the Upload Troubleshooting directions, changed the Group settings and uploaded a new picture via the Gallery, where it worked fine. But then the rest of the pictures in the album went blank. The final picture in the gallery that I just uploaded still works fine, everything else is gone.


I have a user set up:
Login: test
PW: test

Debugging mode is on, I can upload a single file and it will still be valid in the album, however all previously uploaded files then become blank. If you want to play with that, feel free. It's fun, it's different, it's enough to drive you nuts! In FTP and my CPanel File Manager, ALL the photos are still there, Batch Add says they're all there (and new!).

If you'd like admin access, let me know and I will give it. At this rate, I'll have to delete and remake the entire gallery anyway, I'd like someone to be able to go in and play with this and demonstrate I'm not losing my mind!

I upgraded to the latest version some while ago, this was all working fine until now. I haven't been in the gallery code at all since the upgrade/reinstall.


Modified to add: in checking my other galleries, they are ALL doing this. Files are perfectly fine until I enter Batch Add, then all files previously uploaded are marked as being New. Upon backing out (not adding) and returning to the folder, previously uploaded files are now blank.
« Last Edit: February 03, 2006, 05:23:36 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #1 on: January 20, 2006, 07:38:39 am »

not sure if this will fix your issue, but as a first step, you should upgrade to the most recent stable version cpg1.4.3
Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #2 on: January 30, 2006, 12:44:21 am »

OK, because I have so many galleries and the one cited above has THE most photos, I decided to upgrade my smallest, private gallery first and come back to use as an example for help. Since I upgraded, it's still an issue.

Gallery: http://m3.thefotohut.com/

I unlocked a few of the less offensive albums to demonstrate with.

You can see when the last files were uploaded, obviously.



The problem: Files with spaces in file name that were previously uploaded are now not showing up when clicking on thumbnail.


Further Explanation:

Files with spaces in file name that were uploaded recently into their own, NEW albums, are converted to underscore file names and are fine.

Files with spaces in file name that were uploaded recently into EXISTING albums, however, then renders the entire album non-viewable.

Batch Add screen triggers the gallery to realize that the old file names are wrong, and stop displaying the album as is, as well as listing all files in gallery (old or new) as being NEW and ready to upload.

Proceeding with Batch Add of "non-new" files doubles thumbnails in album, rendering first set of thumbnails clickable to invisible image (black square) while second set of thumbnails is new, underscored files.


The Horum album shows these blank squares of files because I did the third sentence up there, not uploading anything new into the gallery but clicking on Batch Add just as a test. It checked all existing files as "new" to be added, and when I backed out of it and returned to Horum album, all files were listed as blank.

If you'd like to upload a file to Print screen as a test, I established the test username and password.



The solution I need:

How to convert old, uploaded files to "new" system without deleting everything and batch adding existing files again? The files already exist, the call address is simply wrong now. Help?   
Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #3 on: January 31, 2006, 05:54:45 pm »

Eh, I'm up early for some ungodly reason and thought I'd bump this to see if anyone knows anything....
Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #4 on: February 02, 2006, 12:22:45 am »

 ???

C'mon, you guys can close and move all kinds of questions around, what about a little "We don't know" or "We're looking into it" or even "Have you searched the forums?" (yes). Anything?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #5 on: February 02, 2006, 01:10:57 am »

I would think you would know this by now: http://coppermine-gallery.net/demo/cpg14x/docs/faq.htm#lamesupport

No need to nag.
Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #6 on: February 02, 2006, 08:08:42 am »

No, I read it and I'm used to you guys, I just figured it was something I considered important and that even a simple "Hey, screw off" would be better than still waiting for ANY type of response like "More info" or "Wrong forum" or whatever, when I can have already switched to another gallery system and be back in business.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #7 on: February 02, 2006, 09:00:51 am »

If you need to hear it: "I don't know". Is this the answer you have been looking for? Maybe I should add "You shouldn't have uploaded pics that contain spaces in the filename in the first place" if that makes you feel better... ::)
Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #8 on: February 02, 2006, 09:58:57 pm »

Yes, any reply is good, thanks.

Logged

M3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 40
Re: Batch Upload - Duplicate files/Deleted files?
« Reply #9 on: February 02, 2006, 11:58:14 pm »

Just in case anyone comes across this same problem, I'll explain how to fix it (you might want to mark the thread "Solved"?)

- Click the Batch Add button for each album you have. Do NOT allow the files to batch add yet though! It will list all files as being "New" and thus uploadable.  Hit the Back Button. Do this for EVERY album.

- In your gallery, click the "Edit Files" tab next to each album

- Let all the thumbs load (very important) then click the "Delete All Files" button at the top of the screen, scroll to the bottom and click "Apply Modifications". If you don't let all the thumbs load first, it won't put a check in every box, just the visible thumbs and you may end up "deleting" the same file four times.

- Once all old files are deleted, go back into Batch Add and complete the Batch Adding. It'll put the updated file name files in the albums.


Why this works is the same reason why it screws up in the first place.... Batch Add updates the file names in your folders FOR you. So while it renders your old albums pretty useless because it updates the file names, it also keeps the "Delete All Files" from deleting ANYTHING out of the folders. It can't delete what no longer exists, but it does clear out the album of all the defunct old links.

et voila
Logged
Pages: [1]   Go Up
 

Page created in 0.053 seconds with 19 queries.