Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: viewlog.php -> template error  (Read 8139 times)

0 Members and 1 Guest are viewing this topic.

slamp

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
    • Baby's gallery
viewlog.php -> template error
« on: January 08, 2006, 09:03:48 pm »

Hello,

if an anonymous user try to access directly viewlog.php it will get an error:
Code: [Select]
Template error
Failed to find block 'admin_approval'(#(<!-- BEGIN admin_approval -->)(.*?)(<!-- END admin_approval -->)#s) in :
[...]
Example: http://coppermine-gallery.net/demo/cpg14x/viewlog.php
« Last Edit: February 14, 2006, 11:14:35 pm by Nibbler »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: viewlog.php -> template error
« Reply #1 on: January 08, 2006, 09:26:10 pm »

Strange... my installation behaves correctly. It shows the critical error message:
You don't have permission to access this page.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: viewlog.php -> template error
« Reply #2 on: January 09, 2006, 08:51:19 am »

did you upgrade or do a fresh install? If you upgraded, you'll need to update your custom theme as suggested.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: viewlog.php -> template error
« Reply #3 on: January 09, 2006, 03:23:59 pm »

The thing is that link goes to our demo, and the error occurs with the classic theme...
Logged

slamp

  • Coppermine newbie
  • Offline Offline
  • Posts: 13
    • Baby's gallery
Re: viewlog.php -> template error
« Reply #4 on: January 09, 2006, 09:12:36 pm »

The thing is that link goes to our demo, and the error occurs with the classic theme...
Exactly. In fact I found the problem on my gallery < http://daury.net/galerie/viewlog.php >, but as the problem occured on the demo gallery, I prefered to post the demo link.
Logged

soro

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: viewlog.php -> template error
« Reply #5 on: February 14, 2006, 11:03:24 pm »

Any news on this one? Same happens with direct hit on thumbnails.php, without parameters. Computer never logged in, no cookies set. Again, the link to your demo site:

http://coppermine-gallery.net/demo/cpg14x/thumbnails.php

Same error as on my site.  :-\
Logged

Nibbler

  • Guest
Re: viewlog.php -> template error
« Reply #6 on: February 14, 2006, 11:15:03 pm »

Dupe of already fixed http://forum.coppermine-gallery.net/index.php?topic=24295.0 tagging as invalid.
Logged

soro

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: viewlog.php -> template error
« Reply #7 on: February 15, 2006, 05:23:08 am »

That solution prevents the text output of the Admin Menu table, it does not fix the Template error. At least if I've understood your fix correctly, Nibbler. Talking about the one with the additional code in themes.inc.php. I'm still getting:

Quote
Template error
Failed to find block 'admin_approval'(#(<!-- BEGIN admin_approval -->)(.*?)(<!-- END admin_approval -->)#s) in :

and this time on the entire system, it seems.

Also, please note that this is not about failing to find block 'log_ecards'. I'm probably missing something, but I'm pretty sure I've extensively used search functions, and this seemed to be the thread most immediately relevant.

Sorry if I'm transgressing the etiquettes of this forum. Please disregard if you find it invalid.
« Last Edit: February 15, 2006, 05:34:47 am by soro »
Logged

Nibbler

  • Guest
Re: viewlog.php -> template error
« Reply #8 on: February 15, 2006, 11:41:35 am »

Disable logging of ecards in config and you will get exactly the same error message as in that thread. The fix does not involve additional code, it involves moving code from one place to another.
Logged

soro

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 22
Re: viewlog.php -> template error
« Reply #9 on: February 15, 2006, 05:02:59 pm »

Ok, that works. Many thanks for swift reaction, and sorry I didn't understand your fix at first.
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 18 queries.