Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: spoke to soon (Warning your browser does not accept script's cookies problem)  (Read 5645 times)

0 Members and 1 Guest are viewing this topic.

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

well, as I mentioned in a previous thread. I was getting this error.

============
here's my home setup

internet  <---> adsl modem <--> freebsd firewall/gateway <--> windows PCs

FreeBSD is running Apache22, PHP 5.1.1 and MySQL 4.1.16. I'm using the latest CPG which I believe is 1.4.3.
==============

I checked from work if I can logged in and I do not get the "Warning your browser does not accept script's cookies" message. But I was getting it from my windows PC which is inside my home network.

So thinking it could be some misconfiguration in Windows, I decided to reinstall Windows from scratch. The problem is that I'm still getting the error. I have changed the cookie configuration in IE to accept all cookies and I still get the problem.

Could there be a setting somewhere to make it work?

I have to add that my home network setup has been in existent for several months now and it was working beautifully. It's only recently that I have been getting this "Warning your browser does not accept script's cookies" problem when logging in from inside the home network.

Thank you for the help.
« Last Edit: January 05, 2006, 01:01:20 pm by jarthel »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de

do you only get the warning or are you actually not able to log in?
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

do you only get the warning or are you actually not able to log in?

If I put my correct username and password, CPG will say "Welcome username" to indicate that my info was verified successfully. It will then take me to the index page where I will see the login link again. I know that if I'm able to login successfully, I get new set of links in the index page.
===============
As I know PHP, I did some tracing.

The index page will successfully call "setcookie" function (the function returned true). According to PHP manual:
=======
Once the cookies have been set, they can be accessed on the next page load with the $_COOKIE or $HTTP_COOKIE_VARS arrays. Note, autoglobals such as $_COOKIE became available in PHP 4.1.0. $HTTP_COOKIE_VARS has existed since PHP 3. Cookie values also exist in $_REQUEST.
========
So when I clicked the login link, the cookies should be set (according to the PHP manual). I then add some code in login.php to display $_COOKIE (via print_r function call) and it displays an empty array.
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149

Have you modified any of the source files?
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Have you modified any of the source files?

The only changes I made are inserting numerous echo/print_r statements to track down the problem. I have removed them since.
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

I just tried loggin in from work and I can login successfully. My username/password was verified. Then, I was returned to the index page and I get new set of links (the login link in the index page has disappeared).
Logged

ecto

  • Supporter
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 144
    • My very incomplete gallery

When you're at home, have you tried logging in with a different browser than IE (e.g. Opera or Firefox)? Just to make sure the issue is/isn't browser-related.
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

When you're at home, have you tried logging in with a different browser than IE (e.g. Opera or Firefox)? Just to make sure the issue is/isn't browser-related.

I'll try that when I get home. thanks

ps. I forgot to include that when I tried logging in from work, I was using mozilla and IE. and I didn't habe any problems logging in using both browsers.
Logged

Abbas Ali

  • Administrator
  • Coppermine addict
  • *****
  • Country: in
  • Offline Offline
  • Gender: Male
  • Posts: 2165
  • Spread the PHP Web
    • Ranium Systems

Also note the full URLs in the address bar of the browser before you login (i.e on login.php page) and when you get redirected to index page after login (i.e. index.php page).
Logged
Chief Geek at Ranium Systems

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

Also note the full URLs in the address bar of the browser before you login (i.e on login.php page) and when you get redirected to index page after login (i.e. index.php page).

this is URL for the login page as displayed in the address bar (IE) = http://sakaki_nic3:19998/coppermine/login.php?referer=index.php

After logging in and redirected back to the index page, this is the URL as displayed in the address bar (IE) = http://sakaki_nic3:19998/coppermine/index.php
« Last Edit: January 06, 2006, 12:29:37 pm by jarthel »
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

thinking it could be a misconfiguration in my coppermine, I decided to trash the current one. i drop and recreated the database and deleted all the files and used the files from the zip download.

I then proceeded to install it like it's a brand new install and I was successful. The problem again is that my browser is rejecting cookies.

I'm downloading mozilla now so I'll try that next. :(
Logged

jarthel

  • Coppermine newbie
  • Offline Offline
  • Posts: 13

hmm seems to be browser related. no problems at all logging in using firefox.

as i mentioned above, i have "accept all cookies" set in IE.
Logged

ecto

  • Supporter
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 144
    • My very incomplete gallery

Might have something to do with you using some kind of alias ("sakaki_nic3") instead of the real URL? Some kind of security/zone setting in IE perhaps. Have you tried using the real address?
Logged
Pages: [1]   Go Up
 

Page created in 0.082 seconds with 20 queries.