Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Error when registering new user  (Read 4417 times)

0 Members and 1 Guest are viewing this topic.

emsbear

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Error when registering new user
« on: January 02, 2006, 05:35:15 pm »

I'm on 1.4.2 via Fantaisico and when a new user registers they get the following error....

Template error
Failed to find block 'log_ecards'(#(<!-- BEGIN log_ecards -->)(.*?)(<!-- END log_ecards -->)#s) in :

                <div align="center">
                <table cellpadding="0" cellspacing="1">
                        <tr>

                                <td class="admin_menu"><a href="admin.php" title="{ADMIN_TITLE}">{ADMIN_LNK}</a></td>
                                <td class="admin_menu"><a href="catmgr.php" title="{CATEGORIES_TITLE}">{CATEGORIES_LNK}</a></td>
                                <td class="admin_menu"><a href="albmgr.php{CATL}" title="{ALBUMS_TITLE}">{ALBUMS_LNK}</a></td>
                                <td class="admin_menu"><a href="groupmgr.php" title="{GROUPS_TITLE}">{GROUPS_LNK}</a></td>
                                <td class="admin_menu"><a href="usermgr.php" title="{USERS_TITLE}">{USERS_LNK}</a></td>
                                <td class="admin_menu"><a href="banning.php" title="{BAN_TITLE}">{BAN_LNK}</a></td>
                                <td class="admin_menu"><a href="reviewcom.php" title="{COMMENTS_TITLE}">{COMMENTS_LNK}</a></td>

                                <td class="admin_menu"><a href="picmgr.php" title="{PICTURES_TITLE}">{PICTURES_LNK}</a></td>
                                <td class="admin_menu"><a href="searchnew.php" title="{SEARCHNEW_TITLE}">{SEARCHNEW_LNK}</a></td>
                                <td class="admin_menu"><a href="util.php" title="{UTIL_TITLE}">{UTIL_LNK}</a></td>
                                <td class="admin_menu"><a href="profile.php?op=edit_profile" title="{MY_PROF_TITLE}">{MY_PROF_LNK}</a></td>
<!-- BEGIN documentation -->
                                <td class="admin_menu"><a href="{DOCUMENTATION_HREF}" title="{DOCUMENTATION_TITLE}" target="cpg_documentation">{DOCUMENTATION_LNK}</a></td>
<!-- END documentation -->
                        </tr>
                </table>
                </div>

---------------------------------------
Link to gallery
http://www.fansofjohngoodman.com/Gallery/login.php

I don't program so I'm fairly lost going through PHP code.  I can log in as admin and see the site fine.  I was running for quite a while on 1.3.x with no problems at all now after upgrading to 1.4.2 I get this.....any clues?

« Last Edit: January 02, 2006, 07:48:04 pm by Nibbler »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Error when registering new user
« Reply #1 on: January 02, 2006, 05:55:20 pm »

You need to upgrade your theme. Please read the doc, link available at top of this page.
Logged

emsbear

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Error when registering new user
« Reply #2 on: January 02, 2006, 06:04:08 pm »

Even if I'm only using the default theme with no modifications?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Error when registering new user
« Reply #3 on: January 02, 2006, 06:11:38 pm »

Oh, okay, different issue: http://forum.coppermine-gallery.net/index.php?topic=24295.0

If you don't understand the fix, download the latest version of the file here: http://cvs.sourceforge.net/viewcvs.py/coppermine/stable/include/themes.inc.php
Logged

emsbear

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Error when registering new user
« Reply #4 on: January 02, 2006, 06:22:36 pm »

made the changes and the error chaged to "There was an error while processing a database query  "
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Error when registering new user
« Reply #5 on: January 02, 2006, 06:29:19 pm »

Could you please read the docs on doing an upgrade to 1.4.3, and not use Fantastico? We don't know what they did to the code so we can't provide in-depth support for it. Not that our code is always flawless, but we can't troubleshoot an issue caused by Fantastico without access to its code, so we need to eliminate that confound.
Logged

Nibbler

  • Guest
Re: Error when registering new user
« Reply #6 on: January 02, 2006, 06:41:17 pm »

Enable debug mode in config and search the board for the mysql error message you receive.
Logged

emsbear

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Error when registering new user
« Reply #7 on: January 02, 2006, 07:35:41 pm »

This is the debug data:
----------------------

While executing query "INSERT INTO cpg_users (user_regdate, user_active, user_actkey, user_name, user_password, user_email, user_profile1, user_profile2, user_profile3, user_profile4, user_profile5, user_profile6) VALUES (NOW(), 'YES', '', 'test33', 'test', 'testing@testing.com', '', '', '', '', '', '')" on 0

mySQL error: Unknown column 'user_profile1' in 'field list'
------------------------

raw data it attached
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Logged

Nibbler

  • Guest
Re: Error when registering new user
« Reply #9 on: January 02, 2006, 07:42:55 pm »

You hadn't run update.php. I have run it for you.
Logged

emsbear

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Error when registering new user
« Reply #10 on: January 02, 2006, 07:47:25 pm »

Thank you very much...it's working perfect now.  I really tried looking through all the forums first before posting the request.

Thank again.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.