Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: DATE PROBLEM  (Read 2575 times)

0 Members and 1 Guest are viewing this topic.

altenae

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 234
DATE PROBLEM
« on: December 27, 2005, 08:45:18 pm »

Hi all,

I have a quetion/problem:

I try to understand how this program works and  i don't understand one things.When i use the program in french or English mode i have the date format without the day.
I only have Dec 2005 for example without 27.Is it a bug or you had the same??? In American or every others language it works properly.

How can I make this work with the french language.

Stephane
Logged

Nibbler

  • Guest
Re: DATE PROBLEM
« Reply #1 on: December 27, 2005, 08:57:15 pm »

Look in the language file you are using and adjust the date formats to suit

Code: [Select]
// The various date formats
// See http://www.php.net/manual/en/function.strftime.php to define the variable below
$album_date_fmt =  '%e %B %Y';
$lastcom_date_fmt =  '%d/%m/%y %H:%M';
$lastup_date_fmt = '%e %B %Y';
$register_date_fmt = '%e %B %Y';
$lasthit_date_fmt = ' %a %e %B %Y %H:%M';
$comment_date_fmt =  '%a %e %B %Y %H:%M';
$log_date_fmt = '%B %d, %Y at %I:%M %p'; //cpg1.4
Logged

ecto

  • Supporter
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 144
    • My very incomplete gallery
Re: DATE PROBLEM
« Reply #2 on: December 27, 2005, 09:06:36 pm »

Since all date strings in both english.php and french.php should show the day of month and neither %d nor %e (if altenae is using the unmodified 1.4.2 language files) is showing, maybe this problem is related to a PHP setting and not the language file?

I came to think of this as my gallery won't show %e, but it does show %d. Unfortunately I haven't looked into the problem yet.
Logged

Nibbler

  • Guest
Re: DATE PROBLEM
« Reply #3 on: December 27, 2005, 09:22:15 pm »

According to the manual some specifiers may not work on windows. If you are using windows you can change it to something that is supported. Check the link in the code given above.
Logged

ecto

  • Supporter
  • Coppermine frequent poster
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 144
    • My very incomplete gallery
Re: DATE PROBLEM
« Reply #4 on: December 27, 2005, 10:00:28 pm »

And I thought I had read through that strftime page.. I must have missed that note at the end. Thanks Nibbler! Hopefully this can be of some help to altenae.

"This means that e.g. %e, %T, %R and %D (there might be more) and dates prior to Jan 1, 1970 will not work on Windows, some Linux distributions, and a few other operating systems."
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.