Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Permissions stuck at 755  (Read 5044 times)

0 Members and 1 Guest are viewing this topic.

kehbop

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Permissions stuck at 755
« on: December 14, 2005, 07:34:12 am »

I'm not sure where to post this.

I need to upload files to the folders inside the albums/userpics directory. I can't because of the permissions. I can't change the permissions with my FTP either (dreamweaver) because it keeps saying set access properties failed.

I don't know if this is my FTP or something on Coppermine not allowing me to change it. Any help?  ???
« Last Edit: December 20, 2005, 09:26:14 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Permissions stuck at 755
« Reply #1 on: December 14, 2005, 07:43:20 am »

no chance for us to tell what is wrong. However I should warn you: you mustn't FTP-upload into the userpics folder unless you really, really know what you're doing. Dreamweaver is not a FTP app, although it might contain an embedded FTP upload client.
Ask your webhost for support on this.
Logged

kehbop

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: Permissions stuck at 755
« Reply #2 on: December 14, 2005, 09:00:58 pm »

I went onto my servers webFTP and I still couldn't change it or upload files.

I'm 90% sure that coppermine is forcing it to be a 755 permission. Is there a way to change that?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Permissions stuck at 755
« Reply #3 on: December 16, 2005, 10:59:52 am »

not sure what the actual question is. Ask your webhost for support.
Logged

kehbop

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: Permissions stuck at 755
« Reply #4 on: December 16, 2005, 08:49:30 pm »

aww. Its not easy to contact them.

Basically, I want coppermine to stop making folders that are 755 in the userpics. I want them to be 777. (it creates a new folder for every user that uploads picture)

So my question is how do I make coppermine make new folders in 777 rather than the 755 it's making it?

PS: my other post that you made a double post started on a different topic. It just ended up that the root of the problem ended up being the same.
Logged

Nibbler

  • Guest
Re: Permissions stuck at 755
« Reply #5 on: December 16, 2005, 08:51:32 pm »

It should be using the 'Default mode for directories' option in config when creating subdirectories in userpics.
Logged

kehbop

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: Permissions stuck at 755
« Reply #6 on: December 19, 2005, 04:15:06 am »

Hey I didn't see that before! Thanks Nibbler!

Thank all you guys for doing such a good job with the forum here.

I just have one more related problem. I have a few folders with the 755 already on it and they are so locked in that position that I can't even delete them. How can I change them to 777?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Permissions stuck at 755
« Reply #7 on: December 19, 2005, 09:18:36 am »

use your FTP app or whatever method your webhost allows you to CHMOD. If this doesn't work for you, ask your webhost for support - they may have to CHOWN the folders for you as well.
Logged

kehbop

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 52
Re: Permissions stuck at 755
« Reply #8 on: December 20, 2005, 03:52:38 am »

Yeah, I ended up having to rename the folders. Copying the files to my hard drive and then reuploading them to a folder I created with the original name. I'm not sure why Coppermine is so possessive of the permissions it creates.

Anyways, it's solved. Thanks!
Logged
Pages: [1]   Go Up
 

Page created in 0.029 seconds with 20 queries.