Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Re: CPG1.4.2 released as stable - bug in e-mail encoding  (Read 4237 times)

0 Members and 1 Guest are viewing this topic.

gaborsoha

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 3
    • Moha honlapja (Hungarian)
Re: CPG1.4.2 released as stable - bug in e-mail encoding
« on: December 17, 2005, 11:47:39 am »

Hello,

I have found a bug in sending e-card. The encode settings for the gallery is utf-8. When sendig an e-card, the special caraters seems OK in the browswer. But the recepient can not read it.

The solution:
change the following in include/mailer.inc.php line 125.
    var $CharSet           = "utf-8";       // it was "iso-8859-1"
(the best woulld be to use the encoding of the e-card form to make sure characters will look the same as it filled)


PS. The reason to write it here is I can not open a new topic  ???
« Last Edit: December 20, 2005, 03:57:29 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Re: CPG1.4.2 released as stable - bug in e-mail encoding
« Reply #1 on: December 20, 2005, 03:57:05 pm »

Already fixed.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: CPG1.4.2 released as stable - bug in e-mail encoding
« Reply #2 on: December 21, 2005, 08:59:02 am »

PS. The reason to write it here is I can not open a new topic  ???
Read the sticky thread to find out why. Of course regular users can't start new threads on the announcement board, that's why the support board exists. ::)
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 18 queries.